summaryrefslogtreecommitdiff
path: root/games-rpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /games-rpg
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/Manifest.gzbin8116 -> 8803 bytes
-rw-r--r--games-rpg/asphyxia/Manifest3
-rw-r--r--games-rpg/asphyxia/asphyxia-1.0.ebuild42
-rw-r--r--games-rpg/asphyxia/metadata.xml8
-rw-r--r--games-rpg/hatoful-boyfriend-holiday-star/Manifest3
-rw-r--r--games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild60
-rw-r--r--games-rpg/hatoful-boyfriend-holiday-star/metadata.xml11
-rw-r--r--games-rpg/hatoful-boyfriend/Manifest2
-rw-r--r--games-rpg/hatoful-boyfriend/hatoful-boyfriend-0-r1.ebuild2
-rw-r--r--games-rpg/sakura-spirit/Manifest3
-rw-r--r--games-rpg/sakura-spirit/metadata.xml8
-rw-r--r--games-rpg/sakura-spirit/sakura-spirit-0.ebuild41
-rw-r--r--games-rpg/the-royal-trap/Manifest3
-rw-r--r--games-rpg/the-royal-trap/metadata.xml18
-rw-r--r--games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild41
15 files changed, 243 insertions, 2 deletions
diff --git a/games-rpg/Manifest.gz b/games-rpg/Manifest.gz
index 369b01d72af0..b83140c38cd5 100644
--- a/games-rpg/Manifest.gz
+++ b/games-rpg/Manifest.gz
Binary files differ
diff --git a/games-rpg/asphyxia/Manifest b/games-rpg/asphyxia/Manifest
new file mode 100644
index 000000000000..0ae33dbea0df
--- /dev/null
+++ b/games-rpg/asphyxia/Manifest
@@ -0,0 +1,3 @@
+DIST Asphyxia-1.0-linux.tar 282880294 BLAKE2B cb27797413238c2e828232d46626889379ee8e9b10bc224812215e811927f50d640d520a3c399d3b58da12a5d6e6957020f89c70629c037f5334e8dca8706ba5 SHA512 9e28fe4b961a03b89b717589d7ba223374dfa12710a1f101b61c913a50dc750a6c2c8733d9b312001c92b6eeb58903028eec8e7a0b62de3f52f56eef6971e07e
+EBUILD asphyxia-1.0.ebuild 1061 BLAKE2B 59f45146111481f34bf61fd47fcb907ab6abfd1d6fd69883d9e7dfdb374b890571d581ae8783855713e6330de718d8d9763e2b3122fff57cbde9c28c3d9dfa5d SHA512 2fc1c22a18320cefc9add6561fa5fb02d079e05f168f3b983e4fbe71260b7c9c8a9542bf18007c164d0025ece872439ba7cb7a418e5f331f5eddf4c6d766326a
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/asphyxia/asphyxia-1.0.ebuild b/games-rpg/asphyxia/asphyxia-1.0.ebuild
new file mode 100644
index 000000000000..979aa1a146d9
--- /dev/null
+++ b/games-rpg/asphyxia/asphyxia-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Asphyxia"
+
+DESCRIPTION="Visual novel where the main character has one day to make peace with her friend"
+HOMEPAGE="https://ebihime.itch.io/${PN}"
+SRC_URI="${MY_PN}-${PV}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-linux"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ newicon -s 48 icon.png ${PN}.png
+ make_desktop_entry ${PN} "${MY_PN}"
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/asphyxia/metadata.xml b/games-rpg/asphyxia/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/asphyxia/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-rpg/hatoful-boyfriend-holiday-star/Manifest b/games-rpg/hatoful-boyfriend-holiday-star/Manifest
new file mode 100644
index 000000000000..8440aab9e8d1
--- /dev/null
+++ b/games-rpg/hatoful-boyfriend-holiday-star/Manifest
@@ -0,0 +1,3 @@
+DIST Linux-Standalone-20151218.rar 347789456 BLAKE2B bb41ebcde9524f2259e9d9a69e19aedc2820ddcf5fe3f4f418f0bdf8cdc9bc228da8c38761febbd68d3ecef1c5f32a5a98fa70480930d9bbcd8285ee3f25c70a SHA512 c59c6d1b54ed59cecf0e7606bdedf25dfa97c8c658800bbf343282eb36b906a569a6f3614271a307008c9946e61abfa2868a1f5ba73193f13138d52333013f5b
+EBUILD hatoful-boyfriend-holiday-star-20151218.ebuild 1409 BLAKE2B f30fcaae1f4ef1ddc2e3c129f708047ef14877fd8bb29b0ac50553239947cf62055fa3f296541473c6502ca9d74dd6e586cd1d37f4b15676bf049fb47cad1f6a SHA512 ba983f4dd6b67b2b9cae9a527fe3b86da91f24fb4adbc7d5356ab0a198e6c9faa37c4a18db1fb59d4184f8fcadb5e4449984164e388b4ceac95ab703cb149af2
+MISC metadata.xml 354 BLAKE2B 620415356736dd403be27ef2547bd0d23a3812b3c16b7976125c582118af837336c258d7c0657dbe70b254ee773041f7e169939a34cc616870a5f54ad8429c31 SHA512 6ae66494681059ab163da720d574906da7db8facc7c383db8b8dd0d5ea78f41deb5f19389b1fd8fc2848cfb7ae5c11bd3ba2750a90799b382f0bfe8f70d48637
diff --git a/games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild b/games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild
new file mode 100644
index 000000000000..8ed1e04ebf18
--- /dev/null
+++ b/games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg-utils
+
+DESCRIPTION="Holiday-themed sequel to the Japanese visual novel and dating sim about birds"
+HOMEPAGE="https://www.devolverdigital.com/games/hatoful-boyfriend-holiday-star"
+SRC_URI="Linux-Standalone-${PV}.rar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui"
+RESTRICT="bindist fetch splitdebug"
+
+DEPEND="app-arch/unrar"
+
+RDEPEND="
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ gui? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+"
+
+S="${WORKDIR}/Linux-Standalone"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe HB2.$(usex amd64 x86_64 x86) HB2
+ make_wrapper ${PN} "${DIR}"/HB2
+
+ insinto "${DIR}"
+ doins -r HB2_Data/
+ rm -r "${ED}/${DIR}"/HB2_Data/*/$(usex amd64 x86 x86_64) || die
+
+ if ! use gui; then
+ rm "${ED}/${DIR}"/HB2_Data/Plugins/*/ScreenSelector.so || die
+ fi
+
+ newicon -s 128 HB2_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "Hatoful Boyfriend - Holiday Star"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/hatoful-boyfriend-holiday-star/metadata.xml b/games-rpg/hatoful-boyfriend-holiday-star/metadata.xml
new file mode 100644
index 000000000000..1dbebd848c81
--- /dev/null
+++ b/games-rpg/hatoful-boyfriend-holiday-star/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="gui">Install the GUI for configuring screen resolution and input</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-rpg/hatoful-boyfriend/Manifest b/games-rpg/hatoful-boyfriend/Manifest
index 15afa4a549f4..909cef0198b5 100644
--- a/games-rpg/hatoful-boyfriend/Manifest
+++ b/games-rpg/hatoful-boyfriend/Manifest
@@ -1,3 +1,3 @@
DIST Hatoful_Boyfriend_Linux.zip 474221347 BLAKE2B 95f1d819ec75eeced844cbe5c0b0568bbe35052eddab223d34e683e1dab381c6abcb654e22e65aafcf8629beaebae7034ea82443c543964c197c3e16ef824d21 SHA512 0ef35be35d0c4d9815427fae078a266b3ceafba68cd87d733db23171d92396535974e0d83f1e7f441c666d064a75ddcc82a9807c347922aed84790ed1f6fda21
-EBUILD hatoful-boyfriend-0-r1.ebuild 1516 BLAKE2B 6aff690bfa03604bdac51e2309ea4cab3ada7f2bf3d11d821ade6f9106c4b9dae5d971fa81bc94bf60acab5bcedfc94216233f1f7b824cdfed978824bbe7857b SHA512 917cef574b7cd2f226ba395587dc529b510ef772bde6ed436219977e31d22c49cb9a4dfde87fdb39bae713ecbc221bf142f4f9157ab74f6b0a9b5ff576220117
+EBUILD hatoful-boyfriend-0-r1.ebuild 1515 BLAKE2B 293519809f559a958e6fc9a9a6a091dcb2b0331489edddefcf100c7af5d573147bd9f098a41a7d93a83a23f9920c66d0874c3cc76c294269509933edf1fd9e3d SHA512 78e0a5a26a3914025f00d68569955dab158c665c2f2c70edfbdc80631933c9cc402d91b8f8cb87cd2fc28e6b60c24ea393e02b8a5a44665ac51a63e656c2da59
MISC metadata.xml 354 BLAKE2B 620415356736dd403be27ef2547bd0d23a3812b3c16b7976125c582118af837336c258d7c0657dbe70b254ee773041f7e169939a34cc616870a5f54ad8429c31 SHA512 6ae66494681059ab163da720d574906da7db8facc7c383db8b8dd0d5ea78f41deb5f19389b1fd8fc2848cfb7ae5c11bd3ba2750a90799b382f0bfe8f70d48637
diff --git a/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0-r1.ebuild b/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0-r1.ebuild
index dd43f9b0cc08..c3abc044dea5 100644
--- a/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0-r1.ebuild
+++ b/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0-r1.ebuild
@@ -7,7 +7,7 @@ inherit desktop xdg-utils
MY_PN="Hatoful Boyfriend"
DESCRIPTION="Japanese visual novel and dating simulator where birds rule the Earth"
-HOMEPAGE="http://clione.halfmoon.jp/hatoful-boyfriend/english.html"
+HOMEPAGE="https://www.devolverdigital.com/games/hatoful-boyfriend"
SRC_URI="${MY_PN// /_}_Linux.zip"
LICENSE="all-rights-reserved"
SLOT="0"
diff --git a/games-rpg/sakura-spirit/Manifest b/games-rpg/sakura-spirit/Manifest
new file mode 100644
index 000000000000..92461beb03e1
--- /dev/null
+++ b/games-rpg/sakura-spirit/Manifest
@@ -0,0 +1,3 @@
+DIST Sakura_Spirit-linux.tar 132434253 BLAKE2B a8ea7d111b755cdcf82ca8e4d8cd1c4a41aed661998f77eefd237f748c187e77f43de701f203a97ca24b98665a7a876c458f67646e8f100c014178d8adb58790 SHA512 94c42c7252fd871915ef89535d3d28321496f3e813fd71e9fa6bf3c264421b9c10c445dff1fef64f63d60255e89fb2c1085351c85d5c1279467134e5ef5e7011
+EBUILD sakura-spirit-0.ebuild 1020 BLAKE2B 940025cb640b49c7d02a06bdd3f22bf6048d41180e265e85dfd57f56ab984fc6f50261da0e3c257e03a8353d7946011df16fcdf2c4141353d0d2b0beab0fd0ee SHA512 e165beec63f7b96f7a72bd707ec4c8371ec128d62ef522c0e8f95cd3e74b6b04f38e91789b217a266ad33dedba563fa9b617c1d3081f88507ec69082ef1af975
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-rpg/sakura-spirit/metadata.xml b/games-rpg/sakura-spirit/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/sakura-spirit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-rpg/sakura-spirit/sakura-spirit-0.ebuild b/games-rpg/sakura-spirit/sakura-spirit-0.ebuild
new file mode 100644
index 000000000000..2cc4e8c84edd
--- /dev/null
+++ b/games-rpg/sakura-spirit/sakura-spirit-0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Sakura Spirit"
+
+DESCRIPTION="Adult-themed visual novel and dating simulator set in Japan"
+HOMEPAGE="http://wingedcloud.com"
+SRC_URI="${MY_PN/ /_}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN/ /_}-linux"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/the-royal-trap/Manifest b/games-rpg/the-royal-trap/Manifest
new file mode 100644
index 000000000000..22968b0ba2af
--- /dev/null
+++ b/games-rpg/the-royal-trap/Manifest
@@ -0,0 +1,3 @@
+DIST The_Royal_Trap_HD_1.2-linux-x86.tar 193616345 BLAKE2B f43eb162abd077b1b2dde85012652704049c18830d0e8eb5ee4aa60b05d4b123b0fe9388aec70154b0d6e8d6a89e12fba06aacf50d5026d2391e6ad90af3d5ba SHA512 d6c0172a35e36fc6e42f1c9827e99f814cd9084a2d94042b9fd2b9a0ffd4ac1adb7c898a6579b856cfde548073b1d34a49fb6ba80d4a6c6bce682673094eff0d
+EBUILD the-royal-trap-1.2.ebuild 1065 BLAKE2B 8fa6bab526cd296f628fe98567225687a208fb131a6ae2bdeb9165138ae3af1cfd8bcc61b4a6bc0fd66857dcaf5566edc2b16fd4448dd26c34f0a705697ad188 SHA512 00bb5d9d02c93040a4eece2fb9b3ef998dacb47797efe34d96ad94895fc7dc6d50a5db0e5a8b7b87f5e1c7f08ca9c916784505131d4164ad70b381105bf151d2
+MISC metadata.xml 720 BLAKE2B a9b4464da7a46fa7e074d18a0e610b11df7fea0e79ad203cd1dc21e35d34be1d6a3dcc232eb88f2ab35a7aed0bd8007c060f82cc5f9cf7b0ed1f86673c77c78c SHA512 48a73c80d55bc4c2617e6f71288747ffb702efc9b3b071c046d502e6272fb9d48fc567bcce03d13de37d60fbff67517007c33f1f038c375969be343b02f6f52b
diff --git a/games-rpg/the-royal-trap/metadata.xml b/games-rpg/the-royal-trap/metadata.xml
new file mode 100644
index 000000000000..59e01fb5b2fa
--- /dev/null
+++ b/games-rpg/the-royal-trap/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+ Madeleine Valois is a prince's companion. Her job is to guide
+ and advise him, to make him look good so that he can land a
+ royal bride. It is her responsibility to keep him out of
+ trouble - not to let him walk blindly into a political
+ minefield, not to let him get arrested for a crime he didn't
+ commit, and definitely not to let him fall in love with her.
+
+ Unfortunately, events are not going according to plan...
+ </longdescription>
+</pkgmetadata>
diff --git a/games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild b/games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild
new file mode 100644
index 000000000000..dccd9ca8f22a
--- /dev/null
+++ b/games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="The Royal Trap"
+
+DESCRIPTION="Visual novel where you help a prince choose his royal bride"
+HOMEPAGE="https://www.hanakogames.com/royaltrap.shtml"
+SRC_URI="${MY_PN// /_}_HD_${PV}-linux-x86.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN} HD ${PV}-linux-x86"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }