summaryrefslogtreecommitdiff
path: root/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild')
-rw-r--r--games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild b/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
new file mode 100644
index 000000000000..bbb377287f74
--- /dev/null
+++ b/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop wrapper
+
+MY_PN="Deponia Doomsday"
+DESCRIPTION="The fourth and final instalment of the Deponia point-and-click adventures"
+HOMEPAGE="https://www.daedalic.com/deponia"
+SRC_URI="Deponia4_${PV}_DEB_Full_Multi_Daedalic_ESD.tar"
+LICENSE="all-rights-reserved BSD LGPL-2.1 MIT OFL-1.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="bonus"
+RESTRICT="bindist fetch splitdebug strip"
+
+# Bundles libopenal.so but 1.20.0 and later are not compatible because
+# the game uses the SelectResampler function, which was inlined.
+
+RDEPEND="
+ media-libs/libpng-compat:1.2
+ media-libs/libsdl2[opengl,video]
+ sys-libs/zlib
+ virtual/opengl
+"
+
+S="${WORKDIR}/${MY_PN}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_prepare() {
+ default
+ rm libs64/libz.so.1 || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe Deponia4
+
+ make_wrapper \
+ ${PN} \
+ "env SDL_DYNAMIC_API=\"${EPREFIX}/usr/$(get_libdir)/libSDL2-2.0.so.0\" ./Deponia4" \
+ "${DIR}" \
+ "${DIR}/lib"
+
+ insinto "${DIR}"
+ doins -r \
+ config.ini \
+ data.vis \
+ version.txt \
+ characters/ \
+ lua/ \
+ scenes/ \
+ videos/
+
+ use bonus && doins -r "bonus content/"
+
+ exeinto "${DIR}"/lib
+ doexe libs64/*
+
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+ dodoc changes.txt documents/licenses/readme.txt
+}