summaryrefslogtreecommitdiff
path: root/games-rpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /games-rpg
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/Manifest.gzbin7280 -> 7447 bytes
-rw-r--r--games-rpg/deponia-doomsday/Manifest3
-rw-r--r--games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild71
-rw-r--r--games-rpg/deponia-doomsday/metadata.xml11
4 files changed, 85 insertions, 0 deletions
diff --git a/games-rpg/Manifest.gz b/games-rpg/Manifest.gz
index c617c3b9cbe1..0a7b0cf7a405 100644
--- a/games-rpg/Manifest.gz
+++ b/games-rpg/Manifest.gz
Binary files differ
diff --git a/games-rpg/deponia-doomsday/Manifest b/games-rpg/deponia-doomsday/Manifest
new file mode 100644
index 000000000000..5d21d5bf41b3
--- /dev/null
+++ b/games-rpg/deponia-doomsday/Manifest
@@ -0,0 +1,3 @@
+DIST Deponia4_1.2.0267_DEB_Full_Multi_Daedalic_ESD.tar 3179350835 BLAKE2B caf1995f2a6204b083e7b462ec0ab45e8c84cf2bd626fbc20fbac36e066551a267cad391c07293dff5219c555523a68dc7e7a351c948a2d049af35be6ec5573c SHA512 daf3427ff3dd4568bb84a11fd63b630fa1de61331ceb84f70f7668c56abd2908e0cfdf897d9f1caefdb6d51d1082cfce435eb4378d1eeb9b0a3598edd6350c07
+EBUILD deponia-doomsday-1.2.0267.ebuild 1547 BLAKE2B 1c5d5ae193edee7b664820c67d9fa6301340ba7f5bc384fdb157e788ad2a9e880fffa18a4475e180a62dd047d2524e8befa0be1bb3a6034e8f54c68e0cfe3779 SHA512 9067788b392937230157c3c5f5c2f493686d66f121006eb761efdc4ffaad2b2738e1824b9938234156d7db018ce4d0eab66af343554bd79e5658971f60f86498
+MISC metadata.xml 358 BLAKE2B d53c2c790885c7b6bb256ad5f157919f9fba23ef903da6d9a90abf41075ce2946dcf682b9c51d9fd3c3540ff10f0c38ce29689910f22e6a97d06f34e591b2cd0 SHA512 8f4a5456696f919d5387f61806f2270bf690184b4a83d3a06e532da2b5d872016f64de0285f639c9c8ff744c12886f75d5b1eb734cc4b8a19cbd7396f69f436d
diff --git a/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild b/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
new file mode 100644
index 000000000000..bbb377287f74
--- /dev/null
+++ b/games-rpg/deponia-doomsday/deponia-doomsday-1.2.0267.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop wrapper
+
+MY_PN="Deponia Doomsday"
+DESCRIPTION="The fourth and final instalment of the Deponia point-and-click adventures"
+HOMEPAGE="https://www.daedalic.com/deponia"
+SRC_URI="Deponia4_${PV}_DEB_Full_Multi_Daedalic_ESD.tar"
+LICENSE="all-rights-reserved BSD LGPL-2.1 MIT OFL-1.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="bonus"
+RESTRICT="bindist fetch splitdebug strip"
+
+# Bundles libopenal.so but 1.20.0 and later are not compatible because
+# the game uses the SelectResampler function, which was inlined.
+
+RDEPEND="
+ media-libs/libpng-compat:1.2
+ media-libs/libsdl2[opengl,video]
+ sys-libs/zlib
+ virtual/opengl
+"
+
+S="${WORKDIR}/${MY_PN}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_prepare() {
+ default
+ rm libs64/libz.so.1 || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe Deponia4
+
+ make_wrapper \
+ ${PN} \
+ "env SDL_DYNAMIC_API=\"${EPREFIX}/usr/$(get_libdir)/libSDL2-2.0.so.0\" ./Deponia4" \
+ "${DIR}" \
+ "${DIR}/lib"
+
+ insinto "${DIR}"
+ doins -r \
+ config.ini \
+ data.vis \
+ version.txt \
+ characters/ \
+ lua/ \
+ scenes/ \
+ videos/
+
+ use bonus && doins -r "bonus content/"
+
+ exeinto "${DIR}"/lib
+ doexe libs64/*
+
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+ dodoc changes.txt documents/licenses/readme.txt
+}
diff --git a/games-rpg/deponia-doomsday/metadata.xml b/games-rpg/deponia-doomsday/metadata.xml
new file mode 100644
index 000000000000..78d4f370ee3c
--- /dev/null
+++ b/games-rpg/deponia-doomsday/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="bonus">Install the bonus content (Art Book, Concept Art, Soundtrack)</flag>
+ </use>
+</pkgmetadata>