summaryrefslogtreecommitdiff
path: root/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild')
-rw-r--r--games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild
new file mode 100644
index 000000000000..4e3bf5f6ec9a
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="Baldur's Gate: Enhanced Edition"
+HOMEPAGE="https://www.baldursgate.com/"
+SRC_URI="gog_baldur_s_gate_enhanced_edition_2.5.0.9.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/expat[abi_x86_32(-)]
+ dev-libs/json-c[abi_x86_32(-)]
+ dev-libs/openssl:0[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]"
+
+QA_PREBUILT="/opt/${PN}/BaldursGate"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ einfo "Please buy and download \"${SRC_URI}\" from"
+ einfo "https://www.gog.com/game/baldurs_gate_enhanced_edition"
+ einfo "and copy it to \"${DISTDIR}\""
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${SRC_URI}"
+}
+
+src_install() {
+ local ABI="x86"
+ local dir="/opt/${PN}"
+
+ dodoc -r "game/Manuals/."
+ rm -r "game/Manuals" || die "rm failed"
+
+ insinto "${dir}"
+ doins -r "game/."
+ fperms +x "${dir}/BaldursGate"
+
+ dodir "${dir}/lib"
+ dosym "../../../usr/$(get_libdir)/libjson-c.so" "${dir}/lib/libjson.so.0"
+
+ newicon "support/icon.png" "${PN}.png"
+ make_wrapper ${PN} "./BaldursGate" "${dir}" "${dir}/lib"
+ make_desktop_entry "${PN}" "Baldur's Gate: Enhanced Edition" "${PN}" "Game;RolePlaying"
+}