summaryrefslogtreecommitdiff
path: root/games-rpg/baldurs-gate-ee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/baldurs-gate-ee
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/baldurs-gate-ee')
-rw-r--r--games-rpg/baldurs-gate-ee/Manifest3
-rw-r--r--games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild56
-rw-r--r--games-rpg/baldurs-gate-ee/metadata.xml21
3 files changed, 80 insertions, 0 deletions
diff --git a/games-rpg/baldurs-gate-ee/Manifest b/games-rpg/baldurs-gate-ee/Manifest
new file mode 100644
index 000000000000..6cf7823e0ea6
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/Manifest
@@ -0,0 +1,3 @@
+DIST gog_baldur_s_gate_enhanced_edition_2.5.0.9.sh 2877124067 BLAKE2B 244e93ae089703c9fae3dcfcad4fb9c1eb32695e7288f7a05b3f2996887f90d6912e745e9b47a93ba45ee3ddda8363e69d22e62c57258ee54c24c47f07b2f619 SHA512 56d4796a959658f29cabef6e7339db5ba9fa792d9fd899ebc375c9b5cf94305b6d11c21d41a8809fcb1cbe38ecb4bc7152158ef19c87395374ab9060f48756a6
+EBUILD baldurs-gate-ee-2.3.67.3-r1.ebuild 1370 BLAKE2B c250d9d87cf58a4906b8a6933d32ace06730fdf5e8b092baac03bfcfb9e688216723b7633818d8977b94575d1a86f751e5d30b77d055e79ecf8da7f620981aa7 SHA512 853b672a76099fd98ad78d368ab9c484ad39c4e323d1a893c7cd433daa8c6e0562c454e38dcea7fb852c4036509a2af1be03feb716a2b9f36a460f0414b06915
+MISC metadata.xml 784 BLAKE2B e6527c6d760208259a31037ffb51533b2fa07d40be2f62bd3c08c63acf1418841abf657b678cfff42650430f75b1430a5f9bcf849e8688af57b853fa911aebb1 SHA512 d92e2613876c7c8840f640ba778f1cbdb62d2e65caf38a1e931bd7ffe6ab3bcacf6093155b01036f1cb3f18583842761242105019fbf1e72df34e096d7f5bbde
diff --git a/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild
new file mode 100644
index 000000000000..4e3bf5f6ec9a
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/baldurs-gate-ee-2.3.67.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="Baldur's Gate: Enhanced Edition"
+HOMEPAGE="https://www.baldursgate.com/"
+SRC_URI="gog_baldur_s_gate_enhanced_edition_2.5.0.9.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/expat[abi_x86_32(-)]
+ dev-libs/json-c[abi_x86_32(-)]
+ dev-libs/openssl:0[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]"
+
+QA_PREBUILT="/opt/${PN}/BaldursGate"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ einfo "Please buy and download \"${SRC_URI}\" from"
+ einfo "https://www.gog.com/game/baldurs_gate_enhanced_edition"
+ einfo "and copy it to \"${DISTDIR}\""
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${SRC_URI}"
+}
+
+src_install() {
+ local ABI="x86"
+ local dir="/opt/${PN}"
+
+ dodoc -r "game/Manuals/."
+ rm -r "game/Manuals" || die "rm failed"
+
+ insinto "${dir}"
+ doins -r "game/."
+ fperms +x "${dir}/BaldursGate"
+
+ dodir "${dir}/lib"
+ dosym "../../../usr/$(get_libdir)/libjson-c.so" "${dir}/lib/libjson.so.0"
+
+ newicon "support/icon.png" "${PN}.png"
+ make_wrapper ${PN} "./BaldursGate" "${dir}" "${dir}/lib"
+ make_desktop_entry "${PN}" "Baldur's Gate: Enhanced Edition" "${PN}" "Game;RolePlaying"
+}
diff --git a/games-rpg/baldurs-gate-ee/metadata.xml b/games-rpg/baldurs-gate-ee/metadata.xml
new file mode 100644
index 000000000000..09145c6cdfdd
--- /dev/null
+++ b/games-rpg/baldurs-gate-ee/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sir.suriv@gmail.com</email>
+ <name>Diogo Pereira</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Baldur's Gate: Enhanced Edition is a remake of the role-playing video
+ game Baldur's Gate. It takes place in the Forgotten Realms, a high
+ fantasy campaign setting, using a modified version of the Advanced
+ Dungeons &amp; Dragons (AD&amp;D) 2nd edition rules.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://support.baldursgate.com/projects/bg-ee-bugs/issues</bugs-to>
+ </upstream>
+</pkgmetadata>