summaryrefslogtreecommitdiff
path: root/games-roguelike/crossfire-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /games-roguelike/crossfire-client
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/Manifest1
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/Manifest b/games-roguelike/crossfire-client/Manifest
index be65c3c2e83a..705e3736e8ca 100644
--- a/games-roguelike/crossfire-client/Manifest
+++ b/games-roguelike/crossfire-client/Manifest
@@ -1,3 +1,4 @@
DIST crossfire-client-1.71.0.tar.bz2 761156 BLAKE2B 6a5938ca8d9c7060f43f5b6a54ff2ed65521ec8ffbc76c10be25ae8802e95d77242edb6d52852410ccd352b51d5fc9edcdb9b85dc618cecfa79cd37ff0212c0f SHA512 86710d684fd7908ea9aaf5ba20bff0f1ba01ff0ba90c3e2847afff9d0db6f60c7b671413c8888b513c992fbf27474e744b79df185d5e2c04afc9d2dce3d8665e
+EBUILD crossfire-client-1.71.0-r100.ebuild 1749 BLAKE2B 1768d1b43ab3217642d38f6f45dc0cf8094e27517abd4fc871d18d0e7c26d36761abcc3e789c8b476b38e7997cd04bac04dd816166b11a09d45bcea917f0662d SHA512 535afd472354e8362576351ac08d7364d8dfbaccd2db4b595d61c9c5009fddd8989d7cd744732fba3f3bd967796555ecebf80cfaba1d9793b7e51939b87e9cbd
EBUILD crossfire-client-1.71.0-r2.ebuild 1573 BLAKE2B 741d6525b6acb4c3a5e23e296ae1348c8a47e96d70173e466c76721007a225dea02fc0602b345c81447dd3beac52d59400b198725d0a6410b40dec14b533a785 SHA512 488691c905c146e25847cd2839197167abfa860cd5875ce0cd4337932f585ebb9e870c4d52f79e904d2dcbbaa5c1316419afc41bd67ec563974530d1950f3f33
MISC metadata.xml 332 BLAKE2B b2b20adc6daa1c491850292a929df2b67738519b81cbab2cd2c2d278176daf4e895a10bc712213abcb41714f27bb0c9e2b1731f970b7381cbf9ffefe6c393666 SHA512 cf046be69b614cd43deba574e8fbd23b566507c694b9f7cbda92d7009d727ac4087de411bf63463561beb3160ecfe7f9fb685574b018466b473535184529ccf7
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild
new file mode 100644
index 000000000000..4f37b4914939
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+
+inherit autotools desktop lua-single toolchain-funcs xdg-utils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl sdl sound"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ lua? ( ${LUA_DEPS} )
+ media-libs/libpng:0
+ net-misc/curl
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ sound? ( media-libs/sdl-mixer[vorbis] )
+ sys-libs/zlib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+ # Since we have to rewrite this anyway, dispense with the wrapper
+ # and point configure directly at the implementation of choice.
+ sed -i -e "s/lua-5.1/${ELUA}/" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use lua && myconf="${myconf} --enable-lua"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use opengl || myconf="${myconf} --disable-opengl"
+ use sound || myconf="${myconf} --disable-sound"
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use sound ; then
+ emake -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}