summaryrefslogtreecommitdiff
path: root/games-roguelike
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /games-roguelike
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/Manifest.gzbin3047 -> 3051 bytes
-rw-r--r--games-roguelike/crossfire-client/Manifest1
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild82
-rw-r--r--games-roguelike/stone-soup/Manifest8
-rw-r--r--games-roguelike/stone-soup/files/fixed-font-path.patch20
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.0.ebuild175
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild23
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild17
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1.ebuild156
9 files changed, 139 insertions, 343 deletions
diff --git a/games-roguelike/Manifest.gz b/games-roguelike/Manifest.gz
index e5aa7cf727fc..9ae3f0500be3 100644
--- a/games-roguelike/Manifest.gz
+++ b/games-roguelike/Manifest.gz
Binary files differ
diff --git a/games-roguelike/crossfire-client/Manifest b/games-roguelike/crossfire-client/Manifest
index be65c3c2e83a..705e3736e8ca 100644
--- a/games-roguelike/crossfire-client/Manifest
+++ b/games-roguelike/crossfire-client/Manifest
@@ -1,3 +1,4 @@
DIST crossfire-client-1.71.0.tar.bz2 761156 BLAKE2B 6a5938ca8d9c7060f43f5b6a54ff2ed65521ec8ffbc76c10be25ae8802e95d77242edb6d52852410ccd352b51d5fc9edcdb9b85dc618cecfa79cd37ff0212c0f SHA512 86710d684fd7908ea9aaf5ba20bff0f1ba01ff0ba90c3e2847afff9d0db6f60c7b671413c8888b513c992fbf27474e744b79df185d5e2c04afc9d2dce3d8665e
+EBUILD crossfire-client-1.71.0-r100.ebuild 1749 BLAKE2B 1768d1b43ab3217642d38f6f45dc0cf8094e27517abd4fc871d18d0e7c26d36761abcc3e789c8b476b38e7997cd04bac04dd816166b11a09d45bcea917f0662d SHA512 535afd472354e8362576351ac08d7364d8dfbaccd2db4b595d61c9c5009fddd8989d7cd744732fba3f3bd967796555ecebf80cfaba1d9793b7e51939b87e9cbd
EBUILD crossfire-client-1.71.0-r2.ebuild 1573 BLAKE2B 741d6525b6acb4c3a5e23e296ae1348c8a47e96d70173e466c76721007a225dea02fc0602b345c81447dd3beac52d59400b198725d0a6410b40dec14b533a785 SHA512 488691c905c146e25847cd2839197167abfa860cd5875ce0cd4337932f585ebb9e870c4d52f79e904d2dcbbaa5c1316419afc41bd67ec563974530d1950f3f33
MISC metadata.xml 332 BLAKE2B b2b20adc6daa1c491850292a929df2b67738519b81cbab2cd2c2d278176daf4e895a10bc712213abcb41714f27bb0c9e2b1731f970b7381cbf9ffefe6c393666 SHA512 cf046be69b614cd43deba574e8fbd23b566507c694b9f7cbda92d7009d727ac4087de411bf63463561beb3160ecfe7f9fb685574b018466b473535184529ccf7
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild
new file mode 100644
index 000000000000..4f37b4914939
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.71.0-r100.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+
+inherit autotools desktop lua-single toolchain-funcs xdg-utils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl sdl sound"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ lua? ( ${LUA_DEPS} )
+ media-libs/libpng:0
+ net-misc/curl
+ opengl? ( virtual/opengl
+ media-libs/freeglut )
+ sdl? ( media-libs/libsdl[video]
+ media-libs/sdl-image[png] )
+ sound? ( media-libs/sdl-mixer[vorbis] )
+ sys-libs/zlib
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -ri -e '/^.TH/s:$: 6:' $(find . -name "*man") || die
+ # Since we have to rewrite this anyway, dispense with the wrapper
+ # and point configure directly at the implementation of choice.
+ sed -i -e "s/lua-5.1/${ELUA}/" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # bugs in configure script so we cant use $(use_enable ...)
+ local myconf
+
+ use lua && myconf="${myconf} --enable-lua"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use opengl || myconf="${myconf} --disable-opengl"
+ use sound || myconf="${myconf} --disable-sound"
+
+ econf ${myconf}
+}
+
+src_compile() {
+ # bug 139785
+ if use sound ; then
+ emake -C sound-src AR="$(tc-getAR)"
+ fi
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local s
+
+ default
+ domenu gtk-v2/crossfire-client.desktop
+ for s in 16 32 48
+ do
+ newicon -s ${s} pixmaps/${s}x${s}.png ${PN}.png
+ done
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/games-roguelike/stone-soup/Manifest b/games-roguelike/stone-soup/Manifest
index 0b82d326859a..3c8beeba5df3 100644
--- a/games-roguelike/stone-soup/Manifest
+++ b/games-roguelike/stone-soup/Manifest
@@ -1,11 +1,9 @@
+AUX fixed-font-path.patch 802 BLAKE2B 1c831b28b65b764bdab9e8522cbf80d8449907611c77cc820c5ffe0f18b37fbf01c083ab1554ade3933182546b992fc7e5bf3e8109191723b428009a05d24449 SHA512 3db5ca3c06a27ad26a4ba2961d429153983fa51412e301da2341da87eb54422d590b8e676b4e8a06c8cbf71230e3149e7fab217fc14558d1ff20a94094ce1e82
AUX gitless-1.patch 639 BLAKE2B 646abd41a65b5744618161bd2a66f3fb43c06e40bd64ae78fdadf01bf5669b07f470be5eb3afc4931889d91f2f7a782036d1f10e1812bd7cfe14fe88c3ef40bf SHA512 b46fc9531c06a1f51b23c35be5f9f751f96d72a66f40a3aef3ffa89e0c9af56bc08f4aa6cad237f208aa789ee8511fec7304135fbe1e271345599f9107c52212
AUX rltiles-ldflags-libs.patch 1373 BLAKE2B 5a5a48bdb6081bb81bd66993bed3a6cfed4951ca059b2bf7069ab512e30c855eb65abc9d552da4e3c15c5156924bf14adc852dbb46248aa9840b8f63d1d33652 SHA512 955b6784f7a2ffbccefff6648de2072391d535f998516f52a7b5681e41aeedb34c47ac6cb6d649519448c23ce7007f08f0b0c36ced976dac0f111f2dae204287
DIST stone-soup.png 1351 BLAKE2B cc31abd59701aa6f0fb0bdcd90630ceebf7b3cb8b60f0e2817f8800c5bc4b3a5b9fef63c90a97b6248f306e7e3da0df3863a2195b8771863344d2443e7956d59 SHA512 4695204c8b936f7aac1ba15b02a6115a955fb2c56aa9a0b968ff007bc9a1a59b608110d60cce5625a9b92cd2c869bbea7e15433a53c1a338622809477a5846bc
DIST stone-soup.svg 68546 BLAKE2B 7c66286c9e8a3516e8483b3edb628a59fce29d8d248c3fd5b06e308782bbc651814f21ec958b30c36074a2576ced4bb10f291b5236da6f6e865ce1d7cefdf96d SHA512 dca555271faf704eb8ecdf5ee8a763df42cdeba94e9c163608c438cfc73c6fbf53416547050cad57f477ade191842e701785b65b7a9f18e27ceab05df8f2f75f
-DIST stone_soup-0.25.0.tar.xz 30247768 BLAKE2B 1e6595ae895beb8a4eede97002d5085e710de93726034a3ab9bd4d44fc9d03fc6cc22ff8878c2e6f825ffd0b28e73bbd1d9a087fc5eae9ffd2bc36403edf5b27 SHA512 387bce2c0491bf88c267af8e37afb1037dfc98d4ba4fb4dd3fe442f3446b6bf6f23c10f32483fb7d27e90c6045033bd70fb9e88e0bbe486489bc38ab71e62529
DIST stone_soup-0.25.1.zip 95477710 BLAKE2B 0b38a6c7cb7c4c87acccb861b5aae665cd2b6b532f6e86d4a9fa594e0d363b86b4af1ea47275f7fd026ea69d85215be8cdf46258bd620e738b4850e5eceed006 SHA512 fa7e8be582c5c6615531884ade4c113542c06c164b6912095c1adf2f16a31cb2ecce057d74132b11b1b1c256a77433037948d4e54819739b7e222cc896cd5220
-EBUILD stone-soup-0.25.0.ebuild 4408 BLAKE2B f5827388370cdfa7d57dccfbb25f608dba0df11152de77215709725d8238442d19ba131c8ca9e48cb59e0f59a7a229baea60661f87636cf702191ffd1f5be5ab SHA512 c2e1fda2391bd9de5cd110e19d147e423f19de3fc4e4d5bf3ec266eb5611111f8b983a43b4ab25fdb15fbd23c3703cbe22da4a2135c8a467b9cdc174397f31c5
-EBUILD stone-soup-0.25.1-r1.ebuild 3853 BLAKE2B 45fa35c6df8a1786f01219e3676f35bb7d3a53108bff703c5b9bf35de4bd77607581c2d263e0439c248ccfd028a26af33a5413e3afa984590c740689c500c82c SHA512 3b79556ab3ff0d22e9fdd1b764f877c476c5698e1d81c188d0d10ea2a921aecf89d8bd9e8458660e2f48a685178a858a5f9edc5a9f20126302756e99e66da13e
-EBUILD stone-soup-0.25.1-r100.ebuild 3837 BLAKE2B 43b7c40147eb45ee16e2a64c02e13ae2000dbe4f2a536f40597a711b69f5518bdde4d739708938b8fad9b637aad6d6af59aca583a02e5921c44a4fc72b3464b3 SHA512 10454d94c2f55e4003ed32a75ddbfc11a18c88bdfa914d4c4aa93a3684af39bc3e6dfa34711edee35ec68bd5c6cc1d3c4a96a6c752d4f89faf5921adbbf86288
-EBUILD stone-soup-0.25.1.ebuild 3809 BLAKE2B 0ad600c4387b8035eade2b61a2a82626068a647f4d965a290f4cb4b167bc9852a3338ce06bb0b78da6ee636d97e2bbb1cbcbcb27c46395a78024573c7ebad0ea SHA512 71055266b49150f9f2ae9123cc85324a8f21277b54d7ff3c874543fb41945e452118f47bf211251acec55dcc34b0d80a4f867bf3bd6bfeb6dac664420928569e
+EBUILD stone-soup-0.25.1-r1.ebuild 4100 BLAKE2B e4b77576a9e5c602744c61343504c500b9eca4093354934c348555fbf555a8ad547071e386daaa5d40f7030dfb5f0d3533be8d282d81faf59da6d95a6d26a030 SHA512 047f79befe6562b4f6bd05029e612e82e05f468cc1f5b49b9a0b2840d0bcb535b32f4e16aae78dca9c6408352ff94035404d5edc5a8efa0022fd8887468f50b2
+EBUILD stone-soup-0.25.1-r100.ebuild 4092 BLAKE2B 5a3013e65ec362f3c2d2a560c182e3d12ea0146c8b093b932cb9e4f84505e9a568f900236bdd55bd0bcb73e158d1b74d4abc8f1d523052c959b81613a12f27e5 SHA512 66cd9bcb40f3098e911fa5971f4d3bc270f69df59ea4513a006889fcd932d2052c7664a0e3273d58b3a806735e472db91966a9fa9d7e19cab88ce561bc0c269b
MISC metadata.xml 1619 BLAKE2B 2977dbcb30328109cf2f2c75535175ce089c4ede9d9ce7e550ae715bb8624abffdcf2ba53cb6dc545112dbf1da10b0237a8bffa7719956763955ff81b31554f7 SHA512 711ef0ab70235f7ab3a447bc49508b3e8f53f2dd0e108b4874f6e5a916b3c373decece2d6e4a134971941261315819c31799fd318d0c7be103356ac8e5218137
diff --git a/games-roguelike/stone-soup/files/fixed-font-path.patch b/games-roguelike/stone-soup/files/fixed-font-path.patch
new file mode 100644
index 000000000000..5f6bd651bec8
--- /dev/null
+++ b/games-roguelike/stone-soup/files/fixed-font-path.patch
@@ -0,0 +1,20 @@
+--- a/Makefile 2020-12-11 23:37:30.506956304 -0600
++++ b/Makefile 2020-12-11 23:40:02.925609235 -0600
+@@ -932,7 +932,7 @@
+ INSTALL_FONTS += "$(PROPORTIONAL_FONT)"
+ endif
+ else
+- SYS_PROPORTIONAL_FONT = $(shell util/find_font "$(OUR_PROPORTIONAL_FONT)")
++ SYS_PROPORTIONAL_FONT = /usr/share/fonts/dejavu/DejaVuSans.ttf
+ ifneq (,$(SYS_PROPORTIONAL_FONT))
+ ifeq (,$(COPY_FONTS))
+ DEFINES += -DPROPORTIONAL_FONT=\"$(SYS_PROPORTIONAL_FONT)\"
+@@ -952,7 +952,7 @@
+ INSTALL_FONTS += "$(MONOSPACED_FONT)"
+ endif
+ else
+- SYS_MONOSPACED_FONT = $(shell util/find_font "$(OUR_MONOSPACED_FONT)")
++ SYS_MONOSPACED_FONT = /usr/share/fonts/dejavu/DejaVuSansMono.ttf
+ ifneq (,$(SYS_MONOSPACED_FONT))
+ ifeq (,$(COPY_FONTS))
+ DEFINES += -DMONOSPACED_FONT=\"$(SYS_MONOSPACED_FONT)\"
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.0.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.0.ebuild
deleted file mode 100644
index a26fe45f42c7..000000000000
--- a/games-roguelike/stone-soup/stone-soup-0.25.0.ebuild
+++ /dev/null
@@ -1,175 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO
-# - attempt +test, linked bug claims to be fixed
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-VIRTUALX_REQUIRED="manual"
-inherit desktop distutils-r1 eutils xdg-utils toolchain-funcs
-
-MY_P="stone_soup-${PV}"
-DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
-HOMEPAGE="https://crawl.develz.org"
-SRC_URI="
- https://crawl.develz.org/release/$(ver_cut 1-2)/${PN/-/_}-${PV}.tar.xz
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.png
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.svg
-"
-
-# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
-# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
-# Public Domain|CC0: most of tiles
-# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
-LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug ncurses sound test +tiles"
-# test is broken
-# see https://crawl.develz.org/mantis/view.php?id=6121
-RESTRICT="test"
-
-RDEPEND="
- dev-db/sqlite:3
- =dev-lang/lua-5.1*:0=
- sys-libs/zlib
- !ncurses? ( !tiles? ( sys-libs/ncurses:0 ) )
- ncurses? ( sys-libs/ncurses:0 )
- tiles? (
- media-fonts/dejavu
- media-libs/freetype:2
- media-libs/libpng:0
- sound? (
- media-libs/libsdl2[X,opengl,sound,video]
- media-libs/sdl2-mixer
- )
- !sound? ( media-libs/libsdl2[X,opengl,video] )
- media-libs/sdl2-image[png]
- virtual/glu
- virtual/opengl
- )"
-DEPEND="${RDEPEND}
- dev-lang/perl
- dev-python/pyyaml[${PYTHON_USEDEP}]
- sys-devel/flex
- tiles? (
- app-arch/advancecomp
- media-gfx/pngcrush
- sys-libs/ncurses:0
- )
- virtual/pkgconfig
- virtual/yacc
- "
-
-S=${WORKDIR}/${MY_P}/source
-S_TEST=${WORKDIR}/${MY_P}_test/source
-PATCHES=(
- "${FILESDIR}"/gitless-1.patch
- "${FILESDIR}"/rltiles-ldflags-libs.patch
-)
-
-pkg_setup() {
-
- if use !ncurses && use !tiles ; then
- ewarn "Neither ncurses nor tiles frontend"
- ewarn "selected, choosing ncurses only."
- ewarn "Note that you can also enable both."
- fi
-
- if use sound && use !tiles ; then
- ewarn "Sound support is only available with tiles."
- fi
-}
-
-src_compile() {
-
- # Insurance that we're not using bundled lib sources
- rm -rf contrib || die "Couldn't delete contrib directory"
-
- rm \
- dat/des/arrival/._simple.des \
- dat/des/branches/._crypt.des \
- dat/des/branches/._lair.des \
- dat/des/branches/._pan.des \
- dat/des/branches/._slime.des \
- dat/des/branches/._temple.des \
- dat/des/builder/._layout_halls.des \
- dat/des/builder/._shops.des \
- dat/des/portals/._bazaar.des \
- dat/des/portals/._gauntlet.des \
- dat/des/portals/._ossuary.des \
- dat/des/sprint/._menkaure.des \
- dat/des/sprint/._red_sonja.des \
- dat/des/sprint/._sprint_mu.des \
- dat/des/variable/._the_grid.des \
- || die "Can't remove bogus Apple Macintosh files"
-
- export HOSTCXX=$(tc-getBUILD_CXX)
-
- # leave DATADIR at the top
- myemakeargs=(
- $(usex debug "FULLDEBUG=y DEBUG=y" "")
- BUILD_LUA=
- AR="$(tc-getAR)"
- CFOPTIMIZE=''
- CFOTHERS="${CXXFLAGS}"
- CONTRIBS=
- DATADIR="/usr/share/${PN}"
- GCC="$(tc-getCC)"
- GXX="$(tc-getCXX)"
- LDFLAGS="${LDFLAGS}"
- MAKEOPTS="${MAKEOPTS}"
- PKGCONFIG="$(tc-getPKG_CONFIG)"
- RANLIB="$(tc-getRANLIB)"
- SAVEDIR="~/.crawl"
- SOUND=$(usex sound "y" "")
- STRIP=touch
- USE_LUAJIT=
- V=1
- prefix="/usr"
- )
-
- if use ncurses || (use !ncurses && use !tiles) ; then
- emake "${myemakeargs[@]}"
- # move it in case we build both variants
- use tiles && { mv crawl "${WORKDIR}"/crawl-ncurses || die ;}
- fi
-
- if use tiles ; then
- emake clean
- emake "${myemakeargs[@]}" "TILES=y"
- fi
-}
-
-src_install() {
- emake "${myemakeargs[@]}" $(usex tiles "TILES=y" "") DESTDIR="${D}" prefix_fp="" bin_prefix="${D}/usr/bin" install
- [[ -e "${WORKDIR}"/crawl-ncurses ]] && dobin "${WORKDIR}"/crawl-ncurses
-
- # don't relocate docs, needed at runtime
- rm -rf "${D}/usr/share/${PN}"/docs/license
-
- doman "${WORKDIR}/${MY_P}"/docs/crawl.6
-
- # icons and menu for graphical build
- if use tiles ; then
- doicon -s 48 "${DISTDIR}"/${PN}.png
- doicon -s scalable "${DISTDIR}"/${PN}.svg
- make_desktop_entry crawl
- fi
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-
- if use tiles && use ncurses ; then
- elog "Since you have enabled both tiles and ncurses frontends"
- elog "the ncurses binary is called 'crawl-ncurses' and the"
- elog "tiles binary is called 'crawl'."
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild
index d4d2ba19807a..0c8a1930f33d 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1-r1.ebuild
@@ -8,7 +8,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
VIRTUALX_REQUIRED="manual"
-inherit desktop distutils-r1 eutils xdg-utils toolchain-funcs
+inherit desktop python-any-r1 eutils xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
@@ -25,7 +25,7 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug ncurses sound test +tiles"
# test is broken
# see https://crawl.develz.org/mantis/view.php?id=6121
@@ -42,8 +42,8 @@ RDEPEND="
media-libs/freetype:2
media-libs/libpng:0
sound? (
- media-libs/libsdl2[X,opengl,sound,video]
- media-libs/sdl2-mixer
+ media-libs/libsdl2[X,opengl,sound,video]
+ media-libs/sdl2-mixer
)
!sound? ( media-libs/libsdl2[X,opengl,video] )
media-libs/sdl2-image[png]
@@ -53,7 +53,8 @@ RDEPEND="
DEPEND="${RDEPEND}
app-arch/unzip
dev-lang/perl
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
tiles? (
app-arch/advancecomp
@@ -67,12 +68,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}/source
S_TEST=${WORKDIR}/${MY_P}_test/source
PATCHES=(
+ "${FILESDIR}"/fixed-font-path.patch
"${FILESDIR}"/gitless-1.patch
"${FILESDIR}"/rltiles-ldflags-libs.patch
)
+python_check_deps() {
+ has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
+ python-any-r1_pkg_setup
+
if use !ncurses && use !tiles ; then
ewarn "Neither ncurses nor tiles frontend"
ewarn "selected, choosing ncurses only."
@@ -84,6 +92,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+ python_fix_shebang "${S}/util/species-gen.py"
+}
+
src_compile() {
# Insurance that we're not using bundled lib sources
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
index 984eb6860bc9..fd7baf97c0e4 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1-r100.ebuild
@@ -9,7 +9,7 @@ EAPI=7
LUA_COMPAT=( lua5-{1..3} )
PYTHON_COMPAT=( python3_{6,7,8,9} )
VIRTUALX_REQUIRED="manual"
-inherit desktop distutils-r1 eutils lua-single xdg-utils toolchain-funcs
+inherit desktop python-any-r1 eutils lua-single xdg-utils toolchain-funcs
MY_P="stone_soup-${PV}"
DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
@@ -54,7 +54,8 @@ RDEPEND="
DEPEND="${RDEPEND}
app-arch/unzip
dev-lang/perl
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
tiles? (
sys-libs/ncurses:0
@@ -66,12 +67,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}/source
S_TEST=${WORKDIR}/${MY_P}_test/source
PATCHES=(
+ "${FILESDIR}"/fixed-font-path.patch
"${FILESDIR}"/gitless-1.patch
"${FILESDIR}"/rltiles-ldflags-libs.patch
)
+python_check_deps() {
+ has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
+ python-any-r1_pkg_setup
+
if use !ncurses && use !tiles ; then
ewarn "Neither ncurses nor tiles frontend"
ewarn "selected, choosing ncurses only."
@@ -83,6 +91,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+ python_fix_shebang "${S}/util/species-gen.py"
+}
+
src_compile() {
# Insurance that we're not using bundled lib sources
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild
deleted file mode 100644
index f478d555a48e..000000000000
--- a/games-roguelike/stone-soup/stone-soup-0.25.1.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO
-# - attempt +test, linked bug claims to be fixed
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-VIRTUALX_REQUIRED="manual"
-inherit desktop distutils-r1 eutils xdg-utils toolchain-funcs
-
-MY_P="stone_soup-${PV}"
-DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
-HOMEPAGE="https://crawl.develz.org"
-SRC_URI="
- https://github.com/crawl/crawl/releases/download/${PV}/${PN/-/_}-${PV}.zip
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.png
- https://dev.gentoo.org/~hasufell/distfiles/${PN}.svg
-"
-
-# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
-# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
-# Public Domain|CC0: most of tiles
-# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
-LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug ncurses sound test +tiles"
-# test is broken
-# see https://crawl.develz.org/mantis/view.php?id=6121
-RESTRICT="test"
-
-RDEPEND="
- dev-db/sqlite:3
- =dev-lang/lua-5.1*:0=
- sys-libs/zlib
- !ncurses? ( !tiles? ( sys-libs/ncurses:0 ) )
- ncurses? ( sys-libs/ncurses:0 )
- tiles? (
- media-fonts/dejavu
- media-libs/freetype:2
- media-libs/libpng:0
- sound? (
- media-libs/libsdl2[X,opengl,sound,video]
- media-libs/sdl2-mixer
- )
- !sound? ( media-libs/libsdl2[X,opengl,video] )
- media-libs/sdl2-image[png]
- virtual/glu
- virtual/opengl
- )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-lang/perl
- dev-python/pyyaml[${PYTHON_USEDEP}]
- sys-devel/flex
- tiles? (
- sys-libs/ncurses:0
- )
- virtual/pkgconfig
- virtual/yacc
- "
-
-S=${WORKDIR}/${MY_P}/source
-S_TEST=${WORKDIR}/${MY_P}_test/source
-PATCHES=(
- "${FILESDIR}"/gitless-1.patch
- "${FILESDIR}"/rltiles-ldflags-libs.patch
-)
-
-pkg_setup() {
-
- if use !ncurses && use !tiles ; then
- ewarn "Neither ncurses nor tiles frontend"
- ewarn "selected, choosing ncurses only."
- ewarn "Note that you can also enable both."
- fi
-
- if use sound && use !tiles ; then
- ewarn "Sound support is only available with tiles."
- fi
-}
-
-src_compile() {
-
- # Insurance that we're not using bundled lib sources
- rm -rf contrib || die "Couldn't delete contrib directory"
-
- export HOSTCXX=$(tc-getBUILD_CXX)
-
- # leave DATADIR at the top
- myemakeargs=(
- $(usex debug "FULLDEBUG=y DEBUG=y" "")
- BUILD_LUA=
- AR="$(tc-getAR)"
- CFOPTIMIZE=''
- CFOTHERS="${CXXFLAGS}"
- CONTRIBS=
- DATADIR="/usr/share/${PN}"
- GCC="$(tc-getCC)"
- GXX="$(tc-getCXX)"
- LDFLAGS="${LDFLAGS}"
- MAKEOPTS="${MAKEOPTS}"
- PKGCONFIG="$(tc-getPKG_CONFIG)"
- RANLIB="$(tc-getRANLIB)"
- SAVEDIR="~/.crawl"
- SOUND=$(usex sound "y" "")
- STRIP=touch
- USE_LUAJIT=
- V=1
- prefix="/usr"
- )
-
- if use ncurses || (use !ncurses && use !tiles) ; then
- emake "${myemakeargs[@]}"
- # move it in case we build both variants
- use tiles && { mv crawl "${WORKDIR}"/crawl-ncurses || die ;}
- fi
-
- if use tiles ; then
- emake clean
- emake "${myemakeargs[@]}" "TILES=y"
- fi
-}
-
-src_install() {
- emake "${myemakeargs[@]}" $(usex tiles "TILES=y" "") DESTDIR="${D}" prefix_fp="" bin_prefix="${D}/usr/bin" install
- [[ -e "${WORKDIR}"/crawl-ncurses ]] && dobin "${WORKDIR}"/crawl-ncurses
-
- # don't relocate docs, needed at runtime
- rm -rf "${D}/usr/share/${PN}"/docs/license
-
- doman "${WORKDIR}/${MY_P}"/docs/crawl.6
-
- # icons and menu for graphical build
- if use tiles ; then
- doicon -s 48 "${DISTDIR}"/${PN}.png
- doicon -s scalable "${DISTDIR}"/${PN}.svg
- make_desktop_entry crawl
- fi
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-
- if use tiles && use ncurses ; then
- elog "Since you have enabled both tiles and ncurses frontends"
- elog "the ncurses binary is called 'crawl-ncurses' and the"
- elog "tiles binary is called 'crawl'."
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}