summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /games-fps
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/Manifest.gzbin21076 -> 21074 bytes
-rw-r--r--games-fps/etqw-data/Manifest2
-rw-r--r--games-fps/etqw-data/etqw-data-1.0-r1.ebuild53
-rw-r--r--games-fps/etqw-data/etqw-data-1.0.ebuild65
-rw-r--r--games-fps/freedm/Manifest2
-rw-r--r--games-fps/freedm/freedm-0.11.3.ebuild1
-rw-r--r--games-fps/freedoom/Manifest2
-rw-r--r--games-fps/freedoom/freedoom-0.11.3-r1.ebuild1
-rw-r--r--games-fps/prboom-plus/Manifest4
-rw-r--r--games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch33
-rw-r--r--games-fps/prboom-plus/metadata.xml33
-rw-r--r--games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild68
-rw-r--r--games-fps/prboom/Manifest7
-rw-r--r--games-fps/prboom/files/prboom-2.5.0-libpng14.patch22
-rw-r--r--games-fps/prboom/files/prboom-2.5.0-nvidia-test.c3
-rw-r--r--games-fps/prboom/files/prboom-2.5.0-nvidia.patch48
-rw-r--r--games-fps/prboom/metadata.xml11
-rw-r--r--games-fps/prboom/prboom-2.5.0-r1.ebuild91
18 files changed, 196 insertions, 250 deletions
diff --git a/games-fps/Manifest.gz b/games-fps/Manifest.gz
index 99c567622c97..a4941086d9fd 100644
--- a/games-fps/Manifest.gz
+++ b/games-fps/Manifest.gz
Binary files differ
diff --git a/games-fps/etqw-data/Manifest b/games-fps/etqw-data/Manifest
index 7c6214fe2f0c..ce7b86e9aca4 100644
--- a/games-fps/etqw-data/Manifest
+++ b/games-fps/etqw-data/Manifest
@@ -1,2 +1,2 @@
-EBUILD etqw-data-1.0.ebuild 1301 BLAKE2B d8d4e6fb5ccb3df9e3f336c16a87cceba197236e8bc91b3fdfffc4c184a553cb2b95be9801af42b6d0248816279efaf3aba51f2efce0d1d392c9ba6a690848ff SHA512 f17c60fc3705f86d052082d1806e7a3f1e9450469bbbe4c4b4d72e7f4fb357361cfa46cd596be6cca54bcc4e618b4aa09e35c9509f981b65d11362ca00687147
+EBUILD etqw-data-1.0-r1.ebuild 931 BLAKE2B 6a529cb05255c9a9bf2baccde726e10f0974272937e8f69aa534bcc17c7bbfe616986298c611bf982c13691c7ced98a36f7af696d4b1cddb366d0b00886b29fc SHA512 fdc7f4605d63d3e3539bc345e94e6765f0181f9087800e4121daea913adec2af07be27aad54ec36afe21298b02c425553a9b1676055255d83c2c4860298ee2b2
MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
diff --git a/games-fps/etqw-data/etqw-data-1.0-r1.ebuild b/games-fps/etqw-data/etqw-data-1.0-r1.ebuild
new file mode 100644
index 000000000000..6f5806dd98a1
--- /dev/null
+++ b/games-fps/etqw-data/etqw-data-1.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cdrom
+
+DESCRIPTION="Enemy Territory: Quake Wars data files"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/ETQWFrontPage/"
+SRC_URI=""
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="videos"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/opt/etqw
+
+ cdrom_get_cds Setup/Data/base/DEU:Setup/Data/base/POL:Setup/Data/base
+
+ cd "${CDROM_ROOT}"/Setup/Data/base
+ insinto "${dir}"/base
+ doins pak00{0..4}.pk4
+ doins -r megatextures
+
+ case ${CDROM_SET} in
+ 0)
+ doins \
+ zpak_english000.pk4 \
+ DEU/zpak_german000.pk4 \
+ ESP/zpak_spanish000.pk4 \
+ FRA/zpak_french000.pk4
+ ;;
+ 1)
+ doins \
+ POL/zpak_polish000.pk4 \
+ RUS/zpak_russian000.pk4
+ ;;
+ 2)
+ doins zpak_english000.pk4
+ ;;
+ esac
+
+ if use videos ; then
+ case ${CDROM_SET} in
+ 0|2)
+ doins -r video
+ ;;
+ esac
+ fi
+}
diff --git a/games-fps/etqw-data/etqw-data-1.0.ebuild b/games-fps/etqw-data/etqw-data-1.0.ebuild
deleted file mode 100644
index 048efa9cd245..000000000000
--- a/games-fps/etqw-data/etqw-data-1.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils cdrom games
-
-DESCRIPTION="Enemy Territory: Quake Wars data files"
-HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
-SRC_URI=""
-
-LICENSE="ETQW"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="videos"
-
-S=${WORKDIR}
-
-src_install() {
- local dir=${GAMES_PREFIX_OPT}/etqw
-
- cdrom_get_cds Setup/Data/base/DEU:Setup/Data/base/POL:Setup/Data/base
-
- cd "${CDROM_ROOT}"/Setup/Data/base
- insinto "${dir}"/base
- doins pak00{0..4}.pk4 || die "doins pak failed"
- doins -r megatextures || die "doins megatextures failed"
-
- case ${CDROM_SET} in
- 0)
- doins \
- zpak_english000.pk4 \
- DEU/zpak_german000.pk4 \
- ESP/zpak_spanish000.pk4 \
- FRA/zpak_french000.pk4 \
- || die "doins zpak failed"
- ;;
- 1)
- doins \
- POL/zpak_polish000.pk4 \
- RUS/zpak_russian000.pk4 \
- || die "doins zpak failed"
- ;;
- 2)
- doins zpak_english000.pk4 || die "doins zpak failed"
- ;;
- esac
-
- if use videos ; then
- case ${CDROM_SET} in
- 0|2)
- doins -r video || die "doins video failed"
- ;;
- esac
- fi
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- elog "This is just the data portion of the game. You will need to install"
- elog "games-fps/etqw-bin to play it."
-}
diff --git a/games-fps/freedm/Manifest b/games-fps/freedm/Manifest
index 92857b013f94..bc206eae18fe 100644
--- a/games-fps/freedm/Manifest
+++ b/games-fps/freedm/Manifest
@@ -1,2 +1,2 @@
-EBUILD freedm-0.11.3.ebuild 501 BLAKE2B d7be8788f8f6fb27c630d80ff569a5cb929e443b482166766197cfbd53fcb7a5c3ab952c454600238d58e48428f551a9bd95da0e0a9c655c73cba06e8252eeb8 SHA512 dd5445fc21c0297495e4fba90894fee5ff1c358f270de8611b13b0591478c476de3ab917246ff07451f8068f3052df2d901e6e66f842b341851a070b8fa1e5f4
+EBUILD freedm-0.11.3.ebuild 525 BLAKE2B 25f0efebab82c86cee9ecb2ac7984097d511db2f96efa1316eb44622e503e1b913c6b871b09a29ef05dbb408719e69047dbfa46ca5577bc321f7a711737206f3 SHA512 27432177099fcd42ee3c72d4e2ab5dd8569fe75d23d85174d44629377ed38ed3d5336203b333f39ea5ec181a4d604e9cbb44e12e88e5dcbf3647133f5152b0b3
MISC metadata.xml 1480 BLAKE2B 0755aba8cc597778e420a8142e5febd305e317057870abdaa2f5761e2b45f86c139f63aa096fdb20a5984552d886b47ba7b458ed7f3e971ce4442d03f31e75f9 SHA512 d5847035c6bfa72c3af95a8af203df5909236616726a474dcc33c051de8149f82f4d8c9d1bc8be05b6b05ae1f3a8ec3064f400aa120a6c87d43358ab2e7e20f3
diff --git a/games-fps/freedm/freedm-0.11.3.ebuild b/games-fps/freedm/freedm-0.11.3.ebuild
index 342ceb06a7fe..47c3ee76f4c5 100644
--- a/games-fps/freedm/freedm-0.11.3.ebuild
+++ b/games-fps/freedm/freedm-0.11.3.ebuild
@@ -16,6 +16,7 @@ RDEPEND="
games-fps/gzdoom
games-engines/odamex
games-fps/doomsday
+ games-fps/prboom-plus
)
"
diff --git a/games-fps/freedoom/Manifest b/games-fps/freedoom/Manifest
index 1e5f0ad3225d..641f15e1ccc3 100644
--- a/games-fps/freedoom/Manifest
+++ b/games-fps/freedoom/Manifest
@@ -1,2 +1,2 @@
-EBUILD freedoom-0.11.3-r1.ebuild 528 BLAKE2B 0a72d04671bf677fda1c63348cff4eefa9f6d53972e58284912be3ff50a3189fe2dc589b643bc7b58559dd5d47b67550d9bd3351bf7e0b2ee77434b927bdcdf0 SHA512 2a4eff48c27f68cee0f3391ac926fac08151f7bd45505dfd4ef7e3790d72d0c91ec9a835d696c0bb1a9f41e97f0c1afe1a77fca742cd86e561250ff93b6cea60
+EBUILD freedoom-0.11.3-r1.ebuild 552 BLAKE2B 47c4ad551c551538d5e04564f1f978015a97deb1b4060940d76ae2524ef04654ed38d22537e5281987b0eb881444d7115789c0bc1f8638f027025e51b456a2ae SHA512 689a084fcf603877e13ab96222c9c5f352ec6c767906056ce43098ab32cff23fb8f5509ffd76aa3acf4fd6153fedf1b44e71f6f57c7490cc50587b97f2626bb5
MISC metadata.xml 1809 BLAKE2B 84960851e0fcb2354c71c796ebd28f3c1bea2762e1810d851c04d375cbc90bf6a6cddd9629f802829bb495cea44260b352291e2d3adbb17516c8cb97697da450 SHA512 a1e68567ab9be93d88e5debbba73e2704e5ef9f063bc98f30bc480064e9037b3841fdd3cec24a8f61ba0c76a68d20b63a329dd880d8c99a8c11a3ba39c3de89d
diff --git a/games-fps/freedoom/freedoom-0.11.3-r1.ebuild b/games-fps/freedoom/freedoom-0.11.3-r1.ebuild
index 2f5fd2f5c58a..b0297a0238e1 100644
--- a/games-fps/freedoom/freedoom-0.11.3-r1.ebuild
+++ b/games-fps/freedoom/freedoom-0.11.3-r1.ebuild
@@ -16,6 +16,7 @@ RDEPEND="
games-fps/gzdoom
games-engines/odamex
games-fps/doomsday
+ games-fps/prboom-plus
)
"
diff --git a/games-fps/prboom-plus/Manifest b/games-fps/prboom-plus/Manifest
new file mode 100644
index 000000000000..e6a3a7b51686
--- /dev/null
+++ b/games-fps/prboom-plus/Manifest
@@ -0,0 +1,4 @@
+AUX prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch 907 BLAKE2B efbd5fda7e4e1d8ac57f4d17381b9ea0ae3c2a64e1edfec0f55c25c5fa96c22d842cb510773bd7cfb4e244b3533b0b36a2112d6537ec6cf895c6aa6c922bdf38 SHA512 5582a1a7a69960eea22ed6bc7cfeb4e3e75480f5f6495cb44691548e5cf3ed80901a9059c19eba1c8ddcb2ce02aa52570e13906348c65d8a3f25960543d31b65
+DIST prboom-plus-2.5.1.4.tar.gz 3007237 BLAKE2B 3dce8aad6fb521d13cf3e6b48a261f010b545bafa853860b284be0d0772f65b4fa0bfa965f7cb1869cc0d0eb21a4237e1873d08ff56d439cb3eed00f82bf12fb SHA512 625b75c5fe663bb3ba54bcd90f914ad7461c0860448f6f179180de26bea0a4d766739c50f96a8245687bc213742ec53bf6ffa26cde09772b3ae0bba91662213e
+EBUILD prboom-plus-2.5.1.4.ebuild 1999 BLAKE2B d36f1085ce699d751ac951235d294bb5b793d2a5959bbe7832793ec48a1edc0e5de15d330ad31f97a71b675a3818daae603a547c80e801ff00585c3f7cb9882d SHA512 746f4c507689dab0f3f519a1c840bad809ce65587d71380c44952471aaa7d1d22215e453a2e86bd02faa6c46de602d4cd037ae7d5a67441e2402c077c79936fb
+MISC metadata.xml 1459 BLAKE2B cd2f6519fbb9dc35f231eed64576e53f0666773057844cc6791932ee9e44c2ce52d6dbfea3547402f1b3e502134897d8e17d4036dfbcfc4d4c1d44a948b1f5dd SHA512 0e7df56a1da7c31f51c0ec5eba6b2d3d831399e17b9377b2233d018dd89c3ff39836bee8bcfbd594d46505f927210ccac6e3c7fd316c9609c13796d877a9f01f
diff --git a/games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch b/games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch
new file mode 100644
index 000000000000..c64bd135937d
--- /dev/null
+++ b/games-fps/prboom-plus/files/prboom-plus-2.5.1.4-Remove-nonstandard-gamesdir-variable.patch
@@ -0,0 +1,33 @@
+From d0aaa51e05da23c2b0ad46901c2f4b3cd0500681 Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Fri, 21 Jun 2019 17:31:01 +0900
+Subject: [PATCH] Remove nonstandard gamesdir variable
+
+The Autotools canonical method of configuring the program installation
+directory is via the bindir variable (e.g. "--bindir=/usr/games/doom").
+---
+ src/Makefile.am | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index c20da98..9b3ab13 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -8,12 +8,10 @@
+
+ SUBDIRS = SDL POSIX MAC PCSOUND TEXTSCREEN MUSIC
+
+-gamesdir=$(prefix)/games
+-
+ if BUILD_SERVER
+-games_PROGRAMS = prboom-plus prboom-plus-game-server
++bin_PROGRAMS = prboom-plus prboom-plus-game-server
+ else
+-games_PROGRAMS = prboom-plus
++bin_PROGRAMS = prboom-plus
+ endif
+
+ CFLAGS = @CFLAGS@ @SDL_CFLAGS@
+--
+2.22.0
+
diff --git a/games-fps/prboom-plus/metadata.xml b/games-fps/prboom-plus/metadata.xml
new file mode 100644
index 000000000000..c05b6d7832b5
--- /dev/null
+++ b/games-fps/prboom-plus/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ PrBoom+ is a Doom source port developed from the original PrBoom project.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="dumb">Enable support for various tracker-style music formats via <pkg>media-libs/dumb</pkg></flag>
+ <flag name="fluidsynth">Enable support for MIDI via <pkg>media-sound/fluidsynth</pkg></flag>
+ <flag name="net">Enable support for network play</flag>
+ <flag name="nonfree">Enable non-free components</flag>
+ <flag name="portmidi">Enable support for MIDI via <pkg>media-libs/portmidi</pkg></flag>
+ <flag name="sdl-image">Enable support for high-resolution texture support via <pkg>media-libs/sdl-image</pkg></flag>
+ <flag name="sdl-mixer">Enable support for MIDI via <pkg>media-libs/sdl-mixer</pkg></flag>
+ </use>
+ <upstream>
+ <bugs-to>https://sourceforge.net/p/prboom-plus/bugs</bugs-to>
+ <doc lang="en">https://prboom-plus.sourceforge.net</doc>
+ <remote-id type="sourceforge">prboom-plus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild b/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild
new file mode 100644
index 000000000000..29196ddfd2ea
--- /dev/null
+++ b/games-fps/prboom-plus/prboom-plus-2.5.1.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+DESCRIPTION="A Doom source port developed from the original PrBoom project"
+HOMEPAGE="https://prboom-plus.sourceforge.net"
+# We are using a github mirror here because the upstream tarball is missing the
+# free dog assets; we should update SRC_URI to point to the upstream tarball
+# once the free assets are present as expected
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/coelckers/prboom-plus/archive/f96f891d068dcc5ec52ed91056b46d27e9a8462d.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+
+ nonfree? ( freedist )
+ !nonfree? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dumb fluidsynth mad net nonfree +opengl pcre +png portmidi sdl-image +sdl-mixer vorbis"
+REQUIRED_USE="sdl-image? ( opengl )"
+
+DEPEND="
+ media-libs/libsdl[opengl?,joystick,sound,video]
+ dumb? ( media-libs/dumb )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ mad? ( media-libs/libmad )
+ net? ( media-libs/sdl-net )
+ sdl-image? ( media-libs/sdl-image )
+ pcre? ( dev-libs/libpcre:3 )
+ png? ( media-libs/libpng:0= )
+ portmidi? ( media-libs/portmidi )
+ sdl-mixer? ( media-libs/sdl-mixer[midi] )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/prboom-plus-f96f891d068dcc5ec52ed91056b46d27e9a8462d/prboom2"
+PATCHES="${FILESDIR}/${P}-Remove-nonstandard-gamesdir-variable.patch"
+
+src_prepare() {
+ xdg_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-cpu-opt \
+ $(use_enable nonfree nonfree-graphics) \
+ $(use_enable opengl gl) \
+ $(use_with dumb) \
+ $(use_with fluidsynth) \
+ $(use_with mad) \
+ $(use_with net) \
+ $(use_with pcre) \
+ $(use_with png) \
+ $(use_with portmidi) \
+ $(use_with sdl-image image) \
+ $(use_with sdl-mixer mixer) \
+ $(use_with vorbis vorbisfile) \
+ --with-waddir="${EPREFIX}/usr/share/doom"
+}
+
+src_install() {
+ default
+ newicon ICONS/prboom-plus.svg ${PN}.svg
+ make_desktop_entry "${PN}" "PrBoom+"
+}
diff --git a/games-fps/prboom/Manifest b/games-fps/prboom/Manifest
deleted file mode 100644
index b558a0db3d4b..000000000000
--- a/games-fps/prboom/Manifest
+++ /dev/null
@@ -1,7 +0,0 @@
-AUX prboom-2.5.0-libpng14.patch 547 BLAKE2B b159e7e2654aad0c9d37109c5d6919ca4cc5d29401f839c45690a73ce6b8391aa5ab4f4f1495d48635f87eca0c25b671ef60753ad636f8ee8be0bebd3db56c0b SHA512 0ecebc1f9b8db2662ba643ee36422f11152870e95305cd0e7fda351b4397df002ba8a770664be451fc86c46afd85bd7122aa3a1ed75901d48197accdf35464cf
-AUX prboom-2.5.0-nvidia-test.c 90 BLAKE2B 60afd518380bb119087a3ddde1ce1af2490a650184677e7720dd40be601c227ccf450d68bf1f8afaa54c62ff4272d4a7351b36d7eb1f000b19b48c68ef6f6a6e SHA512 2b864be0a40c213c4dfbef18b25db34ac62968f932f534dbe549019f0000ff7ce524e345740aff8c5b8aecdd2e5df9e42fef298d11f5d2366ad324c3003c4466
-AUX prboom-2.5.0-nvidia.patch 1746 BLAKE2B 94acec8ebe5a1ce554c257790ac1721c68e5adf8537acf600b0ea8b3d291f29d80bab1f689c3e1d436a86412f07479a23c231f610f313ae38d8cb101f9d9754b SHA512 f9f99aa310b82e467fda789630a156c6d96b0cf7ff65678365a4b466f5d9a98773daf529f79a35178cd127460199be589a443d9562932332a5a82f7804269592
-DIST prboom-2.5.0.tar.gz 1049505 BLAKE2B eb044c091279e04bfb65f9fea26bb706be213510b82a95ebe9d482a7c5d2c2ca5a51776afb3af6e8cebeba5df2441922f2298e52c54414b56e98e637c6feb544 SHA512 9e25b55047c66931ea010751fb64484e466395b04dfb738ed9dc515bd8b78e1124a337da33bf7be6e97280016ed1f01c852d8bc12704bdb82074488d7b5d2894
-DIST prboom.png 4254 BLAKE2B cf70f0ee9d41ad41c3f326b30a12df90f76fdb788d252b29bce1925ef253ec272feedc7040a8bf33146f313517afdc038c66324b9c671d90a7db89a5da2569db SHA512 72631d253c6754484ab1c96c953ed37a734197fa851dc88156fd3d4fb8396a77347805233481470b936a504d08e06d994de1eba613e6bf70a89db8fc7ee9b1ac
-EBUILD prboom-2.5.0-r1.ebuild 2010 BLAKE2B f1b0a15691446d91f2143ee808e1d0b285c5223607416936b50def2c304287d080427627e332482399252d6e8e1910821d947c75c40976aa9fb66ce04a717b15 SHA512 15b2d4337f9d9d9b4ad909a7096bc4b533988e7fe6f27f0852ecbb95f76f4833274d5092eaf48beb7ec24c5599bf5d95f84794f60d83d66a13bacd6961fd21df
-MISC metadata.xml 329 BLAKE2B 6c5388579683b49a47404b9f68b46ac1f1a67596bbb523a80fe247ec6fe48d3a4b59ea15aa7be0201879c5f8f050d1713cc2d8c28f128009ba92c8662f71a28f SHA512 a1c50442cb2fb1e0b536fd7b2402f74f4edf3a8edb0ff45ea6873cf24402fd5c37535006604e98b3c0073f9788763efaff2e51a91cd44b7fc37343549be87e80
diff --git a/games-fps/prboom/files/prboom-2.5.0-libpng14.patch b/games-fps/prboom/files/prboom-2.5.0-libpng14.patch
deleted file mode 100644
index 3dea0e7a983b..000000000000
--- a/games-fps/prboom/files/prboom-2.5.0-libpng14.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=308739
-
---- a/src/SDL/i_sshot.c
-+++ b/src/SDL/i_sshot.c
-@@ -231,7 +231,7 @@
- if (fp)
- {
- png_struct *png_ptr = png_create_write_struct(
-- PNG_LIBPNG_VER_STRING, png_error_ptr_NULL, error_fn, warning_fn);
-+ PNG_LIBPNG_VER_STRING, NULL, error_fn, warning_fn);
-
- if (png_ptr)
- {
-@@ -279,7 +279,7 @@
- break;
- }
- }
-- png_destroy_write_struct(&png_ptr, png_infopp_NULL);
-+ png_destroy_write_struct(&png_ptr, NULL);
- }
- fclose(fp);
- }
diff --git a/games-fps/prboom/files/prboom-2.5.0-nvidia-test.c b/games-fps/prboom/files/prboom-2.5.0-nvidia-test.c
deleted file mode 100644
index f9e4bd700f8a..000000000000
--- a/games-fps/prboom/files/prboom-2.5.0-nvidia-test.c
+++ /dev/null
@@ -1,3 +0,0 @@
-#include <SDL/SDL_opengl.h>
-PFNGLCOLORTABLEEXTPROC glColorTableEXT;
-int main(){return 0;}
diff --git a/games-fps/prboom/files/prboom-2.5.0-nvidia.patch b/games-fps/prboom/files/prboom-2.5.0-nvidia.patch
deleted file mode 100644
index c602c784c13f..000000000000
--- a/games-fps/prboom/files/prboom-2.5.0-nvidia.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/src/gl_intern.h.orig 2003-09-21 16:39:30.247451624 -0400
-+++ b/src/gl_intern.h 2003-09-21 16:39:41.610724144 -0400
-@@ -84,6 +84,6 @@
- #define min(a,b) ((a)<(b)?(a):(b))
- #endif
-
--PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
-+//PFNGLCOLORTABLEEXTPROC gld_ColorTableEXT;
-
- #endif // _GL_INTERN_H
---- a/src/gl_main.c.orig 2003-09-21 16:39:55.436622288 -0400
-+++ b/src/gl_main.c 2003-09-21 16:43:00.943420968 -0400
-@@ -285,6 +285,7 @@
-
- if (strcasecmp(extension, "GL_EXT_texture_filter_anisotropic") == 0)
- gl_texture_filter_anisotropic = true;
-+/*
- else if (strcasecmp(extension, "GL_EXT_paletted_texture") == 0) {
- if (gl_use_paletted_texture) {
- gl_paletted_texture = true;
-@@ -304,6 +305,7 @@
- else
- lprintf(LO_INFO,"using GL_EXT_shared_texture_palette\n",glGetString(GL_VENDOR));
- }
-+*/
-
- extension = p;
- } while (*extension != '\0');
-@@ -761,7 +763,7 @@
- pal[transparent_pal_index*4+1]=0;
- pal[transparent_pal_index*4+2]=0;
- pal[transparent_pal_index*4+3]=0;
-- gld_ColorTableEXT(GL_SHARED_TEXTURE_PALETTE_EXT, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
-+// gld_ColorTableEXT(GL_SHARED_TEXTURE_PALETTE_EXT, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
- W_UnlockLumpName("PLAYPAL");
- } else {
- if (palette>0)
---- a/src/gl_texture.c.orig 2003-09-21 16:43:18.450759448 -0400
-+++ b/src/gl_texture.c 2003-09-21 16:43:39.549551944 -0400
-@@ -178,7 +178,7 @@
- pal[transparent_pal_index*4+1]=0;
- pal[transparent_pal_index*4+2]=0;
- pal[transparent_pal_index*4+3]=0;
-- gld_ColorTableEXT(target, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
-+// gld_ColorTableEXT(target, GL_RGBA, 256, GL_RGBA, GL_UNSIGNED_BYTE, pal);
- W_UnlockLumpName("PLAYPAL");
- }
-
diff --git a/games-fps/prboom/metadata.xml b/games-fps/prboom/metadata.xml
deleted file mode 100644
index 55dd7e52946f..000000000000
--- a/games-fps/prboom/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">prboom</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-fps/prboom/prboom-2.5.0-r1.ebuild b/games-fps/prboom/prboom-2.5.0-r1.ebuild
deleted file mode 100644
index 9cb1017bc0a2..000000000000
--- a/games-fps/prboom/prboom-2.5.0-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit desktop readme.gentoo-r1 toolchain-funcs
-
-DESCRIPTION="Port of ID's doom to SDL and OpenGL"
-HOMEPAGE="http://prboom.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RDEPEND="
- media-libs/libsdl[joystick,video]
- media-libs/sdl-mixer
- media-libs/sdl-net
- !<games-fps/lsdldoom-1.5
- virtual/opengl
- virtual/glu
-"
-DEPEND="${RDEPEND}"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="
-To play the original Doom levels, place doom.wad and/or doom2.wad
-into /usr/share/doom-data
-Then run ${PN} accordingly.
-
-doom1.wad is the shareware demo wad consisting of 1 episode,
-and doom.wad is the full Doom 1 set of 3 episodes
-(or 4 in the Ultimate Doom wad).
-
-You can even emerge doom-data and/or freedoom to play for free.
-"
-
-src_prepare() {
- default
-
- ebegin "Detecting NVidia GL/prboom bug"
- $(tc-getCC) "${FILESDIR}"/${P}-nvidia-test.c 2> /dev/null
- local ret=$?
- eend ${ret} "NVidia GL/prboom bug found ;("
- [ ${ret} -eq 0 ] || eapply "${FILESDIR}"/${P}-nvidia.patch
-
- eapply "${FILESDIR}"/${P}-libpng14.patch
-
- sed -i \
- -e '/^gamesdir/ s/\/games/\/bin/' \
- src/Makefile.in \
- || die "sed failed"
- sed -i \
- -e 's/: install-docDATA/:/' \
- -e '/^SUBDIRS/ s/doc//' \
- Makefile.in \
- || die "sed failed"
- sed -i \
- -e 's:-ffast-math $CFLAGS_OPT::' \
- configure \
- || die "sed configure failed"
-}
-
-src_configure() {
- # leave --disable-cpu-opt in otherwise the configure script
- # will append -march=i686 and crap ... let the user's CFLAGS
- # handle this ...
- econf \
- --enable-gl \
- --disable-i386-asm \
- --disable-cpu-opt \
- --with-waddir="/usr/share/doom-data"
-}
-
-src_install() {
- default
-
- doman doc/*.{5,6}
-
- dodoc doc/README.* doc/*.txt
- readme.gentoo_create_doc
-
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} "PrBoom"
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}