summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /games-fps
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom-data/doom-data-1.9.ebuild26
-rw-r--r--games-fps/freedm-data/Manifest3
-rw-r--r--games-fps/freedm-data/freedm-data-0.11.3.ebuild28
-rw-r--r--games-fps/freedm-data/metadata.xml36
-rw-r--r--games-fps/freedm/Manifest2
-rw-r--r--games-fps/freedm/freedm-0.11.3.ebuild24
-rw-r--r--games-fps/freedm/metadata.xml36
-rw-r--r--games-fps/freedoom-data/Manifest3
-rw-r--r--games-fps/freedoom-data/freedoom-data-0.11.3.ebuild29
-rw-r--r--games-fps/freedoom-data/metadata.xml42
-rw-r--r--games-fps/freedoom/freedoom-0.11.3-r1.ebuild24
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.1.3-install_soundfonts.patch34
12 files changed, 287 insertions, 0 deletions
diff --git a/games-fps/doom-data/doom-data-1.9.ebuild b/games-fps/doom-data/doom-data-1.9.ebuild
new file mode 100644
index 000000000000..73c1f9cd04d5
--- /dev/null
+++ b/games-fps/doom-data/doom-data-1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The IWAD used by the shareware version of Doom"
+HOMEPAGE="http://www.idsoftware.com"
+SRC_URI="http://distro.ibiblio.org/pub/linux/distributions/slitaz/sources/packages/d/doom1.wad"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+S="${DISTDIR}"
+
+DOOMWADPATH="/usr/share/doom"
+
+src_install() {
+ insinto ${DOOMWADPATH}
+ doins doom1.wad
+}
+
+pkg_postinst() {
+ elog "Doom WAD file installed into the ${DOOMWADPATH} directory."
+ elog "A Doom engine is required in order to play the doom1.wad file."
+}
diff --git a/games-fps/freedm-data/Manifest b/games-fps/freedm-data/Manifest
new file mode 100644
index 000000000000..7975d84ec2f7
--- /dev/null
+++ b/games-fps/freedm-data/Manifest
@@ -0,0 +1,3 @@
+DIST freedm-0.11.3.zip 7853186 BLAKE2B 5f399233e0d1f1c61d8170dc8e13ca0c6efe79255a87511027ad69e9ab7cf21045e9bc7f40fec6fa3604b3c77590cde8e85b2e9a53e1d89c5aeaf67bffa7023e SHA512 263f126e519a883b828b4f321363fe0f8c557ae58b76c6b3e28aa60e86c15fcc78c866bf003fc523276cefbb431023de64f09b026e85b0a0c7c85a88d1f47cd0
+EBUILD freedm-data-0.11.3.ebuild 588 BLAKE2B 58f96cb841b50dc6d8042d3d5f891a689dbefff0ed38ad284ad5278dc70cadc23c2374d6465dbbceba0654c4ab18171b9885eeb65a1e4696b1e09c066dbf9979 SHA512 6ee871e952c8cbcdeba69b807bca9bba5532f077954429db08f82ed05bb65285c1756423f0aaccdd1ba99c5e42a60593a9ea50e0ca0629a015edba0ab831b4b7
+MISC metadata.xml 1480 BLAKE2B 0755aba8cc597778e420a8142e5febd305e317057870abdaa2f5761e2b45f86c139f63aa096fdb20a5984552d886b47ba7b458ed7f3e971ce4442d03f31e75f9 SHA512 d5847035c6bfa72c3af95a8af203df5909236616726a474dcc33c051de8149f82f4d8c9d1bc8be05b6b05ae1f3a8ec3064f400aa120a6c87d43358ab2e7e20f3
diff --git a/games-fps/freedm-data/freedm-data-0.11.3.ebuild b/games-fps/freedm-data/freedm-data-0.11.3.ebuild
new file mode 100644
index 000000000000..43ac7804c6a0
--- /dev/null
+++ b/games-fps/freedm-data/freedm-data-0.11.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Game resources for FreeDM"
+HOMEPAGE="https://freedoom.github.io"
+SRC_URI="https://github.com/freedoom/freedoom/releases/download/v${PV}/freedm-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/freedm-${PV}"
+
+DOOMWADPATH=/usr/share/doom
+
+src_install() {
+ insinto ${DOOMWADPATH}
+ doins freedm.wad
+ dodoc CREDITS.txt README.html
+}
+
+pkg_postinst() {
+ elog "FreeDM WAD file installed into ${DOOMWADPATH} directory."
+}
diff --git a/games-fps/freedm-data/metadata.xml b/games-fps/freedm-data/metadata.xml
new file mode 100644
index 000000000000..5a1b13afef99
--- /dev/null
+++ b/games-fps/freedm-data/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ FreeDM is a fast-paced competitive deathmatch game, part of the Freedoom
+ project. Rather than the usual single-player focused levels, these
+ contain no monsters and are intended for deathmatch only. It is
+ compatible with mods for Doom II.
+
+ The Freedoom project aims to create a complete free content first person
+ shooter game. But Freedoom by itself is just the raw material for a
+ game: it must be paired with a compatible game engine to be played.
+
+ id Software released the source code to their classic game, Doom, under
+ the GNU General Public License. This means that the program code that
+ powers Doom is free; Freedoom complements this with free levels,
+ artwork, sound effects and music to make a completely free game.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/freedoom/freedoom/issues</bugs-to>
+ <doc lang="en">https://freedoom.github.io</doc>
+ <remote-id type="github">freedoom/freedoom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/freedm/Manifest b/games-fps/freedm/Manifest
new file mode 100644
index 000000000000..92857b013f94
--- /dev/null
+++ b/games-fps/freedm/Manifest
@@ -0,0 +1,2 @@
+EBUILD freedm-0.11.3.ebuild 501 BLAKE2B d7be8788f8f6fb27c630d80ff569a5cb929e443b482166766197cfbd53fcb7a5c3ab952c454600238d58e48428f551a9bd95da0e0a9c655c73cba06e8252eeb8 SHA512 dd5445fc21c0297495e4fba90894fee5ff1c358f270de8611b13b0591478c476de3ab917246ff07451f8068f3052df2d901e6e66f842b341851a070b8fa1e5f4
+MISC metadata.xml 1480 BLAKE2B 0755aba8cc597778e420a8142e5febd305e317057870abdaa2f5761e2b45f86c139f63aa096fdb20a5984552d886b47ba7b458ed7f3e971ce4442d03f31e75f9 SHA512 d5847035c6bfa72c3af95a8af203df5909236616726a474dcc33c051de8149f82f4d8c9d1bc8be05b6b05ae1f3a8ec3064f400aa120a6c87d43358ab2e7e20f3
diff --git a/games-fps/freedm/freedm-0.11.3.ebuild b/games-fps/freedm/freedm-0.11.3.ebuild
new file mode 100644
index 000000000000..342ceb06a7fe
--- /dev/null
+++ b/games-fps/freedm/freedm-0.11.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A 32-level game designed for competitive deathmatch play."
+HOMEPAGE="https://freedoom.github.io"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ~games-fps/freedm-data-${PV}
+ || (
+ games-fps/gzdoom
+ games-engines/odamex
+ games-fps/doomsday
+ )
+"
+
+pkg_postinst() {
+ elog "If you are looking for a single-player focused game, please install games-fps/freedoom."
+}
diff --git a/games-fps/freedm/metadata.xml b/games-fps/freedm/metadata.xml
new file mode 100644
index 000000000000..5a1b13afef99
--- /dev/null
+++ b/games-fps/freedm/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ FreeDM is a fast-paced competitive deathmatch game, part of the Freedoom
+ project. Rather than the usual single-player focused levels, these
+ contain no monsters and are intended for deathmatch only. It is
+ compatible with mods for Doom II.
+
+ The Freedoom project aims to create a complete free content first person
+ shooter game. But Freedoom by itself is just the raw material for a
+ game: it must be paired with a compatible game engine to be played.
+
+ id Software released the source code to their classic game, Doom, under
+ the GNU General Public License. This means that the program code that
+ powers Doom is free; Freedoom complements this with free levels,
+ artwork, sound effects and music to make a completely free game.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/freedoom/freedoom/issues</bugs-to>
+ <doc lang="en">https://freedoom.github.io</doc>
+ <remote-id type="github">freedoom/freedoom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/freedoom-data/Manifest b/games-fps/freedoom-data/Manifest
new file mode 100644
index 000000000000..b667bef450be
--- /dev/null
+++ b/games-fps/freedoom-data/Manifest
@@ -0,0 +1,3 @@
+DIST freedoom-0.11.3.zip 18889307 BLAKE2B 052d7f58d1beb7947f4fff3021ec0229c9746bfb7970a52d23fa44fc881d8cf3c314b8ecf0dc400c2da4e28c623695874ae75dcd1e45933fdb1826ea04f0e24b SHA512 c67fc69bca87cba2ba40b91f578724feaabbd6cd64c6845fa567d6901b7a9e3145185011731c677a71f7b5a6f8707855fb573c0c09b6d47fef83b1577b211816
+EBUILD freedoom-data-0.11.3.ebuild 632 BLAKE2B a65af31246cf206f39dfd031caffa57a04b35f3cec7471a2515ed4b35646ea6f13c3ec2ee66dbdadbbe61d15af0f3cf871f69b1ffd28fd8c9defeeaa7b10a81f SHA512 b2c47cfed880ab80ff4c8ceaa0926871ace5fe4cd2d812922273466c91125cf7e1f64e3543c74c77750be9873c0cbe6cd5a144f90bc01ead6e3576e977289425
+MISC metadata.xml 1809 BLAKE2B 84960851e0fcb2354c71c796ebd28f3c1bea2762e1810d851c04d375cbc90bf6a6cddd9629f802829bb495cea44260b352291e2d3adbb17516c8cb97697da450 SHA512 a1e68567ab9be93d88e5debbba73e2704e5ef9f063bc98f30bc480064e9037b3841fdd3cec24a8f61ba0c76a68d20b63a329dd880d8c99a8c11a3ba39c3de89d
diff --git a/games-fps/freedoom-data/freedoom-data-0.11.3.ebuild b/games-fps/freedoom-data/freedoom-data-0.11.3.ebuild
new file mode 100644
index 000000000000..5e38d534c7e2
--- /dev/null
+++ b/games-fps/freedoom-data/freedoom-data-0.11.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Game resources for Freedoom: Phase 1+2"
+HOMEPAGE="https://freedoom.github.io"
+SRC_URI="https://github.com/freedoom/freedoom/releases/download/v${PV}/freedoom-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/freedoom-${PV}"
+
+DOOMWADPATH=/usr/share/doom
+
+src_install() {
+ insinto ${DOOMWADPATH}
+ doins freedoom1.wad
+ doins freedoom2.wad
+ dodoc CREDITS.txt README.html
+}
+
+pkg_postinst() {
+ elog "Freedoom WAD files installed into ${DOOMWADPATH} directory."
+}
diff --git a/games-fps/freedoom-data/metadata.xml b/games-fps/freedoom-data/metadata.xml
new file mode 100644
index 000000000000..08a722785b1d
--- /dev/null
+++ b/games-fps/freedoom-data/metadata.xml
@@ -0,0 +1,42 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ The Freedoom project aims to create a complete free content first person
+ shooter game. But Freedoom by itself is just the raw material for a
+ game: it must be paired with a compatible game engine to be played.
+
+ id Software released the source code to their classic game, Doom, under
+ the GNU General Public License. This means that the program code that
+ powers Doom is free; Freedoom complements this with free levels,
+ artwork, sound effects and music to make a completely free game.
+
+ Phase 1 is the first part of the single-player game, containing four
+ chapters which are nine levels each, smoothly paced for beginner
+ players. It is compatible with mods for the original Doom and The
+ Ultimate Doom.
+
+ Phase 2 is the second major part of the single-player game, a massive
+ 32-level chapter expanding upon the same concepts present in Phase 1, as
+ well as containing additional monsters and the double-barreled shotgun!
+ The levels in this game tend to demand more skillful play than the
+ previous chapters. It is compatible with mods for Doom II.
+ </longdescription>
+ <maintainer type="person">
+ <email>vilhelm.gray@gmail.com</email>
+ <name>William Breathitt Gray</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/freedoom/freedoom/issues</bugs-to>
+ <doc lang="en">https://freedoom.github.io</doc>
+ <remote-id type="github">freedoom/freedoom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/freedoom/freedoom-0.11.3-r1.ebuild b/games-fps/freedoom/freedoom-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..2f5fd2f5c58a
--- /dev/null
+++ b/games-fps/freedoom/freedoom-0.11.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A complete free-content single-player focused game based on the Doom engine"
+HOMEPAGE="https://freedoom.github.io"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ ~games-fps/freedoom-data-${PV}
+ || (
+ games-fps/gzdoom
+ games-engines/odamex
+ games-fps/doomsday
+ )
+"
+
+pkg_postinst() {
+ elog "If you are looking for a multiplayer-focused deathmatch game, please install games-fps/freedm."
+}
diff --git a/games-fps/gzdoom/files/gzdoom-4.1.3-install_soundfonts.patch b/games-fps/gzdoom/files/gzdoom-4.1.3-install_soundfonts.patch
new file mode 100644
index 000000000000..1fe0b99d9a8e
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.1.3-install_soundfonts.patch
@@ -0,0 +1,34 @@
+From 2d1c7ba17cac3ccd201e77ad01a9dd06ab22cb2e Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Thu, 13 Jun 2019 18:01:08 +0900
+Subject: [PATCH] Install soundfonts and WOPL/WOPN banks
+
+The INSTALL_SOUNDFONT_PATH cache entry is used to configure the
+installation directory.
+---
+ src/CMakeLists.txt | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 0bb16f39e..4ff15062d 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1451,6 +1451,15 @@ add_custom_command(TARGET zdoom POST_BUILD
+ ${CMAKE_SOURCE_DIR}/fm_banks/gs-by-papiezak-and-sneakernets.wopn $<TARGET_FILE_DIR:zdoom>/fm_banks/gs-by-papiezak-and-sneakernets.wopn
+ )
+
++if( WIN32 )
++ set( INSTALL_SOUNDFONT_PATH . CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++else()
++ set( INSTALL_SOUNDFONT_PATH share/games/doom CACHE STRING "Directory where soundfonts and WOPL/WOPN banks will be placed during install." )
++endif()
++install(FILES "${PROJECT_BINARY_DIR}/soundfonts" "${PROJECT_BINARY_DIR}/fm_banks"
++ DESTINATION ${INSTALL_SOUNDFONT_PATH}
++ COMPONENT "Soundfont resources")
++
+ if( CMAKE_COMPILER_IS_GNUCXX )
+ # GCC misoptimizes this file
+ set_source_files_properties( oplsynth/fmopl.cpp PROPERTIES COMPILE_FLAGS "-fno-tree-dominator-opts -fno-tree-fre" )
+--
+2.21.0
+