summaryrefslogtreecommitdiff
path: root/games-fps/serioussam-tfe-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
commita2210d6624510ad5825191a26603b73bbc096b98 (patch)
tree532ae6f32e362993fd926b040ad57cabe1c8d4e8 /games-fps/serioussam-tfe-data
parent7ab79528a3e9a77497eb58022bb0e775e7440885 (diff)
gentoo auto-resync : 27:12:2023 - 01:38:47
Diffstat (limited to 'games-fps/serioussam-tfe-data')
-rw-r--r--games-fps/serioussam-tfe-data/Manifest3
-rw-r--r--games-fps/serioussam-tfe-data/metadata.xml15
-rw-r--r--games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild70
3 files changed, 88 insertions, 0 deletions
diff --git a/games-fps/serioussam-tfe-data/Manifest b/games-fps/serioussam-tfe-data/Manifest
new file mode 100644
index 000000000000..813ccd095beb
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/Manifest
@@ -0,0 +1,3 @@
+DIST serioussamfe-patch_1.05_FE.tar.xz 1221836 BLAKE2B 0ae7103151ee42f3c1ff88afd2d77037e0c3e5c49c19adf213068f87eed524c7aa6552d020c3337f5457847f167c1a2e4ca1fda7572e96b9630fb2dbfd3e6b0f SHA512 18c5a5f66e1fbe3864eca3274d20e525f50c223507e0c1c793a642aed66edfeb723cf3d4ffc583afa4d9a10388cbed14af7035bf6a1b9c214dac79c5eb1d2548
+EBUILD serioussam-tfe-data-1.5-r1.ebuild 2173 BLAKE2B ffa108888e2b922e49e1eb52544643865868e271268d379ddc6fcc84ba1786f47b7d1d4378e4a4725a06c67408f90735be676bd2669175738a026bdd2e18eb4f SHA512 bcfbb7aecbe576ac138a418a62d4da2f446b53d5daf14fc8f66bbe730a7c0ea0c5511530d60f8afd93c9489ec43ae277aaf7c3b53ee4539c3ba887676d010e9f
+MISC metadata.xml 491 BLAKE2B 0bd3ad81a3be5b29a638c2e725fb39152da9e74941e984733d62f40888e0aad1169feb24396d60adbda4b9eec909796a35327bab23ababf1d7f89a7f84ae049e SHA512 974012a7a5edb7291417f645c22b1c0071bcc00a5ad2a8dceded814343cd415197cf66e35599bc6b1099c1cbd0e419ef82af2580519957acc4e8c9066b883937
diff --git a/games-fps/serioussam-tfe-data/metadata.xml b/games-fps/serioussam-tfe-data/metadata.xml
new file mode 100644
index 000000000000..e76bc72b6a01
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tx00100xt/serioussam-mods</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild b/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild
new file mode 100644
index 000000000000..8b0b3f73ea37
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cdrom unpacker
+
+# Game name
+GN="serioussam"
+PATCH_PREFIX="${GN}fe-patch_1.05_FE"
+
+DESCRIPTION="Croteam's Serious Sam Classic The First Encounter ... the data files"
+HOMEPAGE="https://www.croteam.com/
+ https://store.steampowered.com/app/41050/Serious_Sam_Classic_The_First_Encounter/"
+SRC_URI="https://github.com/tx00100xt/serioussam-mods/raw/main/Patches/${PATCH_PREFIX}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist"
+
+pkg_setup() {
+ cdrom_get_cds "Install/1_00_music.gro"
+}
+
+src_unpack() {
+ mkdir Levels Mods || die "failed create dirs"
+ cat "${DISTDIR}/${PATCH_PREFIX}.tar.xz" > "${PATCH_PREFIX}.tar.xz" \
+ || die "failed to copy patch 1.05"
+ unpack "${WORKDIR}/${PATCH_PREFIX}.tar.xz"
+}
+
+src_install() {
+ local dir="/usr/share/${GN}"
+
+ einfo "Copying from ${CDROM_ROOT}"
+ insinto "${dir}"
+ doins -r "${CDROM_ROOT}"/Install/*
+
+ mv "${WORKDIR}"/*.gro "${ED}${dir}" || die "failed to moved patch 1.05"
+ mv "${ED}${dir}"/Scripts/PersistentSymbols.ini "${WORKDIR}" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ rm -rf \
+ "${ED}${dir}"/{Bin,Controls,Data,Demos,Mods,Players,Scripts} \
+ || die "failed to remove directories"
+ rm -rf \
+ "${ED}${dir}"/{VirtualTrees,Locales,Help/ShellSymbols.txt} \
+ || die "failed to remove directories"
+ mkdir "${ED}${dir}/Scripts" || die "failed create Scripts dir"
+ mv "${WORKDIR}"/PersistentSymbols.ini "${ED}${dir}/Scripts" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ # Remove useless Windows files
+ rm -f "${ED}${dir}"/{*.exe,*.ex_,*.bmp,*.inx,*.hdr,*.bin,*.cab,*.ini,*.log} \
+ || die "Failed to remove windows cruft"
+
+ # Ensure that file datestamps from the CD are sane
+ find "${ED}${dir}"/Levels -exec touch -d '09 May 2020 14:00' '{}' \; \
+ || die "touch failed"
+}
+
+pkg_postinst() {
+ elog "Important information about the Linux port is at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " look at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information about of the game"
+}