summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 01:38:47 +0000
commita2210d6624510ad5825191a26603b73bbc096b98 (patch)
tree532ae6f32e362993fd926b040ad57cabe1c8d4e8 /games-fps
parent7ab79528a3e9a77497eb58022bb0e775e7440885 (diff)
gentoo auto-resync : 27:12:2023 - 01:38:47
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/Manifest.gzbin11884 -> 12371 bytes
-rw-r--r--games-fps/serioussam-tfe-data/Manifest3
-rw-r--r--games-fps/serioussam-tfe-data/metadata.xml15
-rw-r--r--games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild70
-rw-r--r--games-fps/serioussam-tse-data/Manifest3
-rw-r--r--games-fps/serioussam-tse-data/metadata.xml15
-rw-r--r--games-fps/serioussam-tse-data/serioussam-tse-data-1.7-r1.ebuild70
-rw-r--r--games-fps/serioussam/Manifest3
-rw-r--r--games-fps/serioussam/metadata.xml22
-rw-r--r--games-fps/serioussam/serioussam-1.10.6.ebuild106
10 files changed, 307 insertions, 0 deletions
diff --git a/games-fps/Manifest.gz b/games-fps/Manifest.gz
index df3bca4c2298..eb7cbe39398f 100644
--- a/games-fps/Manifest.gz
+++ b/games-fps/Manifest.gz
Binary files differ
diff --git a/games-fps/serioussam-tfe-data/Manifest b/games-fps/serioussam-tfe-data/Manifest
new file mode 100644
index 000000000000..813ccd095beb
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/Manifest
@@ -0,0 +1,3 @@
+DIST serioussamfe-patch_1.05_FE.tar.xz 1221836 BLAKE2B 0ae7103151ee42f3c1ff88afd2d77037e0c3e5c49c19adf213068f87eed524c7aa6552d020c3337f5457847f167c1a2e4ca1fda7572e96b9630fb2dbfd3e6b0f SHA512 18c5a5f66e1fbe3864eca3274d20e525f50c223507e0c1c793a642aed66edfeb723cf3d4ffc583afa4d9a10388cbed14af7035bf6a1b9c214dac79c5eb1d2548
+EBUILD serioussam-tfe-data-1.5-r1.ebuild 2173 BLAKE2B ffa108888e2b922e49e1eb52544643865868e271268d379ddc6fcc84ba1786f47b7d1d4378e4a4725a06c67408f90735be676bd2669175738a026bdd2e18eb4f SHA512 bcfbb7aecbe576ac138a418a62d4da2f446b53d5daf14fc8f66bbe730a7c0ea0c5511530d60f8afd93c9489ec43ae277aaf7c3b53ee4539c3ba887676d010e9f
+MISC metadata.xml 491 BLAKE2B 0bd3ad81a3be5b29a638c2e725fb39152da9e74941e984733d62f40888e0aad1169feb24396d60adbda4b9eec909796a35327bab23ababf1d7f89a7f84ae049e SHA512 974012a7a5edb7291417f645c22b1c0071bcc00a5ad2a8dceded814343cd415197cf66e35599bc6b1099c1cbd0e419ef82af2580519957acc4e8c9066b883937
diff --git a/games-fps/serioussam-tfe-data/metadata.xml b/games-fps/serioussam-tfe-data/metadata.xml
new file mode 100644
index 000000000000..e76bc72b6a01
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tx00100xt/serioussam-mods</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild b/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild
new file mode 100644
index 000000000000..8b0b3f73ea37
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cdrom unpacker
+
+# Game name
+GN="serioussam"
+PATCH_PREFIX="${GN}fe-patch_1.05_FE"
+
+DESCRIPTION="Croteam's Serious Sam Classic The First Encounter ... the data files"
+HOMEPAGE="https://www.croteam.com/
+ https://store.steampowered.com/app/41050/Serious_Sam_Classic_The_First_Encounter/"
+SRC_URI="https://github.com/tx00100xt/serioussam-mods/raw/main/Patches/${PATCH_PREFIX}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist"
+
+pkg_setup() {
+ cdrom_get_cds "Install/1_00_music.gro"
+}
+
+src_unpack() {
+ mkdir Levels Mods || die "failed create dirs"
+ cat "${DISTDIR}/${PATCH_PREFIX}.tar.xz" > "${PATCH_PREFIX}.tar.xz" \
+ || die "failed to copy patch 1.05"
+ unpack "${WORKDIR}/${PATCH_PREFIX}.tar.xz"
+}
+
+src_install() {
+ local dir="/usr/share/${GN}"
+
+ einfo "Copying from ${CDROM_ROOT}"
+ insinto "${dir}"
+ doins -r "${CDROM_ROOT}"/Install/*
+
+ mv "${WORKDIR}"/*.gro "${ED}${dir}" || die "failed to moved patch 1.05"
+ mv "${ED}${dir}"/Scripts/PersistentSymbols.ini "${WORKDIR}" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ rm -rf \
+ "${ED}${dir}"/{Bin,Controls,Data,Demos,Mods,Players,Scripts} \
+ || die "failed to remove directories"
+ rm -rf \
+ "${ED}${dir}"/{VirtualTrees,Locales,Help/ShellSymbols.txt} \
+ || die "failed to remove directories"
+ mkdir "${ED}${dir}/Scripts" || die "failed create Scripts dir"
+ mv "${WORKDIR}"/PersistentSymbols.ini "${ED}${dir}/Scripts" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ # Remove useless Windows files
+ rm -f "${ED}${dir}"/{*.exe,*.ex_,*.bmp,*.inx,*.hdr,*.bin,*.cab,*.ini,*.log} \
+ || die "Failed to remove windows cruft"
+
+ # Ensure that file datestamps from the CD are sane
+ find "${ED}${dir}"/Levels -exec touch -d '09 May 2020 14:00' '{}' \; \
+ || die "touch failed"
+}
+
+pkg_postinst() {
+ elog "Important information about the Linux port is at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " look at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information about of the game"
+}
diff --git a/games-fps/serioussam-tse-data/Manifest b/games-fps/serioussam-tse-data/Manifest
new file mode 100644
index 000000000000..2fa76d6d7639
--- /dev/null
+++ b/games-fps/serioussam-tse-data/Manifest
@@ -0,0 +1,3 @@
+DIST serioussamse-patch_1.07_SE.tar.xz 33172 BLAKE2B bc185d0b504e7aa01862a57ba97691881e19d0031ac88187ec80fb52d8bd758c0dac6b932a333fa4f9df09264232ab87e97875a8ae7a58cd0816153a082ffc45 SHA512 1c0e2ac2503584d26ac7fc59f72b0dcb6903bfc4897acc5732b426fe691928c1f49839b3a893809e635e178e447aa72fb9969179806a1703d412c4ea321ca637
+EBUILD serioussam-tse-data-1.7-r1.ebuild 2189 BLAKE2B 54d92db6459ecf6e2bdafbc3b11cc88db26d96de728a0d617dafa971bada10ddcd97f3b3c61b88c7fa3752dd74debaa88aab9e16050a95693dde955f41828494 SHA512 4998b98abdeeecbaa02378a9f5ffa20a9f6bf7fc04ae869d405c2206119fd36d6663e2fb12b067ef3718476106814d900cbd226ff4c4b743851c2817ba126170
+MISC metadata.xml 491 BLAKE2B 0bd3ad81a3be5b29a638c2e725fb39152da9e74941e984733d62f40888e0aad1169feb24396d60adbda4b9eec909796a35327bab23ababf1d7f89a7f84ae049e SHA512 974012a7a5edb7291417f645c22b1c0071bcc00a5ad2a8dceded814343cd415197cf66e35599bc6b1099c1cbd0e419ef82af2580519957acc4e8c9066b883937
diff --git a/games-fps/serioussam-tse-data/metadata.xml b/games-fps/serioussam-tse-data/metadata.xml
new file mode 100644
index 000000000000..e76bc72b6a01
--- /dev/null
+++ b/games-fps/serioussam-tse-data/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tx00100xt/serioussam-mods</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam-tse-data/serioussam-tse-data-1.7-r1.ebuild b/games-fps/serioussam-tse-data/serioussam-tse-data-1.7-r1.ebuild
new file mode 100644
index 000000000000..3f46d0d019f9
--- /dev/null
+++ b/games-fps/serioussam-tse-data/serioussam-tse-data-1.7-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cdrom unpacker
+
+# Game name
+GN="serioussamse"
+PATCH_PREFIX="${GN}-patch_1.07_SE"
+
+DESCRIPTION="Croteam's Serious Sam Classic The Second Encounter ... the data files"
+HOMEPAGE="https://www.croteam.com/
+ https://store.steampowered.com/app/41060/Serious_Sam_Classic_The_Second_Encounter/"
+SRC_URI="https://github.com/tx00100xt/serioussam-mods/raw/main/Patches/${PATCH_PREFIX}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist"
+
+pkg_setup() {
+ cdrom_get_cds "Install/SE1_00_Levels.gro"
+}
+
+src_unpack() {
+ mkdir Levels Mods || die "failed create dirs"
+ cat "${DISTDIR}/${PATCH_PREFIX}.tar.xz" > "${PATCH_PREFIX}.tar.xz" \
+ || die "failed to copy patch 1.07"
+ unpack "${WORKDIR}/${PATCH_PREFIX}.tar.xz"
+}
+
+src_install() {
+ local dir="/usr/share/${GN}"
+
+ einfo "Copying from ${CDROM_ROOT}"
+ insinto "${dir}"
+ doins -r "${CDROM_ROOT}"/Install/*
+
+ mv "${WORKDIR}"/*.gro "${ED}${dir}" || die "failed to moved patch 1.07"
+ mv "${ED}${dir}"/Scripts/PersistentSymbols.ini "${WORKDIR}" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ rm -rf \
+ "${ED}${dir}"/{Bin,Controls,Data,Demos,Mods,Players,Scripts,Locales} \
+ || die "failed to remove directories"
+ rm -rf \
+ "${ED}${dir}"/{VirtualTrees,ModEXT.txt,Help/ShellSymbols.txt} \
+ || die "failed to remove directories"
+ mkdir "${ED}${dir}/Scripts" || die "failed create Scripts dir"
+ mv "${WORKDIR}"/PersistentSymbols.ini "${ED}${dir}/Scripts" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ # Remove useless Windows files
+ rm -f "${ED}${dir}"/{*.exe,*.ex_,*.bmp,*.inx,*.hdr,*.bin,*.cab,*.ini,*.log} \
+ || die "Failed to remove windows cruft"
+
+ # Ensure that file datestamps from the CD are sane
+ find "${ED}${dir}"/Levels -exec touch -d '09 May 2020 14:00' '{}' \; \
+ || die "touch failed"
+}
+
+pkg_postinst() {
+ elog "Important information about the Linux port is at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " look at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information about of the game"
+}
diff --git a/games-fps/serioussam/Manifest b/games-fps/serioussam/Manifest
new file mode 100644
index 000000000000..d2a7641c9520
--- /dev/null
+++ b/games-fps/serioussam/Manifest
@@ -0,0 +1,3 @@
+DIST serioussam-1.10.6c.tar.gz 47908208 BLAKE2B 90af9f8c11b474ce0e114c3390e1afd5c746c1b2ca4e61bd6085f1dc42f6f73981cc4434ff8fdcc1306178ae9d2707026765a3a1da006d5adb841d2d314a4214 SHA512 de1ba536c84977d1e7335833b8a2080b13a22ca25efba88363972dceb4bcbfda1db448de42d262fa003fe9df393327509e76afc3cc501f96ed6495d29b74b6bb
+EBUILD serioussam-1.10.6.ebuild 3053 BLAKE2B 02bfe75c9f094a5a4b29592ff652f62bc010120c19838b4bd396f1a26b894c7ed7425023cf458503056d315411becd47d0fdef4ca1672e9ec5c3e4443a480c5b SHA512 a29ce2a5bd037fd49a04e858363044b22c41541ce00aa2debcff31b358cd31f382deb0b887bd3efadc9d5e124dd3e01f125dc8800457f88cd7868cffbb44df49
+MISC metadata.xml 846 BLAKE2B 59dd6e1ebcb1b9e4c19271f53f8564a003b78627640312b18a0e52b686d59878b6b00fd946803df40c8b4a9e60fcc85886d11d318c3f0d4be3544aa5d9f4be9b SHA512 80a0b25d6d0f2dd23b030179e17c55d6d8b42b5bd8aa68103eee6250e228d0860d35d8b98e6c833156ee0fbe7b2663a988469362631ce218a657f742b8463a91
diff --git a/games-fps/serioussam/metadata.xml b/games-fps/serioussam/metadata.xml
new file mode 100644
index 000000000000..c9c22cde71e7
--- /dev/null
+++ b/games-fps/serioussam/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="alsa">Enable support ALSA sound.</flag>
+ <flag name="pipewire">Enable support for pipewire.</flag>
+ <flag name="vulkan">Enable support Vulkan render.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">tx00100xt/SeriousSamClassic-VK</remote-id>
+ <bugs-to>https://github.com/tx00100xt/SeriousSamClassic-VK/issues</bugs-to>
+ <changelog>https://github.com/tx00100xt/SeriousSamClassic-VK/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam/serioussam-1.10.6.ebuild b/games-fps/serioussam/serioussam-1.10.6.ebuild
new file mode 100644
index 000000000000..5b9b2d1a433d
--- /dev/null
+++ b/games-fps/serioussam/serioussam-1.10.6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop
+
+MY_PN1="SamTFE"
+MY_PN2="SamTSE"
+# Game name
+GN1="serioussam"
+GN2="serioussamse"
+
+DESCRIPTION="Linux port of Serious Sam Classic with Vulkan support"
+HOMEPAGE="https://github.com/tx00100xt/SeriousSamClassic-VK"
+SRC_URI="https://github.com/tx00100xt/SeriousSamClassic-VK/archive/refs/tags/${PV}c.tar.gz -> ${P}c.tar.gz"
+S="${WORKDIR}/SeriousSamClassic-VK-${PV}c"
+
+MY_CONTENT1="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN1}"
+MY_CONTENT2="${WORKDIR}/SeriousSamClassic-VK-${PV}c/${MY_PN2}"
+
+LICENSE="GPL-2 BSD ZLIB"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa pipewire vulkan"
+
+RDEPEND="
+ games-fps/serioussam-tfe-data
+ games-fps/serioussam-tse-data
+ media-libs/libsdl2[video,joystick,opengl]
+ media-libs/libvorbis
+ sys-libs/zlib
+ alsa? (
+ >=media-libs/libsdl2-2.0.6[alsa,sound]
+ )
+ pipewire? (
+ >=media-libs/libsdl2-2.0.6[pipewire,sound]
+ )
+ vulkan? (
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ media-libs/libsdl2[video,joystick,opengl,vulkan]
+ )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/flex
+ sys-devel/bison
+ media-gfx/imagemagick
+"
+
+src_configure() {
+ einfo "Remove Win32 stuff..."
+ rm -rf "${MY_CONTENT1}"/Tools.Win32 || die "Failed to remove stuff Win32"
+ rm -rf "${MY_CONTENT2}"/Tools.Win32 || die "Failed to remove stuff Win32"
+
+ einfo "Setting build type Release..."
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(
+ -DUSE_SYSTEM_INSTALL=ON
+ -DUSE_SYSTEM_VULKAN=$(usex vulkan ON OFF)
+ -DUSE_ASM=$(usex x86 OFF ON)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local dir1="/usr/share/${GN1}"
+ local dir2="/usr/share/${GN2}"
+ local dir3="/usr/share/applications"
+ cmake_src_install
+
+ # install man pages
+ mv "${S}"/man/gentoo/serioussam-vk.1 "${S}"/man/gentoo/serioussam.1 \
+ || die "Failed move man pages"
+ doman "${S}"/man/gentoo/serioussam.1
+
+ # removing repo stuff
+ rm -fr "${MY_CONTENT1}/Sources" && rm -fr "${MY_CONTENT2}/Sources" \
+ || die "Failed to remove Sources"
+ rm -f "${MY_CONTENT1}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussam icon and desktop file"
+ rm -f "${MY_CONTENT2}"/{*.png,*.desktop} \
+ || die "Failed to remove serioussamse icon and desktop file"
+ rm -f "${ED}${dir3}/${GN1}.desktop" "${ED}${dir3}/${GN2}.desktop" \
+ || die "Failed to remove desktop file"
+
+ # moving repo content (Scripts, Data, Settings ...)
+ cp -fr "${MY_CONTENT1}"/* "${ED}${dir1}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+ cp -fr "${MY_CONTENT2}"/* "${ED}${dir2}" \
+ || die "Failed to copy repo content (Scripts, Settings)"
+
+ make_desktop_entry ${GN1} "Serious Sam The First Encounter" ${GN1}
+ make_desktop_entry ${GN2} "Serious Sam The Second Encounter" ${GN2}
+}
+
+pkg_postinst() {
+ elog " Look at:"
+ elog " man serioussam"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information on the first launch of the game"
+}