summaryrefslogtreecommitdiff
path: root/games-fps/alephone-durandal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
commit048bd060badd229e3bb596029874760a86d27060 (patch)
tree255c77a2abedb5474cd77d0b3cac24551de7771d /games-fps/alephone-durandal
parent8993ea73a9714d22178ba6ada8c04be83cd71ec7 (diff)
gentoo auto-resync : 30:08:2022 - 04:47:47
Diffstat (limited to 'games-fps/alephone-durandal')
-rw-r--r--games-fps/alephone-durandal/Manifest3
-rw-r--r--games-fps/alephone-durandal/alephone-durandal-20220115.ebuild37
-rw-r--r--games-fps/alephone-durandal/metadata.xml16
3 files changed, 56 insertions, 0 deletions
diff --git a/games-fps/alephone-durandal/Manifest b/games-fps/alephone-durandal/Manifest
new file mode 100644
index 000000000000..10671a39311b
--- /dev/null
+++ b/games-fps/alephone-durandal/Manifest
@@ -0,0 +1,3 @@
+DIST Marathon2-20220115-Data.zip 29710307 BLAKE2B eadf9dac7ad9bedec5b4484c74b5bc4c342223d209af0a4ce90c58649833642c8127a7c21ec87efe1d6229018d6b1002ca1a63b5ed8634103547796e1750c559 SHA512 3f259a865bd9d3709fdc79722e5b0cffd3ddfec981310a00898d2a1348c6b2ffcee0fe36a8ef2da26f235e800703e24ab8f33fbfb3ed8f96a6fc46f84808700f
+EBUILD alephone-durandal-20220115.ebuild 890 BLAKE2B 8cd86943fcc9c7e9465b964286761a59a60e6a31d67fecfd88ea7ae0aebd5b32e1098525fc66c99b47b355349b5c84abc61f73f7964fc18727be38c6bf8b7295 SHA512 61c3e01b32fe0a07ef74b5f1de57d56bdde1d8bb73f0d98e3ba13c49a08cfdc327531785144f9718efe863b72a32906fa851fed1d40e2cf0d8ad062e675284d9
+MISC metadata.xml 510 BLAKE2B 585a78c69b8ffff8640baa9eb39fe66a3115cc004da917eeb37573b1ae816e399a63ed5f043d547bcd7e59499c670e5063da56356e00c78cc22df039f11d8a09 SHA512 95337185f46c35a2f8022a1acc00bbebc8174472bcda28dae1a58acd2c314081a0451ef9a6a348390ac908eb249ede97721cf43b21f8ff1984e74f1ea63a6f5e
diff --git a/games-fps/alephone-durandal/alephone-durandal-20220115.ebuild b/games-fps/alephone-durandal/alephone-durandal-20220115.ebuild
new file mode 100644
index 000000000000..3815c515b226
--- /dev/null
+++ b/games-fps/alephone-durandal/alephone-durandal-20220115.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon 2 (Durandal)"
+HOMEPAGE="http://marathon.sourceforge.net/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon2-${PV}-Data.zip"
+S="${WORKDIR}/Marathon 2"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="durandal"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}
diff --git a/games-fps/alephone-durandal/metadata.xml b/games-fps/alephone-durandal/metadata.xml
new file mode 100644
index 000000000000..2a5f1108e681
--- /dev/null
+++ b/games-fps/alephone-durandal/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ <remote-id type="sourceforge">marathon</remote-id>
+ </upstream>
+</pkgmetadata>