summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 04:47:47 +0100
commit048bd060badd229e3bb596029874760a86d27060 (patch)
tree255c77a2abedb5474cd77d0b3cac24551de7771d /games-fps
parent8993ea73a9714d22178ba6ada8c04be83cd71ec7 (diff)
gentoo auto-resync : 30:08:2022 - 04:47:47
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/Manifest.gzbin11365 -> 12042 bytes
-rw-r--r--games-fps/alephone-durandal/Manifest3
-rw-r--r--games-fps/alephone-durandal/alephone-durandal-20220115.ebuild37
-rw-r--r--games-fps/alephone-durandal/metadata.xml16
-rw-r--r--games-fps/alephone-infinity/Manifest3
-rw-r--r--games-fps/alephone-infinity/alephone-infinity-20220115.ebuild37
-rw-r--r--games-fps/alephone-infinity/metadata.xml16
-rw-r--r--games-fps/alephone-marathon/Manifest3
-rw-r--r--games-fps/alephone-marathon/alephone-marathon-20220115.ebuild37
-rw-r--r--games-fps/alephone-marathon/metadata.xml16
-rw-r--r--games-fps/alephone/Manifest5
-rw-r--r--games-fps/alephone/alephone-20220115.ebuild90
-rw-r--r--games-fps/alephone/alephone-9999.ebuild90
-rw-r--r--games-fps/alephone/files/alephone.sh28
-rw-r--r--games-fps/alephone/metadata.xml17
15 files changed, 398 insertions, 0 deletions
diff --git a/games-fps/Manifest.gz b/games-fps/Manifest.gz
index c98e19a64265..7818fb6fa2bf 100644
--- a/games-fps/Manifest.gz
+++ b/games-fps/Manifest.gz
Binary files differ
diff --git a/games-fps/alephone-durandal/Manifest b/games-fps/alephone-durandal/Manifest
new file mode 100644
index 000000000000..10671a39311b
--- /dev/null
+++ b/games-fps/alephone-durandal/Manifest
@@ -0,0 +1,3 @@
+DIST Marathon2-20220115-Data.zip 29710307 BLAKE2B eadf9dac7ad9bedec5b4484c74b5bc4c342223d209af0a4ce90c58649833642c8127a7c21ec87efe1d6229018d6b1002ca1a63b5ed8634103547796e1750c559 SHA512 3f259a865bd9d3709fdc79722e5b0cffd3ddfec981310a00898d2a1348c6b2ffcee0fe36a8ef2da26f235e800703e24ab8f33fbfb3ed8f96a6fc46f84808700f
+EBUILD alephone-durandal-20220115.ebuild 890 BLAKE2B 8cd86943fcc9c7e9465b964286761a59a60e6a31d67fecfd88ea7ae0aebd5b32e1098525fc66c99b47b355349b5c84abc61f73f7964fc18727be38c6bf8b7295 SHA512 61c3e01b32fe0a07ef74b5f1de57d56bdde1d8bb73f0d98e3ba13c49a08cfdc327531785144f9718efe863b72a32906fa851fed1d40e2cf0d8ad062e675284d9
+MISC metadata.xml 510 BLAKE2B 585a78c69b8ffff8640baa9eb39fe66a3115cc004da917eeb37573b1ae816e399a63ed5f043d547bcd7e59499c670e5063da56356e00c78cc22df039f11d8a09 SHA512 95337185f46c35a2f8022a1acc00bbebc8174472bcda28dae1a58acd2c314081a0451ef9a6a348390ac908eb249ede97721cf43b21f8ff1984e74f1ea63a6f5e
diff --git a/games-fps/alephone-durandal/alephone-durandal-20220115.ebuild b/games-fps/alephone-durandal/alephone-durandal-20220115.ebuild
new file mode 100644
index 000000000000..3815c515b226
--- /dev/null
+++ b/games-fps/alephone-durandal/alephone-durandal-20220115.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon 2 (Durandal)"
+HOMEPAGE="http://marathon.sourceforge.net/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon2-${PV}-Data.zip"
+S="${WORKDIR}/Marathon 2"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="durandal"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}
diff --git a/games-fps/alephone-durandal/metadata.xml b/games-fps/alephone-durandal/metadata.xml
new file mode 100644
index 000000000000..2a5f1108e681
--- /dev/null
+++ b/games-fps/alephone-durandal/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ <remote-id type="sourceforge">marathon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/alephone-infinity/Manifest b/games-fps/alephone-infinity/Manifest
new file mode 100644
index 000000000000..4f75eeaa9361
--- /dev/null
+++ b/games-fps/alephone-infinity/Manifest
@@ -0,0 +1,3 @@
+DIST MarathonInfinity-20220115-Data.zip 32203483 BLAKE2B c00e1ff6b4fc053e9df7f15711a73fd46f8e978714a7755137d1d9228a11715f5f3f161af17c1bd9d8bb9b6aaa4ae8292f5d007223c0c14b9a37a5f3e466675c SHA512 b37865f9f8e7ec14995e3ef5df8c3b3a8badc12fc1dc2388beaad90863e40f4fc589a08482e11a9ab21b7b1659c2248a340083ae0d0166689a4377a07d3c03ae
+EBUILD alephone-infinity-20220115.ebuild 900 BLAKE2B 610cecae473bb5216da717ff7f052f4ffdee1507ce9601836bc2ac4489839725eddb443ecf325bcea284913cfcebcd05dc01743b6baf8c6ece0a652f71cc5da9 SHA512 ff056ce38f86babfcd10b7d9261f6b3f834e902ed352e93d2002e1919bc0b07756c61469a7d79ce96a428d7e89e8868b3e585da22fceef2f5356d66793f8e0fc
+MISC metadata.xml 510 BLAKE2B 585a78c69b8ffff8640baa9eb39fe66a3115cc004da917eeb37573b1ae816e399a63ed5f043d547bcd7e59499c670e5063da56356e00c78cc22df039f11d8a09 SHA512 95337185f46c35a2f8022a1acc00bbebc8174472bcda28dae1a58acd2c314081a0451ef9a6a348390ac908eb249ede97721cf43b21f8ff1984e74f1ea63a6f5e
diff --git a/games-fps/alephone-infinity/alephone-infinity-20220115.ebuild b/games-fps/alephone-infinity/alephone-infinity-20220115.ebuild
new file mode 100644
index 000000000000..2b0f0b0b8319
--- /dev/null
+++ b/games-fps/alephone-infinity/alephone-infinity-20220115.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon Infinity"
+HOMEPAGE="http://marathon.sourceforge.net/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/MarathonInfinity-${PV}-Data.zip"
+S="${WORKDIR}/Marathon Infinity"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="infinity"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}
diff --git a/games-fps/alephone-infinity/metadata.xml b/games-fps/alephone-infinity/metadata.xml
new file mode 100644
index 000000000000..2a5f1108e681
--- /dev/null
+++ b/games-fps/alephone-infinity/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ <remote-id type="sourceforge">marathon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/alephone-marathon/Manifest b/games-fps/alephone-marathon/Manifest
new file mode 100644
index 000000000000..e22fc9834102
--- /dev/null
+++ b/games-fps/alephone-marathon/Manifest
@@ -0,0 +1,3 @@
+DIST Marathon-20220115-Data.zip 26473230 BLAKE2B d6a917c0e884d128af11a56473cd4ec0022ca373c4c1e33f39b58ed24cd65a3cb40efd3e874f9ef64be6d3bf39206cd3a51310719223788d240747670075f697 SHA512 dd1eaaafcffe03b66244497c69044a3cabb8348186f1023dd08444a519a6fca59330bc5daf4950967482a12167059055d577e8211f3a70c92f512f74c8415bc8
+EBUILD alephone-marathon-20220115.ebuild 881 BLAKE2B 75551d5e841db81fb50863f94d6b7b0b412b12ef11a1007ef1b1e9f7f0cb4067021381f66b677a790308760fc2a70c3c89aded41844315137cddae5e786d7ca1 SHA512 356372d486e8a25aacb0059c9c32af41ebca53e761ddcc1ccfdba17d2b0d1aedc0e66db2d51d3433b10ce168dcf064407e0a18499c0f222dc65aead8561ef3ac
+MISC metadata.xml 510 BLAKE2B 585a78c69b8ffff8640baa9eb39fe66a3115cc004da917eeb37573b1ae816e399a63ed5f043d547bcd7e59499c670e5063da56356e00c78cc22df039f11d8a09 SHA512 95337185f46c35a2f8022a1acc00bbebc8174472bcda28dae1a58acd2c314081a0451ef9a6a348390ac908eb249ede97721cf43b21f8ff1984e74f1ea63a6f5e
diff --git a/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild b/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild
new file mode 100644
index 000000000000..a1a96ad86ae5
--- /dev/null
+++ b/games-fps/alephone-marathon/alephone-marathon-20220115.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon (M1A1)"
+HOMEPAGE="http://marathon.sourceforge.net/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon-${PV}-Data.zip"
+S="${WORKDIR}/Marathon"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="marathon"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}
diff --git a/games-fps/alephone-marathon/metadata.xml b/games-fps/alephone-marathon/metadata.xml
new file mode 100644
index 000000000000..2a5f1108e681
--- /dev/null
+++ b/games-fps/alephone-marathon/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ <remote-id type="sourceforge">marathon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
new file mode 100644
index 000000000000..59beb0d6d58a
--- /dev/null
+++ b/games-fps/alephone/Manifest
@@ -0,0 +1,5 @@
+AUX alephone.sh 486 BLAKE2B ed0a60d272e7894ec64ce6f5a727dd4cd129ae8e582f72c74d2177cf22e2be18ee72d0988204fb65650da2c0e3890c9640844bea2f8091b32d24dfb80537dd8e SHA512 4eaf345bec8daecba38125a4bceef2d20985b1653550f935af20a28ec59f8615bf14d9254257e56d006affa24d63a3859e3270f416fcfb318dc688fefa2aff3b
+DIST release-20220115.tar.gz 6487243 BLAKE2B 7c304d28e826e2b3b32427661d3e85ff5ec41e6200d98468edeb5ea11a751fbbd333b72e3efe0937bc496088e36560351f810a6471d92cb684b0bf6adceabf68 SHA512 53d9c602af58f56b5236ca9a539ffac47abe8350b3d228345348e63648a5ef343335be9b0a3366a201807b3e3aa013dc360a38c3e7b47f4a6da2a696ec6ea646
+EBUILD alephone-20220115.ebuild 2203 BLAKE2B 48cdaf7c9a634881c8d0d04e2497af3407a1004df94f84d0af19bce0c1ba0c109c6d6f3ca90ae3d19c3a36c57d39f6f7589fb1304606e9c7488195db50c61e71 SHA512 e27bca5564e1c2062dc259fcbfce5d49c7d6fe7aed4b69a3843f10911f1d15582b062b1b710abec876068d8bbbac97a0ab96a2a804e10ec8114f1dcfcfa13190
+EBUILD alephone-9999.ebuild 2203 BLAKE2B 48cdaf7c9a634881c8d0d04e2497af3407a1004df94f84d0af19bce0c1ba0c109c6d6f3ca90ae3d19c3a36c57d39f6f7589fb1304606e9c7488195db50c61e71 SHA512 e27bca5564e1c2062dc259fcbfce5d49c7d6fe7aed4b69a3843f10911f1d15582b062b1b710abec876068d8bbbac97a0ab96a2a804e10ec8114f1dcfcfa13190
+MISC metadata.xml 599 BLAKE2B fec1ac113594c4548d8cc07eda9a63bc49c345fb0c08ee0622d3de2c1f15b25f8f4a1c4f33770685a479417136a2aa5f66f3f8ee7e7b4ff91e4f3fb97c05eddb SHA512 42faf1057312f77764da14f535dacc06f1029524b4c92db915bcd353d529334614545bff73ee9c36ffc6955f78f451063fee03660a9d615f0b00a023cea1aefc
diff --git a/games-fps/alephone/alephone-20220115.ebuild b/games-fps/alephone/alephone-20220115.ebuild
new file mode 100644
index 000000000000..9bddbbc0d931
--- /dev/null
+++ b/games-fps/alephone/alephone-20220115.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature prefix xdg
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Aleph-One-Marathon/alephone/"
+ EGIT_SUBMODULES=() # Upstream includes game data as submodules, we only want the engine
+else
+ SRC_URI="https://github.com/Aleph-One-Marathon/alephone/archive/refs/tags/release-${PV}.tar.gz"
+ S="${WORKDIR}/${PN}-release-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+ BitstreamVera OFL-1.1"
+SLOT="0"
+
+IUSE="alsa curl speex upnp"
+
+# ffmpeg covers most audio/video use cases and the package doesn't configure with alternatives enabled (media-libs/smpeg)
+# When resolved upstream, !ffmpeg ( media-libs/libmad media-libs/libsndfile media-libs/libvorbis media-libs/smpeg )
+# with an appropriate REQUIRED_USE may be added.
+# See https://github.com/Aleph-One-Marathon/alephone/issues/85
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/zziplib:=
+ media-libs/libpng
+ media-libs/libsdl2
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ media-video/ffmpeg:=[mp3,vorbis]
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ speex? ( media-libs/speex )
+ upnp? ( net-libs/miniupnpc )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-lua \
+ --enable-opengl \
+ --with-ffmpeg \
+ --without-mad \
+ --without-smpeg \
+ --without-sndfile \
+ --without-vorbis \
+ $(use_with alsa) \
+ $(use_with curl) \
+ $(use_with speex) \
+ $(use_with upnp miniupnpc)
+}
+
+src_install() {
+ default
+ prefixify_ro "${FILESDIR}"/${PN}.sh
+ dobin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ docinto html/
+ dodoc docs/*.html
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature_header "Install game data:"
+ optfeature "Marathon data files" games-fps/alephone-marathon
+ optfeature "Marathon 2 Durandal data files" games-fps/alephone-durandal
+ optfeature "Marathon: Infinity data files" games-fps/alephone-infinity
+}
diff --git a/games-fps/alephone/alephone-9999.ebuild b/games-fps/alephone/alephone-9999.ebuild
new file mode 100644
index 000000000000..9bddbbc0d931
--- /dev/null
+++ b/games-fps/alephone/alephone-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature prefix xdg
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Aleph-One-Marathon/alephone/"
+ EGIT_SUBMODULES=() # Upstream includes game data as submodules, we only want the engine
+else
+ SRC_URI="https://github.com/Aleph-One-Marathon/alephone/archive/refs/tags/release-${PV}.tar.gz"
+ S="${WORKDIR}/${PN}-release-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+ BitstreamVera OFL-1.1"
+SLOT="0"
+
+IUSE="alsa curl speex upnp"
+
+# ffmpeg covers most audio/video use cases and the package doesn't configure with alternatives enabled (media-libs/smpeg)
+# When resolved upstream, !ffmpeg ( media-libs/libmad media-libs/libsndfile media-libs/libvorbis media-libs/smpeg )
+# with an appropriate REQUIRED_USE may be added.
+# See https://github.com/Aleph-One-Marathon/alephone/issues/85
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/zziplib:=
+ media-libs/libpng
+ media-libs/libsdl2
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ media-video/ffmpeg:=[mp3,vorbis]
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ speex? ( media-libs/speex )
+ upnp? ( net-libs/miniupnpc )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-lua \
+ --enable-opengl \
+ --with-ffmpeg \
+ --without-mad \
+ --without-smpeg \
+ --without-sndfile \
+ --without-vorbis \
+ $(use_with alsa) \
+ $(use_with curl) \
+ $(use_with speex) \
+ $(use_with upnp miniupnpc)
+}
+
+src_install() {
+ default
+ prefixify_ro "${FILESDIR}"/${PN}.sh
+ dobin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ docinto html/
+ dodoc docs/*.html
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature_header "Install game data:"
+ optfeature "Marathon data files" games-fps/alephone-marathon
+ optfeature "Marathon 2 Durandal data files" games-fps/alephone-durandal
+ optfeature "Marathon: Infinity data files" games-fps/alephone-infinity
+}
diff --git a/games-fps/alephone/files/alephone.sh b/games-fps/alephone/files/alephone.sh
new file mode 100644
index 000000000000..3bb51c26b67c
--- /dev/null
+++ b/games-fps/alephone/files/alephone.sh
@@ -0,0 +1,28 @@
+#!/usr/bin/env bash
+
+DIR=$(dirname "${0}")
+CMD=$(basename "${0}")
+ALEPHONE=${CMD%%.sh}
+
+if [[ -z "${1}" ]]
+then
+ echo "Usage: ${0} SCENARIO FLAGS"
+ echo "Where SCENARIO is one of:"
+ for d in @GENTOO_PORTAGE_EPREFIX@/usr/share/alephone-*
+ do
+ echo " ${d##*/alephone-}"
+ done
+ exit 2
+fi
+
+DATA="@GENTOO_PORTAGE_EPREFIX@/usr/share/alephone-${1}"
+
+shift
+
+# kill ARTS, because we're just that nice
+if artsshell terminate 2> /dev/null
+then
+ sleep 2
+fi
+
+"${DIR}"/"${ALEPHONE}" "$@" "${DATA}"
diff --git a/games-fps/alephone/metadata.xml b/games-fps/alephone/metadata.xml
new file mode 100644
index 000000000000..62d4b84ac671
--- /dev/null
+++ b/games-fps/alephone/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Aleph-One-Marathon/alephone</remote-id>
+ <remote-id type="sourceforge">marathon</remote-id>
+ <bugs-to>https://github.com/Aleph-One-Marathon/alephone/issues</bugs-to>
+ </upstream>
+</pkgmetadata>