summaryrefslogtreecommitdiff
path: root/games-board/phalanx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /games-board/phalanx
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'games-board/phalanx')
-rw-r--r--games-board/phalanx/Manifest2
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild43
2 files changed, 23 insertions, 22 deletions
diff --git a/games-board/phalanx/Manifest b/games-board/phalanx/Manifest
index 1e135a24e83e..1a6ca116cf87 100644
--- a/games-board/phalanx/Manifest
+++ b/games-board/phalanx/Manifest
@@ -1,3 +1,3 @@
DIST Phalanx-XXII.tar.gz 356831 BLAKE2B 11eacd51a77df0a0b25315145a3519e0ae34f97b1498b691167978700fe038770db24e0ce3dec4141a4f5f4c38ab38bf90b338a1320a09191f1757b895ce7307 SHA512 e959556bb29eb2178dbf77c656d6c6520a8568e93e03350c5141bee8808a04d0a0c1050a3db53b1fef4a7b6e6b724272700e52feb6c5d7f8308cebca91c51d67
-EBUILD phalanx-22-r1.ebuild 930 BLAKE2B edd80d4bcd0c850e67ed5c378d290c256c2acd320652a0becda1cc3cb188f3f0cd44f5a0cc68342e6e050144ac839d06f88a9f35b85891839fb63b78db39270b SHA512 e335f8cbf3d84867d7062d35ab2905d8da9df656fcffadb239abccb5e032c9a1b3d305d1be77f8ead81d584384c44a44cd30e5b751a2422b8121dd9cf3c1df5a
+EBUILD phalanx-22-r1.ebuild 764 BLAKE2B cbd17d476b8f65057abdd924288010c68f82f67c633adf483a510365c7d9d7d09b43ddfae11eee488cce5d1f6fc0f6efa7134d49c73d5b17111bca09925ff123 SHA512 c7f497dad9f1c30339fe7ce69102704ce4f1c4c758d7fd05b597fca76353f4024d166b1e174b199d01ff3ba69d2842dc8fa5e85a16fc3a3234b828d65091a5a6
MISC metadata.xml 591 BLAKE2B 8f1dc9165e28dcc87494161b48134a2ac6874637d417f14b8f7e3a9f03426bd461c15fcb0d2e23466ae42aebff14cdeb5405d4526bc89dab1aa6f895a88d5b7c SHA512 06096368d51a7e9c1564d78f56fb75f763267254df25cc3f04bcc34ca9fe621a457505ed5a65175fbb7ce6043f5230e5ae15fdce9e113e37b17814ba114096a5
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
index cb72a63812f8..4d2f1f020ea5 100644
--- a/games-board/phalanx/phalanx-22-r1.ebuild
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -1,41 +1,42 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
-MY_PN="Phalanx"
-MY_PV="XXII"
-MY_P="${MY_PN}-${MY_PV}"
+MY_P="${PN^}-XXII"
-DESCRIPTION="A chess engine suitable for beginner and intermediate players"
+DESCRIPTION="Chess engine suitable for beginner and intermediate players"
HOMEPAGE="http://phalanx.sourceforge.net/"
SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
src_compile() {
- # configure is not used in the project; confs are in Makefile,
- # and here we override them:
- local define="-DGNUFUN" myvar
- for myvar in "PBOOK" "SBOOK" "LEARN" ; do
- define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
- done
- emake \
- DEFINES="${define}" \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
+ local defines=(
+ -DGNUFUN
+ -D{PBOOK,SBOOK,LEARN}_DIR="'\"${EPREFIX}/usr/share/${PN}\"'"
+ )
+
+ local emakeargs=(
+ DEFINES="${defines[*]}"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
LDFLAGS="${LDFLAGS}"
+ )
+
+ emake "${emakeargs[@]}"
}
src_install() {
dobin phalanx
+
insinto /usr/share/${PN}
- doins pbook.phalanx sbook.phalanx learn.phalanx
+ doins {pbook,sbook,learn}.phalanx
+
einstalldocs
}