summaryrefslogtreecommitdiff
path: root/games-board/phalanx/phalanx-22-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/phalanx/phalanx-22-r1.ebuild')
-rw-r--r--games-board/phalanx/phalanx-22-r1.ebuild43
1 files changed, 22 insertions, 21 deletions
diff --git a/games-board/phalanx/phalanx-22-r1.ebuild b/games-board/phalanx/phalanx-22-r1.ebuild
index cb72a63812f8..4d2f1f020ea5 100644
--- a/games-board/phalanx/phalanx-22-r1.ebuild
+++ b/games-board/phalanx/phalanx-22-r1.ebuild
@@ -1,41 +1,42 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
-MY_PN="Phalanx"
-MY_PV="XXII"
-MY_P="${MY_PN}-${MY_PV}"
+MY_P="${PN^}-XXII"
-DESCRIPTION="A chess engine suitable for beginner and intermediate players"
+DESCRIPTION="Chess engine suitable for beginner and intermediate players"
HOMEPAGE="http://phalanx.sourceforge.net/"
SRC_URI="mirror://sourceforge/phalanx/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
src_compile() {
- # configure is not used in the project; confs are in Makefile,
- # and here we override them:
- local define="-DGNUFUN" myvar
- for myvar in "PBOOK" "SBOOK" "LEARN" ; do
- define="${define} -D${myvar}_DIR=\"\\\"/usr/share/${PN}\\\"\""
- done
- emake \
- DEFINES="${define}" \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
+ local defines=(
+ -DGNUFUN
+ -D{PBOOK,SBOOK,LEARN}_DIR="'\"${EPREFIX}/usr/share/${PN}\"'"
+ )
+
+ local emakeargs=(
+ DEFINES="${defines[*]}"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
LDFLAGS="${LDFLAGS}"
+ )
+
+ emake "${emakeargs[@]}"
}
src_install() {
dobin phalanx
+
insinto /usr/share/${PN}
- doins pbook.phalanx sbook.phalanx learn.phalanx
+ doins {pbook,sbook,learn}.phalanx
+
einstalldocs
}