summaryrefslogtreecommitdiff
path: root/games-board/gmchess/gmchess-0.29.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/gmchess/gmchess-0.29.6-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/gmchess/gmchess-0.29.6-r2.ebuild')
-rw-r--r--games-board/gmchess/gmchess-0.29.6-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-board/gmchess/gmchess-0.29.6-r2.ebuild b/games-board/gmchess/gmchess-0.29.6-r2.ebuild
new file mode 100644
index 000000000000..007c50270126
--- /dev/null
+++ b/games-board/gmchess/gmchess-0.29.6-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic libtool gnome2-utils
+
+DESCRIPTION="Chinese chess with gtkmm and c++"
+HOMEPAGE="https://github.com/lerosua/gmchess"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm:2.4"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo-r1.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac}
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ --disable-static \
+ --localedir='/usr/share/locale'
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ itlocaledir='/usr/share/locale' \
+ pixmapsdir='/usr/share/pixmaps' \
+ desktopdir='/usr/share/applications' \
+ install
+ dodoc AUTHORS NEWS README
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}