summaryrefslogtreecommitdiff
path: root/games-board/gmchess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-board/gmchess
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-board/gmchess')
-rw-r--r--games-board/gmchess/Manifest4
-rw-r--r--games-board/gmchess/files/gmchess-0.29.6-gentoo-r1.patch25
-rw-r--r--games-board/gmchess/gmchess-0.29.6-r2.ebuild57
-rw-r--r--games-board/gmchess/metadata.xml11
4 files changed, 97 insertions, 0 deletions
diff --git a/games-board/gmchess/Manifest b/games-board/gmchess/Manifest
new file mode 100644
index 000000000000..47f367cd3c46
--- /dev/null
+++ b/games-board/gmchess/Manifest
@@ -0,0 +1,4 @@
+AUX gmchess-0.29.6-gentoo-r1.patch 871 BLAKE2B eb99dc2a6b5199c104a608990e5da84ebeb4b04df560a365f9c884e2a7f788d0daac6063680ce1b87b833f2bb3fd0c4592b2507ab4b825e6676a106348f2ed59 SHA512 b7466bcc8b734a7449f99ec0b9fcc16d0820628866945710b681dc5c97b5ba37f359e938aeec76fbe411061c88a706b552a9df48d7e7115a84ddfc05143d7e4c
+DIST gmchess-0.29.6.tar.bz2 1437904 BLAKE2B fdc98a317e62a455c394f3486c61abb49ad76bc2a77fae6f3a71271a56e8fc95e58dbf6cd387401a172bafc19379ca1ee971b6ce3911d0aa6b9d97b400a62d28 SHA512 b6af5205dc087c9fdea4cee81f9002c5dd56282be10b09c99f6f4105730676abff8d036843b7c0232937f43d87d222555a0b9c86e192a5ac8c039509841467a6
+EBUILD gmchess-0.29.6-r2.ebuild 1008 BLAKE2B fdd2dcb5a576955eff24df49e11281976cf267ae65c55bcf11a8e31b3cbbdf2753c7f28e28519b040b9ec831bf3daf87a0dbd76333fd81260144b6bdf50b4dd0 SHA512 c7250791db1360059592710947a7dac2b91e49e678bc8697aac5d5994447c0feca47b11f44c0f49cc29f184cd91b7de9cdffc56a9896041bb68bb4b1a313c10c
+MISC metadata.xml 330 BLAKE2B 04e8696c37299e01d7554cc6f370b25facaeb67a994f97d0829fe77bc15fda99af19e56d304a8424bcdd4791f5512da0d06b3ae4da2400a6b5ae457dbec65bb7 SHA512 172b4a1ec7cb67f32ab991337ecc058be002d35f8867819b54d28d65ba1ade6217318460f7560c96a03357d262d76bc7e6eaf810be78e32b3a0290037ddbaaa2
diff --git a/games-board/gmchess/files/gmchess-0.29.6-gentoo-r1.patch b/games-board/gmchess/files/gmchess-0.29.6-gentoo-r1.patch
new file mode 100644
index 000000000000..6ef990460774
--- /dev/null
+++ b/games-board/gmchess/files/gmchess-0.29.6-gentoo-r1.patch
@@ -0,0 +1,25 @@
+diff -ru gmchess-0.29.6.orig/configure.in gmchess-0.29.6/configure.in
+--- gmchess-0.29.6.orig/configure.in 2011-11-28 07:22:56.000000000 -0500
++++ gmchess-0.29.6/configure.in 2013-05-13 21:30:38.103817044 -0400
+@@ -4,7 +4,7 @@
+ AC_PREREQ([2.63])
+ AC_INIT(gmchess, 0.29.6, lerosua@gmail.com)
+ AC_CONFIG_SRCDIR([src/Pgnfile.cc])
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE(gmchess,0.29.6)
+
+
+diff -ru gmchess-0.29.6.orig/data/gmchess.desktop.in gmchess-0.29.6/data/gmchess.desktop.in
+--- gmchess-0.29.6.orig/data/gmchess.desktop.in 2009-09-07 08:08:47.000000000 -0400
++++ gmchess-0.29.6/data/gmchess.desktop.in 2013-05-13 21:30:19.444462390 -0400
+@@ -1,4 +1,3 @@
+-
+ [Desktop Entry]
+ Name=Chinese chess
+ Name[zh_CN]=天书棋谈
+@@ -10,4 +9,3 @@
+ Type=Application
+ Categories=GNOME;GTK;Game;BoardGame;
+ StartupNotify=true
+-Encoding=UTF-8
diff --git a/games-board/gmchess/gmchess-0.29.6-r2.ebuild b/games-board/gmchess/gmchess-0.29.6-r2.ebuild
new file mode 100644
index 000000000000..007c50270126
--- /dev/null
+++ b/games-board/gmchess/gmchess-0.29.6-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic libtool gnome2-utils
+
+DESCRIPTION="Chinese chess with gtkmm and c++"
+HOMEPAGE="https://github.com/lerosua/gmchess"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm:2.4"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo-r1.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac}
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ --disable-static \
+ --localedir='/usr/share/locale'
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ itlocaledir='/usr/share/locale' \
+ pixmapsdir='/usr/share/pixmaps' \
+ desktopdir='/usr/share/applications' \
+ install
+ dodoc AUTHORS NEWS README
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-board/gmchess/metadata.xml b/games-board/gmchess/metadata.xml
new file mode 100644
index 000000000000..8529633ccba3
--- /dev/null
+++ b/games-board/gmchess/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">gmchess</remote-id>
+ </upstream>
+</pkgmetadata>