summaryrefslogtreecommitdiff
path: root/games-arcade/xbill/xbill-2.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /games-arcade/xbill/xbill-2.1-r3.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'games-arcade/xbill/xbill-2.1-r3.ebuild')
-rw-r--r--games-arcade/xbill/xbill-2.1-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-arcade/xbill/xbill-2.1-r3.ebuild b/games-arcade/xbill/xbill-2.1-r3.ebuild
new file mode 100644
index 000000000000..70378b00ceb9
--- /dev/null
+++ b/games-arcade/xbill/xbill-2.1-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="A game about an evil hacker called Bill!"
+HOMEPAGE="http://www.xbill.org/"
+SRC_URI="http://www.xbill.org/download/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="acct-group/gamestat
+ media-fonts/font-misc-misc
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? ( x11-libs/libXaw )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk2.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-motif \
+ $(use_enable gtk) \
+ $(use_enable !gtk athena)
+}
+
+src_install() {
+ default
+ newicon pixmaps/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} XBill ${PN}
+ fowners :gamestat /var/lib/xbill/scores
+ fperms 664 /var/lib/xbill/scores
+}