summaryrefslogtreecommitdiff
path: root/games-arcade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /games-arcade
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/Manifest.gzbin21373 -> 21543 bytes
-rw-r--r--games-arcade/shovel-knight/Manifest3
-rw-r--r--games-arcade/shovel-knight/metadata.xml8
-rw-r--r--games-arcade/shovel-knight/shovel-knight-3.3.ebuild66
-rw-r--r--games-arcade/xbill/Manifest4
-rw-r--r--games-arcade/xbill/files/xbill-2.1-gtk2.patch4
-rw-r--r--games-arcade/xbill/xbill-2.1-r3.ebuild (renamed from games-arcade/xbill/xbill-2.1-r2.ebuild)30
7 files changed, 100 insertions, 15 deletions
diff --git a/games-arcade/Manifest.gz b/games-arcade/Manifest.gz
index 1a0940212f21..3efb3dff4ea3 100644
--- a/games-arcade/Manifest.gz
+++ b/games-arcade/Manifest.gz
Binary files differ
diff --git a/games-arcade/shovel-knight/Manifest b/games-arcade/shovel-knight/Manifest
new file mode 100644
index 000000000000..31066ff3de8e
--- /dev/null
+++ b/games-arcade/shovel-knight/Manifest
@@ -0,0 +1,3 @@
+DIST shovel_knight_treasure_trove_en_3_3_15418.sh 226753557 BLAKE2B 3103871333f5dec931b109ccc8a8820054f8bd934d01daf97bb5ad84e9dfaebd2c79d1943fb7049468f49c9db87c51dec0e08d38469e364bafb8bc50fbd9d40d SHA512 6832593440cc5059f0df37be991bb2e87c071c7ed566b2c6d0f6cc418190be92c4f793f2c694f620b9378914cde13abf9049eba8cdd90b9dfe961ae9a65dc42a
+EBUILD shovel-knight-3.3.ebuild 1612 BLAKE2B 8fef8cc68fe987156e8e5f9ee1db3b8893019678070b4ac2b4e0580cb6a584871c125c6825cf63cec44edce605ce5bac29df4b4210c2c30f1f12605d09111752 SHA512 44e1bac52bb7bedf3fdc288fb8d739e6dbc215fb222c65ee5ec3886f13b5c98f8d2e552794ffbd6cca177472f74164dcafc415db700af5b8368fa699d28cd759
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-arcade/shovel-knight/metadata.xml b/games-arcade/shovel-knight/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-arcade/shovel-knight/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-arcade/shovel-knight/shovel-knight-3.3.ebuild b/games-arcade/shovel-knight/shovel-knight-3.3.ebuild
new file mode 100644
index 000000000000..656b2c154484
--- /dev/null
+++ b/games-arcade/shovel-knight/shovel-knight-3.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop unpacker xdg-utils
+
+MY_PN="ShovelKnight"
+DESCRIPTION="Sweeping classic action adventure with an 8-bit retro aesthetic"
+HOMEPAGE="https://yachtclubgames.com/shovel-knight/"
+SRC_URI="${PN//-/_}_treasure_trove_en_3_3_15418.sh"
+LICENSE="Yacht-Club-Games-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+# I packaged Box2D in the hope of unbundling it but it turns out this
+# game uses a custom version. -- Chewi :(
+
+RDEPEND="
+ media-libs/glew:1.10
+ media-libs/libsdl2[opengl,sound,video]
+ virtual/opengl
+"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.gog.com/game/${PN//-/_}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local BITS=$(usex amd64 64 32) LIB=
+
+ exeinto "${DIR}"
+ doexe ${BITS}/${MY_PN}
+ make_wrapper ${MY_PN} ./${MY_PN} "${DIR}"
+
+ exeinto "${DIR}"/lib
+ doexe ${BITS}/lib/lib{Box2D.so.*,fmod*-*.so}
+
+ # The FMOD libraries are duplicated rather than symlinked, which is
+ # silly, so create our own symlinks. Both sets of names are needed.
+ for LIB in ${BITS}/lib/libfmod*-*.so; do
+ LIB=${LIB##*/}
+ dosym "${LIB}" "${DIR}/lib/${LIB%-*}.so"
+ done
+
+ insinto "${DIR}"
+ doins -r data/
+
+ newicon -s 256 ../support/icon.png ${PN}.png
+ make_desktop_entry ${MY_PN} "Shovel Knight"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-arcade/xbill/Manifest b/games-arcade/xbill/Manifest
index 3aa4155109d8..7010d3e68e53 100644
--- a/games-arcade/xbill/Manifest
+++ b/games-arcade/xbill/Manifest
@@ -1,5 +1,5 @@
AUX xbill-2.1-gentoo.patch 9281 BLAKE2B 852ac415c5525daeb47f321c2e91d76a2af842b5e934a0082e481a940919cffff3c600cd373c76564741346d580db01eba8ce502ba7f47c627a3c66bf042aa5a SHA512 81bdcb950260b6d8b52b9857d1d09b351b422df5789319873ea6e6f2431559c6a0a5a963a87313ed23b2a496d570c6c02e50df2c22f4195c48506f7711a740b8
-AUX xbill-2.1-gtk2.patch 582 BLAKE2B 6f1c3a23a672f4b1f2acd7fbb3e26df4b762eadbbdbb94fc9d2b0b12afe09cafdef6d6834bfb8cd5b7467575a4be72b985c804e95389a36061b676bd31c1abaa SHA512 628db81665e33431391f8756969c97bcb4514ad91c3248470204c41b386b01b3e2733d7a8a524f282b304e7fa5eafdf77ec6a7e4f1c45cadc09e6a3a355359f7
+AUX xbill-2.1-gtk2.patch 582 BLAKE2B d577b0ba7e6247594c616d0d439136d9e0a6378518085e5d29303dbdce065d21ab623d12a18716ce03c35bd00e2a73aa865553c3f541cfe48eacebf60116d467 SHA512 f25980493ccc86f42c0ac4d996b6ec1580011b7764e7b1ad80dd04698a094c0c1842512e544d62ffd527b9a08109f7389c1741f4837e5320accc128786dbc546
DIST xbill-2.1.tar.gz 77610 BLAKE2B aeadc62fa01a3d37b1ae6388987e5d5e3a2d73b9c5afa99b9a2c61155eeb5fb2efc4a36dd2cbeb3fd2f677b385550146d75964afa5f7e83a27f6dc7a16db83c9 SHA512 127604d88258db0ec47084209c656f8817146d70b0fe16f5a1d79883415cf38200594834b39080d78c627104ae6d204f3c12caf127fa094108c4edfbfa98d966
-EBUILD xbill-2.1-r2.ebuild 788 BLAKE2B 956b073a41e85d3529c1bd7ac1881de3c46edabefcff01ab5f073c23fa046fdc5fc39718f128cff2973f88cad9441e6b7290f38d6cd437106bee185d9fc497f1 SHA512 7bb90ea958abc709616dcc1997499d348cca76b6a844620435ec8051b221cda99a9ac70d5cd5dc5593491a5f70c29e5782cf06320a64cbf80d231ef43edbbe3a
+EBUILD xbill-2.1-r3.ebuild 939 BLAKE2B e4b6236c6232c20f640f9328b9dd68b66da60a3d37256e1de9d78998db9fd22ef5ef738ecd48952a46887dcbbcb5e66873dc05bd4ccd00ef4ace7373934ef035 SHA512 a6c977e4b9b309b01eb01744aa0d5053c3d5fd068dfb7bff7e8c14481e6fd55e093a82091305ab189ad5d5651eeeab919098ddee14961ed87fb003908d9bcd39
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/xbill/files/xbill-2.1-gtk2.patch b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
index 70817b09c7ab..829475badd72 100644
--- a/games-arcade/xbill/files/xbill-2.1-gtk2.patch
+++ b/games-arcade/xbill/files/xbill-2.1-gtk2.patch
@@ -1,5 +1,5 @@
---- configure.in.old 2007-12-05 22:37:57.000000000 +0100
-+++ configure.in 2007-12-05 22:54:57.000000000 +0100
+--- a/configure.in 2007-12-05 22:37:57.000000000 +0100
++++ b/configure.in 2007-12-05 22:54:57.000000000 +0100
@@ -88,12 +88,11 @@
[ --enable-gtk build with the GTK widget set])
diff --git a/games-arcade/xbill/xbill-2.1-r2.ebuild b/games-arcade/xbill/xbill-2.1-r3.ebuild
index 1152f2caca38..70378b00ceb9 100644
--- a/games-arcade/xbill/xbill-2.1-r2.ebuild
+++ b/games-arcade/xbill/xbill-2.1-r3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools games
+EAPI=7
+
+inherit autotools desktop
DESCRIPTION="A game about an evil hacker called Bill!"
HOMEPAGE="http://www.xbill.org/"
@@ -13,20 +14,26 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
IUSE="gtk"
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
+RDEPEND="acct-group/gamestat
+ media-fonts/font-misc-misc
+ gtk? ( x11-libs/gtk+:2 )
!gtk? ( x11-libs/libXaw )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk2.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gtk2.patch \
- "${FILESDIR}"/${P}-gentoo.patch
+ default
+ mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- egamesconf \
+ econf \
--disable-motif \
$(use_enable gtk) \
$(use_enable !gtk athena)
@@ -36,5 +43,6 @@ src_install() {
default
newicon pixmaps/icon.xpm ${PN}.xpm
make_desktop_entry ${PN} XBill ${PN}
- prepgamesdirs
+ fowners :gamestat /var/lib/xbill/scores
+ fperms 664 /var/lib/xbill/scores
}