summaryrefslogtreecommitdiff
path: root/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/supertransball2/supertransball2-1.5-r1.ebuild')
-rw-r--r--games-arcade/supertransball2/supertransball2-1.5-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild b/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
new file mode 100644
index 000000000000..96768ec7e1cd
--- /dev/null
+++ b/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit epatch desktop versionator
+
+MY_PV="$(delete_all_version_separators)"
+MY_P="stransball2-v${MY_PV}"
+FILE="${MY_P}-linux"
+
+DESCRIPTION="Thrust clone"
+HOMEPAGE="http://www.braingames.getput.com/stransball2/"
+SRC_URI="http://braingames.bugreport.nl/stransball2/${FILE}.zip
+ mirror://debian/pool/main/s/${PN}/${PN}_${PV}-8.debian.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/sge
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/${P}/sources"
+
+src_unpack() {
+ unpack ${A}
+ mv -f "${FILE}" ${P}
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:/usr/share/games:/usr/share:" \
+ "${WORKDIR}"/debian/patches/0001-Fix-unix-paths-and-Makefile.patch || die
+
+ epatch "${WORKDIR}"/debian/patches/*.patch
+
+ sed -i \
+ -e "s: -I/usr/local/include/SDL::" \
+ -e "s:-g3 -O3:\$(CXXFLAGS):" \
+ -e "s:c++:\$(CXX):" \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ cd ..
+ dobin ${PN}
+
+ doicon ../debian/${PN}.png
+ make_desktop_entry ${PN} "Super Transball 2"
+ dodoc readme.txt
+ doman ../debian/supertransball2.6
+
+ insinto "/usr/share/${PN}"
+ doins -r demos graphics maps sound
+}