summaryrefslogtreecommitdiff
path: root/games-arcade/supertransball2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/supertransball2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/supertransball2')
-rw-r--r--games-arcade/supertransball2/Manifest4
-rw-r--r--games-arcade/supertransball2/metadata.xml16
-rw-r--r--games-arcade/supertransball2/supertransball2-1.5-r1.ebuild65
3 files changed, 85 insertions, 0 deletions
diff --git a/games-arcade/supertransball2/Manifest b/games-arcade/supertransball2/Manifest
new file mode 100644
index 000000000000..dfc7559f0a85
--- /dev/null
+++ b/games-arcade/supertransball2/Manifest
@@ -0,0 +1,4 @@
+DIST stransball2-v15-linux.zip 302212 BLAKE2B 8b45e32f37c805e75ba0d19ef004d75baea689fe87e946d50301cef01230492fd531b4100bc6200a261c24463443b2811faea8d200d15b15af0c884dbc285d2a SHA512 e87655dfca039c0c8553372b4da139f1d8fa420aad1909b422318dc049a9f7972c8d2398b83fde677b3eaf21d2d70fad73d7ec0c4b7bcbeacbf3544e6e575f6a
+DIST supertransball2_1.5-8.debian.tar.xz 26148 BLAKE2B 50ada1b6976da9686aa5cabd5e3a04222e30f9c69565018eebe51271842842dab88829c0672d7375995e3835c3be4983c8990e736278177d7d10596ed2453a0c SHA512 efbb8517b73d4413755663f96aa01eb679b43876091920a6d9a9fc0a31d001828aa536ac59e74172fa519d14b1dff117c150c022fb8f3898efbee2901a418a53
+EBUILD supertransball2-1.5-r1.ebuild 1346 BLAKE2B 5614b4f90e27a8da89bafa0562b8fc5414aeb9fefb9f7b76e37baf2bd5b295fcdd0feff5cb9b57875737d6f8561a9aca8844fbce40549ca58e20da9f81706e45 SHA512 eb13c56975274f9b2f88cfe4abe7221422e4206ba272848d6b2a912af0f73a5315f413b033b0109a40561ccab86e7811e319a8fd364a7f592e0794341f9d117f
+MISC metadata.xml 732 BLAKE2B 02a55b153806bf73c5f777a196d4bcaa79f3bf4155eda30b792b56ba1289df14c5d8597e38b1a2b122d7b53c4792e589a01b57bf31fafbae99333b3dead5e9f8 SHA512 ff6eef56c6c80e08bac6a0d2ce6f848d22e90c1326a2a3e0927c04fdabe38cd0736b8f3555cd8f0743d1ba6cc5094946488cb0b9cf1c1db4ee4176f3bde79e8d
diff --git a/games-arcade/supertransball2/metadata.xml b/games-arcade/supertransball2/metadata.xml
new file mode 100644
index 000000000000..e1b87682aaf5
--- /dev/null
+++ b/games-arcade/supertransball2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription lang="en">
+"Super Transbal 2" is the sequel of "Transball" and "Transball 2", Inspired in
+THRUST type of games (and concretely in ZARA THRUSTA for the Amiga 500). In each
+level of Transball, the goal is to find the SPHERE, capture it and carry it to
+the upper part of the level. The main obstacle is the gravity, that impulses you
+towards the ground. But many other obstacles, canons, tanks, doors, etc. will
+try to make difficult your journey...
+</longdescription>
+</pkgmetadata>
diff --git a/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild b/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
new file mode 100644
index 000000000000..96768ec7e1cd
--- /dev/null
+++ b/games-arcade/supertransball2/supertransball2-1.5-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit epatch desktop versionator
+
+MY_PV="$(delete_all_version_separators)"
+MY_P="stransball2-v${MY_PV}"
+FILE="${MY_P}-linux"
+
+DESCRIPTION="Thrust clone"
+HOMEPAGE="http://www.braingames.getput.com/stransball2/"
+SRC_URI="http://braingames.bugreport.nl/stransball2/${FILE}.zip
+ mirror://debian/pool/main/s/${PN}/${PN}_${PV}-8.debian.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-sound
+ media-libs/sge
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/${P}/sources"
+
+src_unpack() {
+ unpack ${A}
+ mv -f "${FILE}" ${P}
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:/usr/share/games:/usr/share:" \
+ "${WORKDIR}"/debian/patches/0001-Fix-unix-paths-and-Makefile.patch || die
+
+ epatch "${WORKDIR}"/debian/patches/*.patch
+
+ sed -i \
+ -e "s: -I/usr/local/include/SDL::" \
+ -e "s:-g3 -O3:\$(CXXFLAGS):" \
+ -e "s:c++:\$(CXX):" \
+ Makefile || die "sed Makefile failed"
+}
+
+src_install() {
+ cd ..
+ dobin ${PN}
+
+ doicon ../debian/${PN}.png
+ make_desktop_entry ${PN} "Super Transball 2"
+ dodoc readme.txt
+ doman ../debian/supertransball2.6
+
+ insinto "/usr/share/${PN}"
+ doins -r demos graphics maps sound
+}