summaryrefslogtreecommitdiff
path: root/games-arcade/shovel-knight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /games-arcade/shovel-knight
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'games-arcade/shovel-knight')
-rw-r--r--games-arcade/shovel-knight/Manifest3
-rw-r--r--games-arcade/shovel-knight/metadata.xml8
-rw-r--r--games-arcade/shovel-knight/shovel-knight-3.3.ebuild66
3 files changed, 77 insertions, 0 deletions
diff --git a/games-arcade/shovel-knight/Manifest b/games-arcade/shovel-knight/Manifest
new file mode 100644
index 000000000000..31066ff3de8e
--- /dev/null
+++ b/games-arcade/shovel-knight/Manifest
@@ -0,0 +1,3 @@
+DIST shovel_knight_treasure_trove_en_3_3_15418.sh 226753557 BLAKE2B 3103871333f5dec931b109ccc8a8820054f8bd934d01daf97bb5ad84e9dfaebd2c79d1943fb7049468f49c9db87c51dec0e08d38469e364bafb8bc50fbd9d40d SHA512 6832593440cc5059f0df37be991bb2e87c071c7ed566b2c6d0f6cc418190be92c4f793f2c694f620b9378914cde13abf9049eba8cdd90b9dfe961ae9a65dc42a
+EBUILD shovel-knight-3.3.ebuild 1612 BLAKE2B 8fef8cc68fe987156e8e5f9ee1db3b8893019678070b4ac2b4e0580cb6a584871c125c6825cf63cec44edce605ce5bac29df4b4210c2c30f1f12605d09111752 SHA512 44e1bac52bb7bedf3fdc288fb8d739e6dbc215fb222c65ee5ec3886f13b5c98f8d2e552794ffbd6cca177472f74164dcafc415db700af5b8368fa699d28cd759
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-arcade/shovel-knight/metadata.xml b/games-arcade/shovel-knight/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-arcade/shovel-knight/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-arcade/shovel-knight/shovel-knight-3.3.ebuild b/games-arcade/shovel-knight/shovel-knight-3.3.ebuild
new file mode 100644
index 000000000000..656b2c154484
--- /dev/null
+++ b/games-arcade/shovel-knight/shovel-knight-3.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop unpacker xdg-utils
+
+MY_PN="ShovelKnight"
+DESCRIPTION="Sweeping classic action adventure with an 8-bit retro aesthetic"
+HOMEPAGE="https://yachtclubgames.com/shovel-knight/"
+SRC_URI="${PN//-/_}_treasure_trove_en_3_3_15418.sh"
+LICENSE="Yacht-Club-Games-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+# I packaged Box2D in the hope of unbundling it but it turns out this
+# game uses a custom version. -- Chewi :(
+
+RDEPEND="
+ media-libs/glew:1.10
+ media-libs/libsdl2[opengl,sound,video]
+ virtual/opengl
+"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.gog.com/game/${PN//-/_}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local BITS=$(usex amd64 64 32) LIB=
+
+ exeinto "${DIR}"
+ doexe ${BITS}/${MY_PN}
+ make_wrapper ${MY_PN} ./${MY_PN} "${DIR}"
+
+ exeinto "${DIR}"/lib
+ doexe ${BITS}/lib/lib{Box2D.so.*,fmod*-*.so}
+
+ # The FMOD libraries are duplicated rather than symlinked, which is
+ # silly, so create our own symlinks. Both sets of names are needed.
+ for LIB in ${BITS}/lib/libfmod*-*.so; do
+ LIB=${LIB##*/}
+ dosym "${LIB}" "${DIR}/lib/${LIB%-*}.so"
+ done
+
+ insinto "${DIR}"
+ doins -r data/
+
+ newicon -s 256 ../support/icon.png ${PN}.png
+ make_desktop_entry ${MY_PN} "Shovel Knight"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }