summaryrefslogtreecommitdiff
path: root/games-action/transcend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/transcend
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/transcend')
-rw-r--r--games-action/transcend/Manifest4
-rw-r--r--games-action/transcend/files/transcend-0.3-sound.patch89
-rw-r--r--games-action/transcend/metadata.xml11
-rw-r--r--games-action/transcend/transcend-0.3-r1.ebuild65
4 files changed, 169 insertions, 0 deletions
diff --git a/games-action/transcend/Manifest b/games-action/transcend/Manifest
new file mode 100644
index 000000000000..d836e1f95a62
--- /dev/null
+++ b/games-action/transcend/Manifest
@@ -0,0 +1,4 @@
+AUX transcend-0.3-sound.patch 3101 BLAKE2B d110ec774487b1f1cf5a794fd9c675ad3dcbcc474cf55f79efde2946626da97d301c580b91089000bc1f0791e1bc98fdd35f2da12b66ba1afd3cf1d96cb15c66 SHA512 aa51287cb46fd55db9d7d213b135a099dd1d2cdf07f033143356571d06ad16dd8ba7dcd71b78e98430c9126ddcb5484fa63c82c9e26e1ca2d6de855cc55a293f
+DIST Transcend_0.3_UnixSource.tar.gz 1847261 BLAKE2B 7efeb33dc96744f20e53985f6704398f21c3a018272b743bb49305f966fb5e6a11c3d138383979fe4d85cd28aee6854971b0723aa106fec7b64fffe64d5d7b78 SHA512 5a2d21256c202ee045f8e2c926705f79885f6efbb5f44d3129e5b05cb1e28f909a32a5d873a9673d5fa48cbe4e79766c44947f147089e988e2fa3f83cde1b91d
+EBUILD transcend-0.3-r1.ebuild 1360 BLAKE2B 1331a5bed18f7daf84e547e1d550d148b654757536598bac95bfb1eac138da1522df9028987bd64df02eb1eea50d8f63b4aaad107aa3a41b087c1eb6e4d9253d SHA512 2f1415de806e104a0e69635b25b7c9549b7a7ec2349d5925fbd66bf23315751efcf431489c2931c0dc2585080249cce58e43e3aeabead00d417232ee8cae615b
+MISC metadata.xml 332 BLAKE2B eb4915a0b90e86986fde6d552bc1a132d5998ddb97bc37f8b597617bc234372797cdf1394dfbf68913fe002daea792108b97b637e1da51cb71f64d1d54814b2e SHA512 3af008eea1264d7db9571d88c2e63b767afb43881ab456844c448eedf9bf68577c4c0a27bb2559691b8c92482af38ead48036c8bd429df7489048053054ccdf9
diff --git a/games-action/transcend/files/transcend-0.3-sound.patch b/games-action/transcend/files/transcend-0.3-sound.patch
new file mode 100644
index 000000000000..836cd03754ad
--- /dev/null
+++ b/games-action/transcend/files/transcend-0.3-sound.patch
@@ -0,0 +1,89 @@
+Author: Barry deFreese <bdefreese@debian.org>
+Description: Build with portaudio19.
+--- a/game/SoundPlayer.h
++++ b/game/SoundPlayer.h
+@@ -204,7 +204,7 @@
+ double mMusicLoudness;
+
+
+- PortAudioStream *mAudioStream;
++ PaStream *mAudioStream;
+
+ // realtime sounds that should be mixed into the next to-speaker call
+ SimpleVector<PlayableSound *> *mRealtimeSounds;
+--- a/game/SoundPlayer.cpp
++++ b/game/SoundPlayer.cpp
+@@ -47,9 +47,11 @@
+
+
+ // callback passed into portaudio
+-static int portaudioCallback( void *inputBuffer, void *outputBuffer,
++int portaudioCallback( const void *inputBuffer, void *outputBuffer,
+ unsigned long framesPerBuffer,
+- PaTimestamp outTime, void *userData ) {
++ const PaStreamCallbackTimeInfo *outTime,
++ PaStreamCallbackFlags statusFlags,
++ void *userData ) {
+
+
+ SoundPlayer *player = (SoundPlayer *)userData;
+@@ -147,21 +149,13 @@
+
+ if( error == paNoError ) {
+
+- error = Pa_OpenStream(
++ error = Pa_OpenDefaultStream(
+ &mAudioStream,
+- paNoDevice,// default input device
+ 0, // no input
+- paFloat32, // 32 bit floating point input
+- NULL,
+- Pa_GetDefaultOutputDeviceID(),
+ 2, // stereo output
+ paFloat32, // 32 bit floating point output
+- NULL,
+ mSampleRate,
+ 1024, // frames per buffer
+- 0, // number of buffers, if zero then use default minimum
+- paClipOff, // we won't output out of range samples so
+- // don't bother clipping them
+ portaudioCallback,
+ (void *)this ); // pass self-pointer to callback function
+
+Description: Link to dynamic portaudio instead of static.
+Author: Miriam Ruiz <miriam@debian.org>
+--- a/Makefile.GnuLinuxX86
++++ b/Makefile.GnuLinuxX86
+@@ -22,7 +22,7 @@
+
+ # pthread library needed for linux
+ # also need portaudio library (which in turn needs pthreads)
+-PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu ${ROOT_PATH}/Transcend/portaudio/lib/libportaudio.a -lpthread
++PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu $(shell pkg-config portaudio-2.0 --libs)
+
+
+ # All platforms but OSX support g++ and need no linker hacks
+--- a/game/SoundPlayer.h
++++ b/game/SoundPlayer.h
+@@ -46,8 +46,7 @@
+ #include "SoundFilter.h"
+ #include "PlayableSound.h"
+
+-#include "Transcend/portaudio/pa_common/portaudio.h"
+-#include "Transcend/portaudio/pablio/pablio.h"
++#include <portaudio.h>
+
+
+ #include "minorGems/util/SimpleVector.h"
+--- a/game/SoundPlayerActive.h
++++ b/game/SoundPlayerActive.h
+@@ -16,8 +16,7 @@
+
+ #include "SoundSamples.h"
+
+-#include "Transcend/portaudio/pa_common/portaudio.h"
+-#include "Transcend/portaudio/pablio/pablio.h"
++#include <portaudio.h>
+
+
+ #include "minorGems/util/SimpleVector.h"
diff --git a/games-action/transcend/metadata.xml b/games-action/transcend/metadata.xml
new file mode 100644
index 000000000000..af830ea1122e
--- /dev/null
+++ b/games-action/transcend/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">transcend</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/transcend/transcend-0.3-r1.ebuild b/games-action/transcend/transcend-0.3-r1.ebuild
new file mode 100644
index 000000000000..5f95cff17b5f
--- /dev/null
+++ b/games-action/transcend/transcend-0.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Retro-style, abstract, 2D shooter"
+HOMEPAGE="http://transcend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/Transcend_${PV}_UnixSource.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freeglut
+ media-libs/portaudio
+ x11-libs/libXi
+ x11-libs/libXmu
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/Transcend_${PV}_UnixSource/Transcend
+
+# Apply patch from Debian in order to get sound working. bug #372413
+PATCHES=(
+ "${FILESDIR}"/${P}-sound.patch
+)
+
+src_prepare() {
+ default
+
+ rm -rf game/Makefile portaudio/ || die
+ sed \
+ -e '/^GXX=/d' \
+ -e 's/GXX/CXX/' \
+ -e '/^COMPILE_FLAGS =/ s/OPTIMIZE_FLAG/CXXFLAGS/' \
+ -e '/^EXE_LINK =/ s/LINK_FLAGS/LDFLAGS/' \
+ Makefile.GnuLinuxX86 \
+ Makefile.common \
+ Makefile.minorGems \
+ game/Makefile.all \
+ Makefile.minorGems_targets \
+ > game/Makefile || die
+ sed -i \
+ -e "s:\"levels\":\"/usr/share/${PN}/levels\":" \
+ game/LevelDirectoryManager.cpp \
+ game/game.cpp || die
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake -C game
+}
+
+src_install() {
+ newbin game/Transcend ${PN}
+ insinto /usr/share/${PN}
+ doins -r levels/
+ dodoc doc/{how_to_play.txt,changeLog.txt}
+ make_desktop_entry ${PN} "Transcend"
+}