summaryrefslogtreecommitdiff
path: root/dev-vcs/repo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-vcs/repo
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-vcs/repo')
-rw-r--r--dev-vcs/repo/Manifest4
-rw-r--r--dev-vcs/repo/repo-2.11.ebuild32
-rw-r--r--dev-vcs/repo/repo-2.8.ebuild4
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index b936cabc40b3..1fb63235e4a0 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,5 +1,7 @@
+DIST repo-2.11 39791 BLAKE2B 535de238d934eb2717af7bddd960c158501a56dd400ae02f3665e30c34bd68a1973de4c84e2ea76f48aa027249dfd4270153f1a7d4c4a2d5d883b580f02664e9 SHA512 1889ee9c782a6dc90b782c8ca9c5411b97c4495e0d27add62b9661a5961a782096037e081e984c965e44d33459e8fe4428528b5ebfff9fe356ce401cb610480a
DIST repo-2.5 38761 BLAKE2B 26d002bb7e5a24dc958bb4e0653c2cc260b2766d81fd55edf9a0373542365ed89a224805293383e2c16d8fc331038b265d3b2aca3a9a637d893f4a9c8221ce76 SHA512 36e515241fd9705c63beaf662309dc2ab6406552ba845fe020c878ac82e7eb7e1cd73924a076cf5fe4800ea70919bb5ad5d2d43566d5b0a559f81a45f9a58fe8
DIST repo-2.8 39134 BLAKE2B af52a2c06e09de83100cb297d585f89bcbe85d6e9e5c358024a371ee4d47c59992745d1088b164fc670cdd9db7394a5f3521967e3eb80840c53993af8b0172b1 SHA512 6d577fce34eb298035a7b98c24fc21521c8c9efbdf02abc37af8a54552893ecf8cdce2db5efbc5398d7f99226408f6cc9ce2f81c2961d9d5dd21fb0264194431
+EBUILD repo-2.11.ebuild 859 BLAKE2B 888cb54ac80672bd40a5f8da06afa80568be74afae0c3d3932ac0e38a8fce33def301694a3cceb531ecf2349d02f7226091e230f0b095112b7904c423e46fb85 SHA512 05999f49e7196155838ebc17df76c894be5b20273d220e6fa4e66bb8f1879fd6ae4bf8b562c2b1d7cde350b56183132d4747f9423a635c0b63da5520da3bcaff
EBUILD repo-2.5.ebuild 853 BLAKE2B 5123c3b627a65cf07ab9586308676a9c3edb1b5037525d6b2af702203b4223676ebf5a018239d6655aae90c2daef1358995a490b37a0c67bda6e66c000907ae0 SHA512 b5862ce4158e106a6a21138371b5471f6f70bc5844b074de0f1334daf3183238df0d81784afc448c403cdbb027ce240948c0743d9e39a2c19f053112bf578883
-EBUILD repo-2.8.ebuild 859 BLAKE2B fe8ad85ef67acc2ecfa5ab5a4f84ce25d5b71efda9dd5ebf5d1888e0adb0074ccb5fc5cf374e4adfcd3cd1349bb74fea53f8aeaad087f315f98004720b56b0c4 SHA512 8c12b6b3350b182241dd8b82890a3966dd99938aa344f0df3833df41ec532d09812f0f4b6dddbabcc26abb32cf567b1206a1c0ae74efa288b92e3afdeaefcb86
+EBUILD repo-2.8.ebuild 853 BLAKE2B 4da4a529a7d429a9b5eaca623188e8200ae46997c9d6f10faa3924a63310b85c26405a4769b954cac16c42d1670d6451b1eb3e4f086db99531670c535be7057b SHA512 d3cc7adf815321fbd807369feccbab9571b0a36cf1d8a2bfa562228f0f24c6c7282587870adc3f0c71121b19ecb75c9edcc28bdbf665744542543aa0f24d6659
MISC metadata.xml 214 BLAKE2B c0c4c0ad9c74c68b5d7e4e539dc441e82a025754b84fa14f01d0f6772b5acacc836523305857e1a8ef54d472e77a339d2361ec4bc70651cbf13e7be34b051d81 SHA512 d0c4ab837bd2d936086900fa4ad3d048ad069bfbc58dc7f07ad3819b383646d66f392407314bfe8f542fb8b0b2ffec0848bc7b2d122469f23b9ddaa4aec0a9cd
diff --git a/dev-vcs/repo/repo-2.11.ebuild b/dev-vcs/repo/repo-2.11.ebuild
new file mode 100644
index 000000000000..71f6820e3670
--- /dev/null
+++ b/dev-vcs/repo/repo-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}
diff --git a/dev-vcs/repo/repo-2.8.ebuild b/dev-vcs/repo/repo-2.8.ebuild
index 544acae9a81b..7da69b4ea509 100644
--- a/dev-vcs/repo/repo-2.8.ebuild
+++ b/dev-vcs/repo/repo-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NB: The $PV tracks the *repo launcher version*, not the last signed release
@@ -17,7 +17,7 @@ SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"