summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-vcs
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/Manifest.gzbin10296 -> 10472 bytes
-rw-r--r--dev-vcs/git-big-picture/Manifest5
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild32
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild40
-rw-r--r--dev-vcs/git-big-picture/metadata.xml8
-rw-r--r--dev-vcs/repo/Manifest4
-rw-r--r--dev-vcs/repo/repo-2.11.ebuild32
-rw-r--r--dev-vcs/repo/repo-2.8.ebuild4
-rw-r--r--dev-vcs/stgit/Manifest4
-rw-r--r--dev-vcs/stgit/stgit-0.22.ebuild83
-rw-r--r--dev-vcs/stgit/stgit-0.23.ebuild5
11 files changed, 126 insertions, 91 deletions
diff --git a/dev-vcs/Manifest.gz b/dev-vcs/Manifest.gz
index f6f4212ee574..266574fa0cd2 100644
--- a/dev-vcs/Manifest.gz
+++ b/dev-vcs/Manifest.gz
Binary files differ
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
new file mode 100644
index 000000000000..ece23b28eb76
--- /dev/null
+++ b/dev-vcs/git-big-picture/Manifest
@@ -0,0 +1,5 @@
+DIST git-big-picture-1.0.0.tar.gz 2952246 BLAKE2B caf28b57399bbdc2c80feda70e2a043dc1a8ffdc1e88bc79ccec44d6857e52726961e5febe9d1dbe1230818990a291900237cc01f65e819995243cbbc47ba8a9 SHA512 3b5416d3802c91ee35ad31ef702ada5f23b33cd77ef4c1f15cf22bb7f7d1e3c315e100aabdca3831b56d52b1d1637afa86382f89f0a2bbc8c60970095cd53d43
+DIST git-big-picture-1.1.1.tar.gz 2960674 BLAKE2B 00b3117f810b78965e5a260000689c3275f078307f8e5ef90e6a032036eeedcda743c6eff3e3a1f53744d71d9b3bf2692efc558d5f5b20eada9a9b2e21559796 SHA512 1bf1b620d73cccb058034bc8920adcab117fbda8b921937aac6b90e2162cf4b334cae934b0395efdf40b5e9a363e7ec69090ca943c839829dedaa40428dbdb13
+EBUILD git-big-picture-1.0.0.ebuild 716 BLAKE2B db8f91d4f78796e7624c8509e8867392291e2f3b4d4bc8fa8afbed1d6b000ffb47e2d1310e20f6f8fba714372e73a5cc60d460ffa7814ea9f070166faedb58ea SHA512 9870b64133afa589ceb0a7305d311a49f46b46ae4308cf904d5d12733fc987c6509b922a4d924eb06c8cd7bd8ba98ccca8748ee47b0f2047fedec59521cdacfa
+EBUILD git-big-picture-1.1.1.ebuild 876 BLAKE2B 7ed7dad9d466db2081663a2eec571d2e6814163aa1da7d0b3e891eced006db3943ea360614e541c7424d6bd33b13648c0a6aabdc989935ccf4d20eed3e7c6aab SHA512 5199346a5c329456364de31339801748b8e65e7879b7f6bea9a5376d48872e272a7fb2f88c72e8a13d8fe95ed4000253e68d32ae23af294947a36a0d43c26149
+MISC metadata.xml 249 BLAKE2B a4931a30c3947b238913053d611639235b076475e864914e684020d86ee1b4aa6da94e4cef59c53a0e5ccd3b3d15d3a4ae293800b17bbb89e0af9cff79314a70 SHA512 b1cb770984baef468e3d17e343acff395e1993b14f90def7f8582b5e5d1a512bd3c7727e03f1deca47f7359a8f8cc9a8360130923388a5c06fabbfb9b05d5138
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
new file mode 100644
index 000000000000..6672763d608f
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mv test.py test_some.py || die # help pytest with test discovery
+ default
+}
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild
new file mode 100644
index 000000000000..e83eaba0bc60
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-vcs/git-big-picture/metadata.xml b/dev-vcs/git-big-picture/metadata.xml
new file mode 100644
index 000000000000..ab886b7f0382
--- /dev/null
+++ b/dev-vcs/git-big-picture/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index b936cabc40b3..1fb63235e4a0 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,5 +1,7 @@
+DIST repo-2.11 39791 BLAKE2B 535de238d934eb2717af7bddd960c158501a56dd400ae02f3665e30c34bd68a1973de4c84e2ea76f48aa027249dfd4270153f1a7d4c4a2d5d883b580f02664e9 SHA512 1889ee9c782a6dc90b782c8ca9c5411b97c4495e0d27add62b9661a5961a782096037e081e984c965e44d33459e8fe4428528b5ebfff9fe356ce401cb610480a
DIST repo-2.5 38761 BLAKE2B 26d002bb7e5a24dc958bb4e0653c2cc260b2766d81fd55edf9a0373542365ed89a224805293383e2c16d8fc331038b265d3b2aca3a9a637d893f4a9c8221ce76 SHA512 36e515241fd9705c63beaf662309dc2ab6406552ba845fe020c878ac82e7eb7e1cd73924a076cf5fe4800ea70919bb5ad5d2d43566d5b0a559f81a45f9a58fe8
DIST repo-2.8 39134 BLAKE2B af52a2c06e09de83100cb297d585f89bcbe85d6e9e5c358024a371ee4d47c59992745d1088b164fc670cdd9db7394a5f3521967e3eb80840c53993af8b0172b1 SHA512 6d577fce34eb298035a7b98c24fc21521c8c9efbdf02abc37af8a54552893ecf8cdce2db5efbc5398d7f99226408f6cc9ce2f81c2961d9d5dd21fb0264194431
+EBUILD repo-2.11.ebuild 859 BLAKE2B 888cb54ac80672bd40a5f8da06afa80568be74afae0c3d3932ac0e38a8fce33def301694a3cceb531ecf2349d02f7226091e230f0b095112b7904c423e46fb85 SHA512 05999f49e7196155838ebc17df76c894be5b20273d220e6fa4e66bb8f1879fd6ae4bf8b562c2b1d7cde350b56183132d4747f9423a635c0b63da5520da3bcaff
EBUILD repo-2.5.ebuild 853 BLAKE2B 5123c3b627a65cf07ab9586308676a9c3edb1b5037525d6b2af702203b4223676ebf5a018239d6655aae90c2daef1358995a490b37a0c67bda6e66c000907ae0 SHA512 b5862ce4158e106a6a21138371b5471f6f70bc5844b074de0f1334daf3183238df0d81784afc448c403cdbb027ce240948c0743d9e39a2c19f053112bf578883
-EBUILD repo-2.8.ebuild 859 BLAKE2B fe8ad85ef67acc2ecfa5ab5a4f84ce25d5b71efda9dd5ebf5d1888e0adb0074ccb5fc5cf374e4adfcd3cd1349bb74fea53f8aeaad087f315f98004720b56b0c4 SHA512 8c12b6b3350b182241dd8b82890a3966dd99938aa344f0df3833df41ec532d09812f0f4b6dddbabcc26abb32cf567b1206a1c0ae74efa288b92e3afdeaefcb86
+EBUILD repo-2.8.ebuild 853 BLAKE2B 4da4a529a7d429a9b5eaca623188e8200ae46997c9d6f10faa3924a63310b85c26405a4769b954cac16c42d1670d6451b1eb3e4f086db99531670c535be7057b SHA512 d3cc7adf815321fbd807369feccbab9571b0a36cf1d8a2bfa562228f0f24c6c7282587870adc3f0c71121b19ecb75c9edcc28bdbf665744542543aa0f24d6659
MISC metadata.xml 214 BLAKE2B c0c4c0ad9c74c68b5d7e4e539dc441e82a025754b84fa14f01d0f6772b5acacc836523305857e1a8ef54d472e77a339d2361ec4bc70651cbf13e7be34b051d81 SHA512 d0c4ab837bd2d936086900fa4ad3d048ad069bfbc58dc7f07ad3819b383646d66f392407314bfe8f542fb8b0b2ffec0848bc7b2d122469f23b9ddaa4aec0a9cd
diff --git a/dev-vcs/repo/repo-2.11.ebuild b/dev-vcs/repo/repo-2.11.ebuild
new file mode 100644
index 000000000000..71f6820e3670
--- /dev/null
+++ b/dev-vcs/repo/repo-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}
diff --git a/dev-vcs/repo/repo-2.8.ebuild b/dev-vcs/repo/repo-2.8.ebuild
index 544acae9a81b..7da69b4ea509 100644
--- a/dev-vcs/repo/repo-2.8.ebuild
+++ b/dev-vcs/repo/repo-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# NB: The $PV tracks the *repo launcher version*, not the last signed release
@@ -17,7 +17,7 @@ SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index bc377fc9b0a3..172444cbdcdf 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,8 +1,6 @@
AUX stgit-0.16-man-linkfix.patch 429 BLAKE2B 11cd98b7a58a55fed445be700bc492a4fd926b9bac20a54e095b9c9470d6294a4c32800622b42e87ff10908a40a2bf71e8e139dc306ade3b4989c10609dcceaa SHA512 c71e32a6e6b007ebbbe738dae93bf2109d2be1ed3f3418c98c6ff6ebb602fb8523f974160276649bb66745340d752d69e87c9f0730ca3dd595a6b2b32a0104df
DIST stgit-0.21.tar.gz 319605 BLAKE2B 92bb879d8b8804c8a1b2ca8038d010a0b5118970a4482d87d6bc295992849511c33acb46f376034af6609d42c0323d692bff0ea9bf217cc860e53915fb3c982e SHA512 394c2b30596819f1376bd7432be6923a8dad73f58f049022fe64d1520fd75418665af8069aac98843df051f7fbefbb367762ad4ba57f13bf747819035c7d63ee
-DIST stgit-0.22.tar.gz 308815 BLAKE2B 46c6214012b8d6973273bec716b1ffdafde3ea17930da94de0f73e91e8753fc7ce1d890964c8fac1d32e6343f86e54057b732414fb187b5c9f50e2fa581e6321 SHA512 bfef074b952e01d9041a4ed5dfc6786c29ebb4b09a424ca09e9131ad21c418c4d79ec13eb908f5e8b015ebbc709aacb13824a1c9cad6d97e018a166b014c5e6f
DIST stgit-0.23.tar.gz 303836 BLAKE2B 018e0caf74a3c449a71362e3694b2ddf030f5ee23e3212a98b378b7118bae9fd15d0e4ab2a2a746a12b34e46aa2edb86657a4a7125f3c5ca8aa0142fe3d73534 SHA512 b3c9b5c0833cb7e5137faf0df48af6a11b9508b994cdf55b587567d1c146fd4ae29e7beb6d1a34b3f87e5b3854af035dd7e5ca35338c20740e91da7b47c4568d
EBUILD stgit-0.21.ebuild 1883 BLAKE2B aedcb46f09e670914d19905483f6974b36196a9d746490a9368376d06d83786754b96513ade7df8203e02286745135e8a127d7bed043f5ecd8ca84620eb50528 SHA512 f1f2a8a7ec098783ccf6061eb51a38e47adac3f5c66b473c7f8b886306951eb5f5efc6455c4460278b590ae70976a8d376ccda34be886c5cedb335cdd02d3d30
-EBUILD stgit-0.22.ebuild 1889 BLAKE2B 87652129693e5648f177bb6412fdc45d7414237f636660a9f5ad22f167626bb64e773a14ef58b0d7b66332ec24974dded6060ecf9e22384926a9396ee3ae6352 SHA512 351e7a3389ead3b879b7fa5667559c2974c08111b371291b9866590e0a90f48e18f341a4667c5157ee280af9c6e0d26663b1e0f3d17bda072b5766d591f25f81
-EBUILD stgit-0.23.ebuild 1832 BLAKE2B 0432ac276ff9f7b665131bec96025df4e9324df0f9d65e15666d9e8232148f2ecc4d3b031a98ee07c803326097e821daa1fe853a9f91ac8ed2f1e7a2d286826e SHA512 f63a40017151485c617866e27196a883423d519c6e1f931a5fe9a45e44bd0dae2069930b0d5806a2a174fc1d53a42d5c66b71cba557c384df720d7c8f74df812
+EBUILD stgit-0.23.ebuild 1862 BLAKE2B bd4b77224a144354c2556784eed7b087b14f10677c5fe1630f7dcf28f65e00d1b63bfd530cf881379d2a8333cc14f6e73ab048e74e1b1bb747a9b18ac3f61142 SHA512 75f2df0395d5fe29f7787ccc3921a845c6cad1878c3789bcab206ed9f404da49fea571af81260e03dc0c4d8feddcbc42c8fc9b5f27f6b8f389f832958405c3b8
MISC metadata.xml 240 BLAKE2B bd240e0175a0c9b3a954ded560844811f58403fcf0fd6474dde32d571e7c3f22424ae8de719a4adad492b6d5f4df7d3198f5a5f65f2c21ca8f05274a9f979f85 SHA512 923a0a24ce7efb7b5c6e6561521def809a20d77a8dca21ca55c1bd8e0e34139c0d5d6ec683180f0b97ddb809ea124765eba82f1135abe08c93f4dfb353d18da8
diff --git a/dev-vcs/stgit/stgit-0.22.ebuild b/dev-vcs/stgit/stgit-0.22.ebuild
deleted file mode 100644
index caede5a5d004..000000000000
--- a/dev-vcs/stgit/stgit-0.22.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Manage a stack of patches using GIT as a backend"
-HOMEPAGE="http://www.procode.org/stgit/"
-UPSTREAM_VER=
-[[ -n ${UPSTREAM_VER} ]] && \
- UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
-
-SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${UPSTREAM_PATCHSET_URI}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND=">=dev-vcs/git-1.6.3.3"
-
-# NOTE: It seems to be quite important which asciidoc version to use.
-# So keep an eye on it for the future.
-DEPEND="${RDEPEND}
- doc? (
- app-text/asciidoc
- app-text/xmlto
- dev-lang/perl
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
-)
-
-pkg_setup() {
- if ! use doc; then
- echo
- ewarn "Manpages will not be built and installed."
- ewarn "Enable the 'doc' useflag, if you want them."
- echo
- fi
-}
-
-python_prepare_all() {
- # Upstream's patchset
- [[ -n ${UPSTREAM_VER} ]] && \
- eapply "${WORKDIR}"/patches-upstream
-
- # this will be a noop, as we are working with a tarball,
- # but throws git errors --> just get rid of it
- echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
-
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- distutils-r1_src_compile
-
- # bug 526468
- if use doc; then
- emake DESTDIR="${D}" \
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
- mandir="${EPREFIX}/usr/share/man/" \
- doc
- fi
-}
-
-src_install() {
- if use doc; then
- emake DESTDIR="${D}" \
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
- mandir="${EPREFIX}/usr/share/man/" \
- install-doc install-html
- fi
-
- distutils-r1_src_install
-
- newbashcomp completion/stgit.bash 'stg'
-}
diff --git a/dev-vcs/stgit/stgit-0.23.ebuild b/dev-vcs/stgit/stgit-0.23.ebuild
index a700e23fc3bc..65c2f4791666 100644
--- a/dev-vcs/stgit/stgit-0.23.ebuild
+++ b/dev-vcs/stgit/stgit-0.23.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
inherit bash-completion-r1 distutils-r1