summaryrefslogtreecommitdiff
path: root/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/gitinspector/gitinspector-0.4.4.ebuild')
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.4.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
new file mode 100644
index 000000000000..8a2f93873ec8
--- /dev/null
+++ b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical analysis tool for git repositories"
+HOMEPAGE="https://github.com/ejwa/gitinspector"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND="test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
+
+ # Otherwise this gets installed with the *.txt glob.
+ rm LICENSE.txt || die 'failed to remove LICENSE.txt'
+
+ # Use /usr/share/doc/${PF} instead of /usr/share/doc/${PN}.
+ sed -i setup.py \
+ -e "s:share/doc/gitinspector:share/doc/${PF}:" \
+ || die 'failed to fix the documentation path in setup.py'
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # The distutils install routine misses some important documentation.
+ doman docs/gitinspector.1
+ dodoc docs/*.{pdf,css,html,txt}
+}