summaryrefslogtreecommitdiff
path: root/dev-vcs/gitinspector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-vcs/gitinspector
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-vcs/gitinspector')
-rw-r--r--dev-vcs/gitinspector/Manifest5
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.4.4.ebuild42
-rw-r--r--dev-vcs/gitinspector/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-vcs/gitinspector/Manifest b/dev-vcs/gitinspector/Manifest
new file mode 100644
index 000000000000..c637866eaa4b
--- /dev/null
+++ b/dev-vcs/gitinspector/Manifest
@@ -0,0 +1,5 @@
+DIST gitinspector-0.4.4.tar.gz 312201 SHA256 c7a50772bf675d41b7c19508d8f2ea26725ce4ae16aba709d5b42db42e3d2459 SHA512 6e453a97f7b0bda73e376499268d9a46aa4ff1f8bb65092314a6d32031b0292056152b4e0e3781fbbe3aa6150373679bf78a8c83410882921ab40ce6d356fadb WHIRLPOOL d4c10d1d43296908e0c8463a23d9cd0c5178ea9513d10c1519b250e738357ec9dc4ee259552445a43b6eb2d061480bff51633e01ac5938bf01e0e05cd569d5af
+EBUILD gitinspector-0.4.4.ebuild 1079 SHA256 decb01c7badb40ff788cf213262a2f8ecd3b8826d23f32ac2aa0df0c96796253 SHA512 5488ab8568014db38b1517d6983542a82d6ad1db0ecda49dd24a1b878a6ec3718c8dfcdd8dcd1163be649a550a2eaec0beb227434c9bf19b6a4448f11c949bf7 WHIRLPOOL 265db7bbac925daf6224ed2269dc1f4e8135fe3077ef441ccbdace3f11759cd170a745ab961a3876c984e3318ce2cf2885d4a3b4ed5f6a89764515913d444911
+MISC ChangeLog 3229 SHA256 094f92cc3bc70fe9e8a4c6aecc85d60abf2896dfe20fe92116cd0564dc89bc2f SHA512 9fc7d857a73b0fe12ff841196de0f5fd47bc7ce239728be9c825c0b847a84707f24063c9573d10e6d680e3a3afb9f706e900b9d10ace3d85fa626cd33997c440 WHIRLPOOL bd0a2738179738f92baed80869f4c464ea252e3d0dab5b8664bd53a64365a545404487e9b7c159d74cec03311e6a40d43e5d6c67159a9f90766ab150057fd81b
+MISC ChangeLog-2015 716 SHA256 8a741be1282c1d6d4c5ab308ffbe465b2308fcf7565312b38d864f5e9dfee9d4 SHA512 c6b8f1c7620fdb74b06bbaadfbc053e0af91d100310c619ff2122b20c9acfe4e1c98c5f9ec84a42e5952965c55158bc4a57f54e5a2119fce294215efa7d33cc1 WHIRLPOOL 251c871d0f9e00528a0bd54192bcd3e0b340cf1c8c1ee3653118b3d44d85918365c6dfdc2a99ca78b791d3ec15b5e3549082927d4a8af9d51bef710c537a00c0
+MISC metadata.xml 254 SHA256 a3b874853b824c043f33a4b1955471eca4e02113576dea81e9b7fe157a489882 SHA512 12393bb0a59ac43ececcee078244914186799f0b87706377147004ca6ddcea920a3aac8abac6905a1c68c0cb0652e7d95e62541172424730b9c01300f4e24be1 WHIRLPOOL 8542bafd388e184b5a0a8090cbdd709bc7f5776b3947869cebc70dfb6e3f7e8cf706b2a3d9ea0eeab50bdf2f7f0d5761d610fc0b48eec0e633ee59c281fd9c2d
diff --git a/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
new file mode 100644
index 000000000000..8a2f93873ec8
--- /dev/null
+++ b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical analysis tool for git repositories"
+HOMEPAGE="https://github.com/ejwa/gitinspector"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND="test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
+
+ # Otherwise this gets installed with the *.txt glob.
+ rm LICENSE.txt || die 'failed to remove LICENSE.txt'
+
+ # Use /usr/share/doc/${PF} instead of /usr/share/doc/${PN}.
+ sed -i setup.py \
+ -e "s:share/doc/gitinspector:share/doc/${PF}:" \
+ || die 'failed to fix the documentation path in setup.py'
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # The distutils install routine misses some important documentation.
+ doman docs/gitinspector.1
+ dodoc docs/*.{pdf,css,html,txt}
+}
diff --git a/dev-vcs/gitinspector/metadata.xml b/dev-vcs/gitinspector/metadata.xml
new file mode 100644
index 000000000000..0233271d1ea1
--- /dev/null
+++ b/dev-vcs/gitinspector/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">ejwa/gitinspector</remote-id>
+ </upstream>
+</pkgmetadata>