summaryrefslogtreecommitdiff
path: root/dev-vcs/git-big-picture
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-vcs/git-big-picture
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-vcs/git-big-picture')
-rw-r--r--dev-vcs/git-big-picture/Manifest5
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild32
-rw-r--r--dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild40
-rw-r--r--dev-vcs/git-big-picture/metadata.xml8
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-vcs/git-big-picture/Manifest b/dev-vcs/git-big-picture/Manifest
new file mode 100644
index 000000000000..ece23b28eb76
--- /dev/null
+++ b/dev-vcs/git-big-picture/Manifest
@@ -0,0 +1,5 @@
+DIST git-big-picture-1.0.0.tar.gz 2952246 BLAKE2B caf28b57399bbdc2c80feda70e2a043dc1a8ffdc1e88bc79ccec44d6857e52726961e5febe9d1dbe1230818990a291900237cc01f65e819995243cbbc47ba8a9 SHA512 3b5416d3802c91ee35ad31ef702ada5f23b33cd77ef4c1f15cf22bb7f7d1e3c315e100aabdca3831b56d52b1d1637afa86382f89f0a2bbc8c60970095cd53d43
+DIST git-big-picture-1.1.1.tar.gz 2960674 BLAKE2B 00b3117f810b78965e5a260000689c3275f078307f8e5ef90e6a032036eeedcda743c6eff3e3a1f53744d71d9b3bf2692efc558d5f5b20eada9a9b2e21559796 SHA512 1bf1b620d73cccb058034bc8920adcab117fbda8b921937aac6b90e2162cf4b334cae934b0395efdf40b5e9a363e7ec69090ca943c839829dedaa40428dbdb13
+EBUILD git-big-picture-1.0.0.ebuild 716 BLAKE2B db8f91d4f78796e7624c8509e8867392291e2f3b4d4bc8fa8afbed1d6b000ffb47e2d1310e20f6f8fba714372e73a5cc60d460ffa7814ea9f070166faedb58ea SHA512 9870b64133afa589ceb0a7305d311a49f46b46ae4308cf904d5d12733fc987c6509b922a4d924eb06c8cd7bd8ba98ccca8748ee47b0f2047fedec59521cdacfa
+EBUILD git-big-picture-1.1.1.ebuild 876 BLAKE2B 7ed7dad9d466db2081663a2eec571d2e6814163aa1da7d0b3e891eced006db3943ea360614e541c7424d6bd33b13648c0a6aabdc989935ccf4d20eed3e7c6aab SHA512 5199346a5c329456364de31339801748b8e65e7879b7f6bea9a5376d48872e272a7fb2f88c72e8a13d8fe95ed4000253e68d32ae23af294947a36a0d43c26149
+MISC metadata.xml 249 BLAKE2B a4931a30c3947b238913053d611639235b076475e864914e684020d86ee1b4aa6da94e4cef59c53a0e5ccd3b3d15d3a4ae293800b17bbb89e0af9cff79314a70 SHA512 b1cb770984baef468e3d17e343acff395e1993b14f90def7f8582b5e5d1a512bd3c7727e03f1deca47f7359a8f8cc9a8360130923388a5c06fabbfb9b05d5138
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
new file mode 100644
index 000000000000..6672763d608f
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mv test.py test_some.py || die # help pytest with test discovery
+ default
+}
diff --git a/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild b/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild
new file mode 100644
index 000000000000..e83eaba0bc60
--- /dev/null
+++ b/dev-vcs/git-big-picture/git-big-picture-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Visualization tool for Git repositories"
+HOMEPAGE="https://github.com/git-big-picture/git-big-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# No need for "[python]" or "[${PYTHON_USEDEP}]" with any of these
+# since they are invoked using subprocess
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cram[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-vcs/git
+ media-gfx/graphviz[svg]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+
+ distutils_install_for_testing
+ cram test.cram || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-vcs/git-big-picture/metadata.xml b/dev-vcs/git-big-picture/metadata.xml
new file mode 100644
index 000000000000..ab886b7f0382
--- /dev/null
+++ b/dev-vcs/git-big-picture/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>