summaryrefslogtreecommitdiff
path: root/dev-util/xxdi/xxdi-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/xxdi/xxdi-1.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/xxdi/xxdi-1.0.0.ebuild')
-rw-r--r--dev-util/xxdi/xxdi-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/xxdi/xxdi-1.0.0.ebuild b/dev-util/xxdi/xxdi-1.0.0.ebuild
new file mode 100644
index 000000000000..e5a189229eee
--- /dev/null
+++ b/dev-util/xxdi/xxdi-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_VERSION=001
+
+DESCRIPTION="Simple alternative to vim's 'xxd -i' mode"
+HOMEPAGE="https://github.com/gregkh/xxdi"
+SRC_URI="https://github.com/gregkh/xxdi/archive/v${MODULE_VERSION}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Slurp"
+
+S=${WORKDIR}/${PN}-${MODULE_VERSION}
+
+src_install() {
+ dobin xxdi.pl
+ dodoc README.md
+}