summaryrefslogtreecommitdiff
path: root/dev-util/xxdi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/xxdi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/xxdi')
-rw-r--r--dev-util/xxdi/Manifest3
-rw-r--r--dev-util/xxdi/metadata.xml20
-rw-r--r--dev-util/xxdi/xxdi-1.0.0.ebuild25
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/xxdi/Manifest b/dev-util/xxdi/Manifest
new file mode 100644
index 000000000000..b956dbaf0924
--- /dev/null
+++ b/dev-util/xxdi/Manifest
@@ -0,0 +1,3 @@
+DIST xxdi-1.0.0.tar.gz 8039 BLAKE2B bc881ea566e5f34f03a9c9f2adb42294cf75fb5f663537491a14d393d5e55ba571afe211277bab2f5dfb3128f98b20832430295a71cce255b0196e2448a0b853 SHA512 ebf026f61f0b0a339e3dfa5c9dd6a819ef23f0d29948073cbf5f6ae9668e68a7dd903f695ab5a824494f8424dad8b79aace5742bc23484a25303a15aa32ab698
+EBUILD xxdi-1.0.0.ebuild 524 BLAKE2B df32d03eeb37f01060d9fd573d656ad23ff05ec8128203859b6e80bc6eb5ad0803c934b0f8f567c6220b8884b845bc3d4607d6045d8df37804ced92a9a78bd7d SHA512 fb0557381100c993af68928e186c007f216ea0eb1a9ddab2b1f6da3c8ed6ee9ff502ab555d8d40c9be4a08870e7450f363775b8abbaabd99632fd44839213d21
+MISC metadata.xml 725 BLAKE2B 33538c0cfbeba53623ea742ff310ec5221ba0eb344a000029d65735dc86b968e5d769c6dc80220a02607c80c08b6dd3c65adfb6b4d395d50fe0893b99f4d98e0 SHA512 e123546a703ba283f8f4cebdf737d911d88405fd7a36b991939497891eef66ca2253711dba21b67a3ce58bf1fadb21054c20464c05e2cf42295cd1eef8cb6626
diff --git a/dev-util/xxdi/metadata.xml b/dev-util/xxdi/metadata.xml
new file mode 100644
index 000000000000..2e483a030941
--- /dev/null
+++ b/dev-util/xxdi/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ xxdi.pl is a perl script that implements vim's 'xxd -i' mode
+ so that packages do not have to use all of vim just to get this
+ functionality.
+
+ efitools is an example of a package that uses it in this manner,
+ and in some build configurations, mediastreamer also does.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>gregkh@linuxfoundation.org</email>
+ <name>Greg Kroah-Hartman</name>
+ </maintainer>
+ <bugs-to>https://github.com/gregkh/xxdi/issues</bugs-to>
+ <remote-id type="github">gregkh/xxdi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/xxdi/xxdi-1.0.0.ebuild b/dev-util/xxdi/xxdi-1.0.0.ebuild
new file mode 100644
index 000000000000..e5a189229eee
--- /dev/null
+++ b/dev-util/xxdi/xxdi-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_VERSION=001
+
+DESCRIPTION="Simple alternative to vim's 'xxd -i' mode"
+HOMEPAGE="https://github.com/gregkh/xxdi"
+SRC_URI="https://github.com/gregkh/xxdi/archive/v${MODULE_VERSION}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/File-Slurp"
+
+S=${WORKDIR}/${PN}-${MODULE_VERSION}
+
+src_install() {
+ dobin xxdi.pl
+ dodoc README.md
+}