summaryrefslogtreecommitdiff
path: root/dev-util/statifier/statifier-1.7.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-util/statifier/statifier-1.7.4.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-util/statifier/statifier-1.7.4.ebuild')
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
index 08b4f7afec9b..b4021f0a1cf3 100644
--- a/dev-util/statifier/statifier-1.7.4.ebuild
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit multilib-build
+inherit multilib-build toolchain-funcs
DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
HOMEPAGE="http://statifier.sourceforge.net"
@@ -20,20 +20,23 @@ RDEPEND="app-shells/bash
sys-apps/coreutils
virtual/awk"
-src_prepare() {
+PATCHES=(
# Respect users CFLAGS and LDFLAGS
- sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+ "${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
+)
+
+src_prepare() {
+ default
# Don't compile 32-bit on amd64 no-multilib profile
if ! use abi_x86_32; then
sed -i -e 's/ELF32 .*/ELF32 := no/g' configs/config.x86_64 || die
fi
-
- # Apply user patches
- eapply_user
}
src_configure() {
+ tc-export CC
+
# Fix permissions, as configure is not marked executable
chmod +x configure || die
econf