summaryrefslogtreecommitdiff
path: root/dev-util/statifier
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-util/statifier
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-util/statifier')
-rw-r--r--dev-util/statifier/Manifest3
-rw-r--r--dev-util/statifier/files/statifier-1.7.4-fix-build-system.patch48
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild17
3 files changed, 60 insertions, 8 deletions
diff --git a/dev-util/statifier/Manifest b/dev-util/statifier/Manifest
index 9fbb2a7c62b5..3ac7d7e802dc 100644
--- a/dev-util/statifier/Manifest
+++ b/dev-util/statifier/Manifest
@@ -1,3 +1,4 @@
+AUX statifier-1.7.4-fix-build-system.patch 2104 BLAKE2B 019248feff682a75b90d1aca7eea425aded1b0f01e8dff4bd24410a474ef1350ed8215803915cb52df53866f6dc996428742d0a9187f55bbff17ce30894dd6b3 SHA512 a9bf5adf1206bbca84084df0680785e1f31902fb7ce4d455593ee35e0195ef9546de641d2f5372843afb7c8584fb04b1b13ee7973813ee8561a2282f2162cc87
DIST statifier-1.7.4.tar.gz 73245 BLAKE2B 897b78b31aa4f148b6a6a986251ba9d4f40ebad3209f71896ffffb71e06ab25d337a4a79adc0217592051f917bc71428d3032f6216ec053f62c4632edef474d5 SHA512 22d4873130bafe06144c8f6ce7089aa25e3eb047bbee5709344fee1e8d85b24aac689c88d34537fe4a690e231d768e56a2fa13672b9eccf27d945b3f8bcda756
-EBUILD statifier-1.7.4.ebuild 1129 BLAKE2B 925e516a8711b4c71e39e0f77160f9f144d66139536a86a4daec55ee2debb29369d9cb87ea67463295ee0aa42c2ae8ca8ddcd7fe13a61ac0f58bfc0875b91914 SHA512 43321c83d8fbd0228f91f6dacdae168db1fe7fd1f73b5c41d42c731182e2bb5e7a9dd1508c1ccaea85bac16fdac3675e454bccfc637ce50682bbd337a3ced075
+EBUILD statifier-1.7.4.ebuild 1125 BLAKE2B b0b81af822f90d001cc7509a74334e8149bcc26d0f106d84aaa2ca27d5d79b033da1813d60bb37119c604eaf0f007f6c2a6c3553fedcadaacb53fbc49be116eb SHA512 9a8749dfce5361eb7771e0f330b300c1ce56f08ff6cd93abf1457a2ddcb81b3016c14c54df0fdb602f20b72c97d7f799ae496043024ddae347f3af43da19923e
MISC metadata.xml 369 BLAKE2B 99bc89ce5469bce6e867ce73fa66fee3fa41bf2166453c3606b03b1f3879f837c46d41068430e217a7ab4b0d0096650762095ffe5f13382ab055e5815f90ebb1 SHA512 5d49b66d13a6055421fc9e9a180d6d5657e367cfdc6e74a13c16955cc1bfda765605f0ab7c0d7d5f67ce847e09306fef52a2fb621eccdf358e5d21e82129a2b3
diff --git a/dev-util/statifier/files/statifier-1.7.4-fix-build-system.patch b/dev-util/statifier/files/statifier-1.7.4-fix-build-system.patch
new file mode 100644
index 000000000000..ef8c6a516bd1
--- /dev/null
+++ b/dev-util/statifier/files/statifier-1.7.4-fix-build-system.patch
@@ -0,0 +1,48 @@
+Honour user flags and CC
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -170,7 +170,7 @@
+ echo "VERSION='$(VERSION)'" > $@ || { $(RM) $@; exit 1; }
+
+ $(UTILS_WITH_ELF_CLASS): $(ELF_CLASS)/%: %.c
+- gcc $(FLAGS_ELF) -I$(CPU_DIR) -Wall -O2 -g $< -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(FLAGS_ELF) -I$(CPU_DIR) -g $< -o $@
+
+ MY_GDB_CFILES := \
+ breakpoints.c \
+@@ -187,13 +187,13 @@
+
+ MY_GDB_CPPFLAGS := -I. -I$(CPU_DIR) -I$(ELF_CLASS)
+ $(MY_GDB_OBJ_FILES): $(ELF_CLASS)/%.o: my_gdb/%.c
+- gcc -c $(FLAGS_ELF) $(MY_GDB_CPPFLAGS) -Wall -O2 -g $< -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) -c $(FLAGS_ELF) $(MY_GDB_CPPFLAGS) -g $< -o $@
+
+ $(ELF_CLASS)/my_gdb: $(MY_GDB_OBJ_FILES)
+- gcc $(FLAGS_ELF) $^ -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(FLAGS_ELF) $^ -o $@
+
+ $(ELF_CLASS)/dl-var.s: dl-var.c dl-var.inc
+- gcc $(FLAGS_ELF) $(FLAGS_C_TO_ASM_ELF) -Wall -O2 -S $< -o $@.s
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(FLAGS_ELF) $(FLAGS_C_TO_ASM_ELF) -S $< -o $@.s
+ /bin/sh asm.make.sh < $@.s > $@ || { $(RM) $@; exit 1; }
+
+ # Dependencies should be in correct order
+@@ -210,7 +210,7 @@
+ # Because linker give warning about _start function I specify
+ # pretty dummy '--entry=0x0'
+ $(FILES_TO_BE_EMBEDDED_WITH_ELF_CLASS): $(ELF_CLASS)/%: $(ELF_CLASS)/%.o
+- gcc $(FLAGS_ELF) -o $@ $< -Wl,--oformat,binary,--entry=0x0 -nostdlib
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(FLAGS_ELF) -o $@ $< -Wl,--oformat,binary,--entry=0x0 -nostdlib
+
+ OBJECTS_TO_BE_EMBEDDED_WITH_ELF_CLASS = $(addsuffix .o,$(FILES_TO_BE_EMBEDDED_WITH_ELF_CLASS))
+
+@@ -221,7 +221,7 @@
+ # with -include processor.h, start.S and $<
+ #
+ $(OBJECTS_TO_BE_EMBEDDED_WITH_ELF_CLASS): $(ELF_CLASS)/%.o: $(CPU_DIR)/%.S $(CPU_DIR)/processor.h ./start.S ./end.S
+- gcc $(FLAGS_ELF) -c -o $@ -nostdinc -I$(CURDIR) -I$(CURDIR)/$(ELF_CLASS) -include $(CPU_DIR)/processor.h -include ./start.S -include $< ./end.S
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(FLAGS_ELF) -c -o $@ -nostdinc -I$(CURDIR) -I$(CURDIR)/$(ELF_CLASS) -include $(CPU_DIR)/processor.h -include ./start.S -include $< ./end.S
+
+ # Additional dependencies:
+ $(ELF_CLASS)/regs.o: $(ELF_CLASS)/regs.inc
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
index 08b4f7afec9b..b4021f0a1cf3 100644
--- a/dev-util/statifier/statifier-1.7.4.ebuild
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit multilib-build
+inherit multilib-build toolchain-funcs
DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
HOMEPAGE="http://statifier.sourceforge.net"
@@ -20,20 +20,23 @@ RDEPEND="app-shells/bash
sys-apps/coreutils
virtual/awk"
-src_prepare() {
+PATCHES=(
# Respect users CFLAGS and LDFLAGS
- sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+ "${FILESDIR}"/${PN}-1.7.4-fix-build-system.patch
+)
+
+src_prepare() {
+ default
# Don't compile 32-bit on amd64 no-multilib profile
if ! use abi_x86_32; then
sed -i -e 's/ELF32 .*/ELF32 := no/g' configs/config.x86_64 || die
fi
-
- # Apply user patches
- eapply_user
}
src_configure() {
+ tc-export CC
+
# Fix permissions, as configure is not marked executable
chmod +x configure || die
econf