summaryrefslogtreecommitdiff
path: root/dev-util/qdevicemonitor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
commit6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (patch)
tree860348d8573f52d9ddf8a87c31099b8bb3a04806 /dev-util/qdevicemonitor
parent1118729405d206538433388e0a8bd578f7ae7303 (diff)
gentoo resync : 18.01.2020
Diffstat (limited to 'dev-util/qdevicemonitor')
-rw-r--r--dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-screen-geometry-is-deprecated.patch39
-rw-r--r--dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild52
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-screen-geometry-is-deprecated.patch b/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-screen-geometry-is-deprecated.patch
new file mode 100644
index 000000000000..9b9b46320fe7
--- /dev/null
+++ b/dev-util/qdevicemonitor/files/qdevicemonitor-1.0.1-screen-geometry-is-deprecated.patch
@@ -0,0 +1,39 @@
+From 08985f03236a70b35b03b2749cabbd45398e968b Mon Sep 17 00:00:00 2001
+From: Alexander Lopatin <alopatindev@gmail.com>
+Date: Thu, 16 Jan 2020 11:26:38 +0300
+Subject: [PATCH] Fix "error: const QRect QDesktopWidget::screenGeometry(int)
+ const is deprecated: Use QGuiApplication::screens()
+ [-Werror=deprecated-declarations]" https://bugs.gentoo.org/705438
+
+Signed-off-by: Alexander Lopatin <alopatindev@gmail.com>
+---
+ qdevicemonitor/ui/MainWindow.cpp | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/qdevicemonitor/ui/MainWindow.cpp b/qdevicemonitor/ui/MainWindow.cpp
+index 4266de6..69d4433 100644
+--- a/qdevicemonitor/ui/MainWindow.cpp
++++ b/qdevicemonitor/ui/MainWindow.cpp
+@@ -29,6 +29,7 @@
+ #include <QFileInfo>
+ #include <QMessageBox>
+ #include <QProcess>
++#include <QScreen>
+ #include <QSettings>
+ #include <QStringList>
+ #include <QTabBar>
+@@ -181,9 +182,9 @@ void MainWindow::loadSettings()
+ {
+ setGeometry(geom.toRect());
+ }
+- else
++ else if (!qApp->screens().isEmpty())
+ {
+- QRect geom = qApp->desktop()->screenGeometry();
++ QRect geom = qApp->screens()[0]->availableVirtualGeometry();
+ const int screenWidth = geom.width();
+ const int screenHeight = geom.height();
+ geom.setWidth(int(screenWidth * 0.7f));
+--
+2.21.0
+
diff --git a/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..fd543ed3980a
--- /dev/null
+++ b/dev-util/qdevicemonitor/qdevicemonitor-1.0.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit desktop qmake-utils
+
+DESCRIPTION="Crossplatform log viewer for Android, iOS and text files"
+HOMEPAGE="https://github.com/alopatindev/qdevicemonitor"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alopatindev/${PN}"
+else
+ SRC_URI="https://github.com/alopatindev/qdevicemonitor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-util/android-tools
+ app-pda/usbmuxd"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-qt-5.11.patch
+ "${FILESDIR}"/${P}-crash-after-fresh-install.patch
+ "${FILESDIR}"/${P}-screen-geometry-is-deprecated.patch
+)
+
+src_configure() {
+ cd "${PN}" || die
+ export VERSION_WITH_BUILD_NUMBER="${PV}"
+ eqmake5
+}
+
+src_compile() {
+ cd "${PN}" || die
+ emake
+}
+
+src_install() {
+ dobin "${PN}/${PN}"
+ dodoc README.md
+ newicon -s scalable "icons/app_icon.svg" "${PN}.svg"
+ domenu "icons/${PN}.desktop"
+}