summaryrefslogtreecommitdiff
path: root/dev-util/promu/promu-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/promu/promu-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/promu/promu-0.1.0.ebuild')
-rw-r--r--dev-util/promu/promu-0.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/promu/promu-0.1.0.ebuild b/dev-util/promu/promu-0.1.0.ebuild
new file mode 100644
index 000000000000..6cefcabc0a9c
--- /dev/null
+++ b/dev-util/promu/promu-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="5e82f2f"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ LDFLAGS="-X github.com/prometheus/vendor/github.com/prometheus/common/version.Version=$(cat src/${EGO_PN}/VERSION)
+ -X github.com/prometheus/vendor/github.com/prometheus/common/version.Revision=${EGIT_COMMIT}
+ -extldflags \"-static\""
+ GOPATH="${S}" go build -ldflags "${LDFLAGS}" -o bin/promu src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}