summaryrefslogtreecommitdiff
path: root/dev-util/promu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/promu
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/promu')
-rw-r--r--dev-util/promu/Manifest4
-rw-r--r--dev-util/promu/metadata.xml11
-rw-r--r--dev-util/promu/promu-0.1.0.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/promu/Manifest b/dev-util/promu/Manifest
new file mode 100644
index 000000000000..732b7a99f84c
--- /dev/null
+++ b/dev-util/promu/Manifest
@@ -0,0 +1,4 @@
+DIST promu-0.1.0.tar.gz 1065003 SHA256 043c4149bc85e4d51a93390cdb4fee6871d93123ced5c2d3d4f78a2265167bbc SHA512 18ad54b1ec9fe8975a0048b5c85609858cd500a2d3aa34e51e5c2c3d07a0df4337bac9648562e2007d5c8572e07c814c6bba7522b94836c258cde457df5815e2 WHIRLPOOL 3717496ee2296bfa27baf47d601f3bb5eaa4e4e27c3ebd7fd71979ae9e29d833f04065a16add9b2410fb4cff040d98a51e9d628ba316ab8cb488eda2ef4f7b15
+EBUILD promu-0.1.0.ebuild 853 SHA256 62d2df20ff7ee2736e8c6e0cd57d08909acf15e0c4146d125f9e2f05696ada24 SHA512 3fe36dce670c3f49888edf59ab8629fc2e2f8d8cd3ed1a9eaf3dda3801c889d97b573cc0078b17fa9359d21960a0f5bfca08454f0b15441a53b14bef47e1616f WHIRLPOOL 6c597cf2ac412b8d163fe085a6abed740a6c98b614b5aa8e8888055fc912bc9be0e7028155b3eb55d41800863e580d911550e0563274b3890a116c505d96f9a4
+MISC ChangeLog 336 SHA256 76e511d7d1c57337dd5267f808eabaa2404586af47c60b669149f3fa537157a3 SHA512 92749443b98120a227c119bcc5f2062670974f29b1712ea7bb2ab7df019369673eb1db2ea1993b73eaecd87dc843a28a15b9b2522dbe91fea02e1352ba2d61aa WHIRLPOOL 2648285a1fa4b5da3913efd935195c32a1e1b65a8598e74ed28b67f716235bb8fa112fc9d85ecbd5784aea34dc04f3d1d5c2422088ace8c919d76386ba5b90d5
+MISC metadata.xml 326 SHA256 5dbb55e07c5fb7ac57941fc6df1f1b26448104f4acab549b744a9d17e2adea87 SHA512 2870183c141e5d9ec65aba01e7ab02443f42d13d0f39c4ba51af7adacabdf360cb2308cb898c4bf4f0a8c3e20b35d511af2b978fafcb4de47177de77819f6853 WHIRLPOOL 51b7fef293e4f4b7e6aba9574d917eaa80c20553599482570eb0b3e0f97888ea00b65a9ffef75cb81e27708153ab627ef2f3b1d40c2f23766dab98460e532f78
diff --git a/dev-util/promu/metadata.xml b/dev-util/promu/metadata.xml
new file mode 100644
index 000000000000..547d58abc6fd
--- /dev/null
+++ b/dev-util/promu/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">prometheus/promu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/promu/promu-0.1.0.ebuild b/dev-util/promu/promu-0.1.0.ebuild
new file mode 100644
index 000000000000..6cefcabc0a9c
--- /dev/null
+++ b/dev-util/promu/promu-0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/promu"
+EGIT_COMMIT="5e82f2f"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ LDFLAGS="-X github.com/prometheus/vendor/github.com/prometheus/common/version.Version=$(cat src/${EGO_PN}/VERSION)
+ -X github.com/prometheus/vendor/github.com/prometheus/common/version.Revision=${EGIT_COMMIT}
+ -extldflags \"-static\""
+ GOPATH="${S}" go build -ldflags "${LDFLAGS}" -o bin/promu src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{doc,{README,CONTRIBUTING}.md}
+}