summaryrefslogtreecommitdiff
path: root/dev-util/pkgconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
commit21616d4521c47fc859035ab3939842cddd56e374 (patch)
treebbe695483012ac54498cd55c2d9c03c67fef36d0 /dev-util/pkgconf
parent3fd9d065ab109700e92fc1cea2a6519a39a5b007 (diff)
gentoo auto-resync : 09:08:2022 - 08:15:37
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/pkgconf-1.9.1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-util/pkgconf/pkgconf-1.9.1.ebuild b/dev-util/pkgconf/pkgconf-1.9.1.ebuild
deleted file mode 100644
index 743bdb4a60b0..000000000000
--- a/dev-util/pkgconf/pkgconf-1.9.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2012-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
-else
- SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- # Per release notes, 1.9.0 is a testing/development release.
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
-HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
-
-LICENSE="ISC"
-SLOT="0/4"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-libs/atf
- dev-util/kyua
- )
-"
-RDEPEND="!dev-util/pkgconfig"
-
-src_prepare() {
- default
-
- [[ ${PV} == 9999 ]] && eautoreconf
-
- MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf
- /usr/bin/pkg-config$(get_exeext)
- )
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --with-system-includedir="${EPREFIX}/usr/include"
- --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
- )
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
- default
-}
-
-multilib_src_install() {
- default
-
- dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
- dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find "${ED}" -type f -name '*.la' -delete || die
-}