summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
commit21616d4521c47fc859035ab3939842cddd56e374 (patch)
treebbe695483012ac54498cd55c2d9c03c67fef36d0 /dev-util
parent3fd9d065ab109700e92fc1cea2a6519a39a5b007 (diff)
gentoo auto-resync : 09:08:2022 - 08:15:37
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/Manifest.gzbin67966 -> 67963 bytes
-rw-r--r--dev-util/difftastic/difftastic-0.31.0.ebuild121
-rw-r--r--dev-util/gcovr/gcovr-4.2.ebuild45
-rw-r--r--dev-util/pkgconf/pkgconf-1.9.1.ebuild70
-rw-r--r--dev-util/rebar/Manifest2
-rw-r--r--dev-util/rebar/rebar-3.19.0.ebuild2
6 files changed, 2 insertions, 238 deletions
diff --git a/dev-util/Manifest.gz b/dev-util/Manifest.gz
index 59d1d5041f66..f952641b69dd 100644
--- a/dev-util/Manifest.gz
+++ b/dev-util/Manifest.gz
Binary files differ
diff --git a/dev-util/difftastic/difftastic-0.31.0.ebuild b/dev-util/difftastic/difftastic-0.31.0.ebuild
deleted file mode 100644
index 3e049575a92d..000000000000
--- a/dev-util/difftastic/difftastic-0.31.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Auto-Generated by cargo-ebuild 0.5.1
-
-EAPI=8
-
-CRATES="
- aho-corasick-0.7.18
- ansi_term-0.12.1
- archery-0.4.0
- atty-0.2.14
- autocfg-1.1.0
- bitflags-1.3.2
- bumpalo-3.9.1
- bytecount-0.6.2
- cc-1.0.73
- cfg-if-1.0.0
- clap-3.1.18
- clap_lex-0.2.0
- const_format-0.2.23
- const_format_proc_macros-0.2.22
- crossbeam-channel-0.5.4
- crossbeam-deque-0.8.1
- crossbeam-epoch-0.9.8
- crossbeam-utils-0.8.8
- ctor-0.1.22
- diff-0.1.12
- either-1.6.1
- env_logger-0.7.1
- fixedbitset-0.4.1
- fnv-1.0.7
- hashbrown-0.11.2
- hermit-abi-0.1.19
- humantime-1.3.0
- indexmap-1.7.0
- itertools-0.10.3
- lazy_static-1.4.0
- libc-0.2.126
- libmimalloc-sys-0.1.24
- log-0.4.17
- memchr-2.5.0
- memoffset-0.6.5
- mimalloc-0.1.28
- minimal-lexical-0.2.1
- nom-7.1.1
- num_cpus-1.13.1
- once_cell-1.12.0
- os_str_bytes-6.0.1
- output_vt100-0.1.3
- owo-colors-3.4.0
- petgraph-0.6.1
- pretty_assertions-1.2.1
- pretty_env_logger-0.4.0
- proc-macro2-1.0.39
- quick-error-1.2.3
- quote-1.0.18
- radix-heap-0.4.2
- rayon-1.5.3
- rayon-core-1.9.3
- regex-1.5.6
- regex-syntax-0.6.26
- rpds-0.10.0
- rustc-hash-1.1.0
- same-file-1.0.6
- scopeguard-1.1.0
- static_assertions-1.1.0
- strsim-0.10.0
- syn-1.0.95
- term_size-0.3.2
- termcolor-1.1.3
- terminal_size-0.1.17
- textwrap-0.15.0
- tree-sitter-0.20.6
- tree_magic_mini-3.0.3
- typed-arena-2.0.1
- unicode-ident-1.0.0
- unicode-width-0.1.9
- unicode-xid-0.2.3
- walkdir-2.3.2
- winapi-0.3.9
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-util-0.1.5
- winapi-x86_64-pc-windows-gnu-0.4.0
- wu-diff-0.1.2
-"
-
-inherit cargo
-
-DESCRIPTION="A structural diff that understands syntax."
-# Double check the homepage as the cargo_metadata crate
-# does not provide this value so instead repository is used
-HOMEPAGE="https://github.com/wilfred/difftastic"
-SRC_URI="
- $(cargo_crate_uris ${CRATES})
- https://github.com/Wilfred/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-# License set may be more restrictive as OR is not respected
-# use cargo-license for a more accurate license picture
-LICENSE="Apache-2.0 MIT MPL-2.0 Unlicense ZLIB"
-SLOT="0"
-KEYWORDS="~amd64"
-
-QA_FLAGS_IGNORED="usr/bin/difft"
-
-DOCS=(
- CHANGELOG.md
- README.md
- manual/
-)
-
-src_prepare() {
- rm manual/.gitignore || die
- default
-}
-
-src_install() {
- cargo_src_install
- dodoc -r "${DOCS[@]}"
-}
diff --git a/dev-util/gcovr/gcovr-4.2.ebuild b/dev-util/gcovr/gcovr-4.2.ebuild
deleted file mode 100644
index fc1fc53cd521..000000000000
--- a/dev-util/gcovr/gcovr-4.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="A Python script for summarizing gcov data"
-HOMEPAGE="https://github.com/gcovr/gcovr"
-SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( dev-python/PyUtilib[${PYTHON_USEDEP}] )
-"
-
-# tests fail on gcc newer than 5.8
-RESTRICT="test"
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
-
- local -x PATH="${TEST_DIR}/scripts:${PATH}" \
- PYTHONPATH="${TEST_DIR}/lib"
-
- local deselect=(
- # those tests fail on gcc newer than 5.8
- # https://github.com/gcovr/gcovr/issues/206
- gcovr/tests/test_gcovr.py
- )
-
- epytest gcovr ${deselect[@]/#/--deselect }
-}
diff --git a/dev-util/pkgconf/pkgconf-1.9.1.ebuild b/dev-util/pkgconf/pkgconf-1.9.1.ebuild
deleted file mode 100644
index 743bdb4a60b0..000000000000
--- a/dev-util/pkgconf/pkgconf-1.9.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2012-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
-else
- SRC_URI="https://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
- # Per release notes, 1.9.0 is a testing/development release.
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
-HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
-
-LICENSE="ISC"
-SLOT="0/4"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-libs/atf
- dev-util/kyua
- )
-"
-RDEPEND="!dev-util/pkgconfig"
-
-src_prepare() {
- default
-
- [[ ${PV} == 9999 ]] && eautoreconf
-
- MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf
- /usr/bin/pkg-config$(get_exeext)
- )
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --with-system-includedir="${EPREFIX}/usr/include"
- --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
- )
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
- default
-}
-
-multilib_src_install() {
- default
-
- dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
- dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find "${ED}" -type f -name '*.la' -delete || die
-}
diff --git a/dev-util/rebar/Manifest b/dev-util/rebar/Manifest
index a30a1b51be53..fe2650f605aa 100644
--- a/dev-util/rebar/Manifest
+++ b/dev-util/rebar/Manifest
@@ -18,5 +18,5 @@ DIST relx-4.7.0.tar 76288 BLAKE2B 99af942824344a617dc19b771d5db697fd8d8a19776a67
DIST ssl_verify_fun-1.1.6.tar 14848 BLAKE2B 31f8a92881803b1b93e2f65cf070449cd53af21b50f6aae7a9d036e28c17b2c093b2cb6238279191663ba011aab7fd604af8366ed8ae91b7b1d7c333f9de9ea8 SHA512 65980368629357ec16b37fd8ea1d42f7dbd7fa86318b329bec756e868b70eb4c93cf1bfe3dd34e1b6c011086ba32e11981d61e18fdad78564b77664e4d155a47
EBUILD rebar-2.6.4-r1.ebuild 671 BLAKE2B e2634bb01418f81f97c9d30a91083efb2ed87416b7e42a48e83acd5f07956ce14e8fed23f782bbba6437139da730c2cdabe7d0c523a447966b43c6e2dabf8033 SHA512 95cd7d605d4a3fe6940be8fe90d42db7b413bd0b1983a4ed44cd511308244e64e88d49a70306c9262556a1717402c41e42849c7420f1e958dfc300ce631eb382
EBUILD rebar-3.18.0-r1.ebuild 2462 BLAKE2B 9bdf8762c0a0dedf4ebb5626b5403dbcb847b97cfaa18474fa91d815a816b7c9f926a7e3fd78be27c8fd03f81efaa131e391366405ce053171bebc6c8bdcdd8e SHA512 a005414b5f1fb40fd17a5fa4e0233d50e20d7750cc5eb95831af2090a136fa2f09a1d841690787814636ada855b760cb3303fc0c547ce7af7ee8bbd2b334287c
-EBUILD rebar-3.19.0.ebuild 2467 BLAKE2B 6ddd2cd70be8c2c931e7ce85ee791042a50258a4f69c480264e30505a8350e45ee8fca69534a0c15548fdfe89ac80c9318e77df1b444a7e69f8526c0f61697de SHA512 aae6547794b8a5e08b6ca4709a07db8f3b34b6e1c0a3491d88a56425cb2cafe1712c2dadc2f67ade1c1e9dd6d34164d989062e9520491472b6541e4fb21b36d6
+EBUILD rebar-3.19.0.ebuild 2462 BLAKE2B 52b97493bde303b742e274dd294bde9df57a89b4bd4bce81034599e2297a73198373e9588da48fe54dc58e57b3100025a75fb78117c91fa76190a3b8795f8ffe SHA512 93c6921f3d94ebcf7d37f9e4f0d68717cb4e7e7924fac52297f95162940ba4ca8e2160b42cf37139721ad9c51ce63ab9cde1b71ba29491db2c1b409cc5e69c79
MISC metadata.xml 361 BLAKE2B d58dbad87667d782d0b5d81f0d9166b4e93dc0dea86b7b665acd6463c945949425746085f1a36cc952ad0ca3bcd7acb949a855c2aa57eae8a18bfd16120da1ae SHA512 aa1aae5e0688d6e921d4018714a37f079a333282baff352d7faeef3b1810471be421c99a705b1b97de0cb5c846efb69b3ec4f018033cb56efc307164fb8871c3
diff --git a/dev-util/rebar/rebar-3.19.0.ebuild b/dev-util/rebar/rebar-3.19.0.ebuild
index 6229094316c4..8cd38412ecbb 100644
--- a/dev-util/rebar/rebar-3.19.0.ebuild
+++ b/dev-util/rebar/rebar-3.19.0.ebuild
@@ -27,7 +27,7 @@ S="${WORKDIR}"/${MY_PN}-${PV}
LICENSE="Apache-2.0 MIT BSD"
SLOT="3"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"