summaryrefslogtreecommitdiff
path: root/dev-util/gcovr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
commit21616d4521c47fc859035ab3939842cddd56e374 (patch)
treebbe695483012ac54498cd55c2d9c03c67fef36d0 /dev-util/gcovr
parent3fd9d065ab109700e92fc1cea2a6519a39a5b007 (diff)
gentoo auto-resync : 09:08:2022 - 08:15:37
Diffstat (limited to 'dev-util/gcovr')
-rw-r--r--dev-util/gcovr/gcovr-4.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-util/gcovr/gcovr-4.2.ebuild b/dev-util/gcovr/gcovr-4.2.ebuild
deleted file mode 100644
index fc1fc53cd521..000000000000
--- a/dev-util/gcovr/gcovr-4.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="A Python script for summarizing gcov data"
-HOMEPAGE="https://github.com/gcovr/gcovr"
-SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( dev-python/PyUtilib[${PYTHON_USEDEP}] )
-"
-
-# tests fail on gcc newer than 5.8
-RESTRICT="test"
-
-distutils_enable_tests pytest
-
-python_test() {
- distutils_install_for_testing
-
- local -x PATH="${TEST_DIR}/scripts:${PATH}" \
- PYTHONPATH="${TEST_DIR}/lib"
-
- local deselect=(
- # those tests fail on gcc newer than 5.8
- # https://github.com/gcovr/gcovr/issues/206
- gcovr/tests/test_gcovr.py
- )
-
- epytest gcovr ${deselect[@]/#/--deselect }
-}