summaryrefslogtreecommitdiff
path: root/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild')
-rw-r--r--dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild b/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild
new file mode 100644
index 000000000000..e4e77ba0b9f3
--- /dev/null
+++ b/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Visualization of hierarchical data, especially pofiled stack traces"
+HOMEPAGE="https://www.brendangregg.com/flamegraphs.html https://github.com/brendangregg/FlameGraph"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/brendangregg/FlameGraph.git"
+else
+ SRC_URI="https://dev.gentoo.org/~flow/distfiles/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CDDL"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/awk
+"
+
+src_test() {
+ ./test.sh || die
+}
+
+src_install() {
+ dobin *.pl *.awk
+ dodoc README.md
+}