summaryrefslogtreecommitdiff
path: root/dev-util/FlameGraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/FlameGraph
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/FlameGraph')
-rw-r--r--dev-util/FlameGraph/FlameGraph-1.0.ebuild32
-rw-r--r--dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild32
-rw-r--r--dev-util/FlameGraph/FlameGraph-9999.ebuild32
-rw-r--r--dev-util/FlameGraph/Manifest6
-rw-r--r--dev-util/FlameGraph/metadata.xml8
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-util/FlameGraph/FlameGraph-1.0.ebuild b/dev-util/FlameGraph/FlameGraph-1.0.ebuild
new file mode 100644
index 000000000000..dbf96c39df4e
--- /dev/null
+++ b/dev-util/FlameGraph/FlameGraph-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Visualization of hierarchical data, especially pofiled stack traces"
+HOMEPAGE="https://www.brendangregg.com/flamegraphs.html https://github.com/brendangregg/FlameGraph"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/brendangregg/FlameGraph.git"
+else
+ SRC_URI="https://github.com/brendangregg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CDDL"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/awk
+"
+
+src_test() {
+ ./test.sh || die
+}
+
+src_install() {
+ dobin *.pl *.awk
+ dodoc README.md
+}
diff --git a/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild b/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild
new file mode 100644
index 000000000000..e4e77ba0b9f3
--- /dev/null
+++ b/dev-util/FlameGraph/FlameGraph-1.0_p20210830.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Visualization of hierarchical data, especially pofiled stack traces"
+HOMEPAGE="https://www.brendangregg.com/flamegraphs.html https://github.com/brendangregg/FlameGraph"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/brendangregg/FlameGraph.git"
+else
+ SRC_URI="https://dev.gentoo.org/~flow/distfiles/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CDDL"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/awk
+"
+
+src_test() {
+ ./test.sh || die
+}
+
+src_install() {
+ dobin *.pl *.awk
+ dodoc README.md
+}
diff --git a/dev-util/FlameGraph/FlameGraph-9999.ebuild b/dev-util/FlameGraph/FlameGraph-9999.ebuild
new file mode 100644
index 000000000000..dbf96c39df4e
--- /dev/null
+++ b/dev-util/FlameGraph/FlameGraph-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Visualization of hierarchical data, especially pofiled stack traces"
+HOMEPAGE="https://www.brendangregg.com/flamegraphs.html https://github.com/brendangregg/FlameGraph"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/brendangregg/FlameGraph.git"
+else
+ SRC_URI="https://github.com/brendangregg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CDDL"
+SLOT="0"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/awk
+"
+
+src_test() {
+ ./test.sh || die
+}
+
+src_install() {
+ dobin *.pl *.awk
+ dodoc README.md
+}
diff --git a/dev-util/FlameGraph/Manifest b/dev-util/FlameGraph/Manifest
new file mode 100644
index 000000000000..ac4852427419
--- /dev/null
+++ b/dev-util/FlameGraph/Manifest
@@ -0,0 +1,6 @@
+DIST FlameGraph-1.0.tar.gz 1049627 BLAKE2B 4ac6669de754d5c17cd783a2f4aca956f48ef5f2d02740ee63c10629b940df70ea4ea66b8ea5ebbe3c1da5ca74987383ffd700409ce469ad43eedcb72d2e8a3c SHA512 0ae27fd14f76f0db7873a50079efb2bc4fd77ee6550700746b51eeee6813fbebb233d35d744e1b397734da9f89b25c4c0de3567f283cf1218ee7baee46e1b8e8
+DIST FlameGraph-1.0_p20210830.tar.gz 1057405 BLAKE2B 75669be86ace6e6ccb30bd3883c77aef9a3b6e9c1d5d62e4d22f4090d9934a37fa083fe7783e4514f5439448c7d39d3f1c3b839170ac523e44a3bca71597463b SHA512 16769c1e3e907f0b53fd544a55eb3f580a2f1af55dd22b594d6aac9f4ffa881a2cdc6ddfc3599a6479eb127c1d3aefe0052dff1932553a2bdc377aa6f995f26c
+EBUILD FlameGraph-1.0.ebuild 679 BLAKE2B 503e0bf6daf12f57c73833da0303784eb97c079f7b0a6fa24dd07841bc263bc63e254123f05afd4135663a55dc2df1f623e8275679cba72852b7e116ae96df6c SHA512 67501fcf34e87e498fa160a0c99ca3151ad00a706c104ab14e5550049c3dc133ba99171002609666e37c53f8e398d0df4b420319acc070b3b2b13ff26702bfc0
+EBUILD FlameGraph-1.0_p20210830.ebuild 661 BLAKE2B 8f962d62d3a327765a6b2c617223e41233585315c0e1b7de05a3f5d11e6b7884fbb141e4d36cbfa350b743dbee8db471f4eff650b4244946636c9064a8025802 SHA512 97c53bcdaa1103789b2171a8ac6792fd7e6587591890f9ceaebf73fc7dc716320b2f534f8d0e242f47c9a370eea31a62467e5768cddc342a1e129b61388cb53d
+EBUILD FlameGraph-9999.ebuild 679 BLAKE2B 503e0bf6daf12f57c73833da0303784eb97c079f7b0a6fa24dd07841bc263bc63e254123f05afd4135663a55dc2df1f623e8275679cba72852b7e116ae96df6c SHA512 67501fcf34e87e498fa160a0c99ca3151ad00a706c104ab14e5550049c3dc133ba99171002609666e37c53f8e398d0df4b420319acc070b3b2b13ff26702bfc0
+MISC metadata.xml 246 BLAKE2B e270b04a529da44d267eaf5bfd160569fc99a3521dfc6495e0a4db19c98e5b9badf77774cc80c7be905f3e97b1c75784bc7b4cb6bfe659d726a47c7ae70e7bfb SHA512 7e2151bbca24beeefd585e18d6c1108442b2d9197679876bb180da3d4896602e83ea701432ff67fc61cccfa9bf642a01a62d87bacf32c55e0a54336c7c5a2c53
diff --git a/dev-util/FlameGraph/metadata.xml b/dev-util/FlameGraph/metadata.xml
new file mode 100644
index 000000000000..87a759d410cf
--- /dev/null
+++ b/dev-util/FlameGraph/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>