summaryrefslogtreecommitdiff
path: root/dev-tex/dot2tex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
commit3a6d209caa07e3be8e8423251b70c8bbeeedb17f (patch)
treeaa94c255fa1bd982214ca518fb93d674cc253101 /dev-tex/dot2tex
parent1f43daba2fbe6f53e67c63944941dc645657c5b3 (diff)
gentoo auto-resync : 12:04:2024 - 00:33:28
Diffstat (limited to 'dev-tex/dot2tex')
-rw-r--r--dev-tex/dot2tex/Manifest2
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild63
-rw-r--r--dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch24
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
index 2918f7a975cd..be6c3d3283b6 100644
--- a/dev-tex/dot2tex/Manifest
+++ b/dev-tex/dot2tex/Manifest
@@ -1,3 +1,5 @@
+AUX dot2tex-2.11.3-setup-py-script.patch 775 BLAKE2B 785ecf2da027e1423938398156b756d52deb39950b9903d82505bb60e7787cd97bd83a8a4cf25818c8d32cfc1abf166e498222ede101fc593eaf9d42c6c30cdc SHA512 e4b4f6431b8375fbd3543d4fcf91e828e1c4c565a5fb32027de2c33aee64ce8e54f3ec7843b3604c1f417a8c421665d2d412a33086d09506720a64384762d379
DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
+EBUILD dot2tex-2.11.3-r1.ebuild 1472 BLAKE2B bd799faba9611ce34ac1b90aaf7bee73aea0d80b27f1b037894ab0a8db9c8d6b731801e7fa77e68e218feb8c00820b25a4873148b32123ec16c35eaf80c90e76 SHA512 f61b086cb99cbe2bffc627382a5c0dd871c5dba8a14961a4ea39dbca6f189a0386459eb32c9fc2b6c17b97b1861c7fde49c287d92c62990bb46259596407bc47
EBUILD dot2tex-2.11.3.ebuild 1384 BLAKE2B b32436730fff119c2e9299dbf9e08416fe967a00b67958cd896b5125e9c90e4bf2adf8d01bb9189edad1813f173cdc78433d99c377fb0be7403a1e6322a4cf86 SHA512 0d11153d900cf54aa495774d55f54410dc8e2045d722d97740a0567200ddc9e92f11208eb6fbcce051362d46508e88f3d88976f20ba73a2632a34568fae53bd3
MISC metadata.xml 406 BLAKE2B 1acb388f5dda8fa375956ee5e2d31db3362654912d62198391113c76e58442087e44fed1269aaa8bc801b05ba5bdfb1a7169c07d899166383bac4ef6c461948a SHA512 8de45a24567e35353856221d9b865a6a7586e140c49585212fa423687da0ba31fe4152079d903624e49d45c783033b46f2fe5a57335817562b20aec1a097c5c5
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild
new file mode 100644
index 000000000000..85bf337ba030
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/xyz2tex/dot2tex"
+SRC_URI="https://github.com/xyz2tex/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # https://github.com/xyz2tex/dot2tex/issues/94
+ tests/test_dot2tex.py::MultipleStatements::test_semicolon
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-setup-py-script.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Syntax failures (old-style print)
+ # Looks fixed in master: https://github.com/xyz2tex/dot2tex/commit/38aeef9615f90fe347c5c45d514eaf00b116422b
+ rm -r "${S}"/tests/experimental || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r docs/_build/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch b/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch
new file mode 100644
index 000000000000..9bda03b5a484
--- /dev/null
+++ b/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch
@@ -0,0 +1,24 @@
+From 7b4c3e2b62a0e988db06051976260faa3889377a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Thu, 11 Apr 2024 23:11:15 +0200
+Subject: [PATCH] setup.py: Drop script "dot2tex" that collides with entrypoint
+
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index d107eed..9f50c7c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -25,7 +25,6 @@ Graphviz_, a more LaTeX friendly look and feel. This is accomplished by:
+ author_email='kjellmf@gmail.com',
+ url="https://github.com/kjellmf/dot2tex",
+ py_modules=['dot2tex.dot2tex', 'dot2tex.dotparsing'],
+- scripts=['dot2tex/dot2tex'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+--
+2.44.0
+