summaryrefslogtreecommitdiff
path: root/dev-tex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 00:33:29 +0100
commit3a6d209caa07e3be8e8423251b70c8bbeeedb17f (patch)
treeaa94c255fa1bd982214ca518fb93d674cc253101 /dev-tex
parent1f43daba2fbe6f53e67c63944941dc645657c5b3 (diff)
gentoo auto-resync : 12:04:2024 - 00:33:28
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/Manifest.gzbin6532 -> 6528 bytes
-rw-r--r--dev-tex/dot2tex/Manifest2
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild63
-rw-r--r--dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch24
-rw-r--r--dev-tex/rubber/Manifest2
-rw-r--r--dev-tex/rubber/files/rubber-1.6.4-pythontex.patch30
-rw-r--r--dev-tex/rubber/rubber-1.6.4-r1.ebuild115
7 files changed, 236 insertions, 0 deletions
diff --git a/dev-tex/Manifest.gz b/dev-tex/Manifest.gz
index c8b15311cc68..58fa133b69d1 100644
--- a/dev-tex/Manifest.gz
+++ b/dev-tex/Manifest.gz
Binary files differ
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
index 2918f7a975cd..be6c3d3283b6 100644
--- a/dev-tex/dot2tex/Manifest
+++ b/dev-tex/dot2tex/Manifest
@@ -1,3 +1,5 @@
+AUX dot2tex-2.11.3-setup-py-script.patch 775 BLAKE2B 785ecf2da027e1423938398156b756d52deb39950b9903d82505bb60e7787cd97bd83a8a4cf25818c8d32cfc1abf166e498222ede101fc593eaf9d42c6c30cdc SHA512 e4b4f6431b8375fbd3543d4fcf91e828e1c4c565a5fb32027de2c33aee64ce8e54f3ec7843b3604c1f417a8c421665d2d412a33086d09506720a64384762d379
DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
+EBUILD dot2tex-2.11.3-r1.ebuild 1472 BLAKE2B bd799faba9611ce34ac1b90aaf7bee73aea0d80b27f1b037894ab0a8db9c8d6b731801e7fa77e68e218feb8c00820b25a4873148b32123ec16c35eaf80c90e76 SHA512 f61b086cb99cbe2bffc627382a5c0dd871c5dba8a14961a4ea39dbca6f189a0386459eb32c9fc2b6c17b97b1861c7fde49c287d92c62990bb46259596407bc47
EBUILD dot2tex-2.11.3.ebuild 1384 BLAKE2B b32436730fff119c2e9299dbf9e08416fe967a00b67958cd896b5125e9c90e4bf2adf8d01bb9189edad1813f173cdc78433d99c377fb0be7403a1e6322a4cf86 SHA512 0d11153d900cf54aa495774d55f54410dc8e2045d722d97740a0567200ddc9e92f11208eb6fbcce051362d46508e88f3d88976f20ba73a2632a34568fae53bd3
MISC metadata.xml 406 BLAKE2B 1acb388f5dda8fa375956ee5e2d31db3362654912d62198391113c76e58442087e44fed1269aaa8bc801b05ba5bdfb1a7169c07d899166383bac4ef6c461948a SHA512 8de45a24567e35353856221d9b865a6a7586e140c49585212fa423687da0ba31fe4152079d903624e49d45c783033b46f2fe5a57335817562b20aec1a097c5c5
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild
new file mode 100644
index 000000000000..85bf337ba030
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/xyz2tex/dot2tex"
+SRC_URI="https://github.com/xyz2tex/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # https://github.com/xyz2tex/dot2tex/issues/94
+ tests/test_dot2tex.py::MultipleStatements::test_semicolon
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-setup-py-script.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Syntax failures (old-style print)
+ # Looks fixed in master: https://github.com/xyz2tex/dot2tex/commit/38aeef9615f90fe347c5c45d514eaf00b116422b
+ rm -r "${S}"/tests/experimental || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r docs/_build/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch b/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch
new file mode 100644
index 000000000000..9bda03b5a484
--- /dev/null
+++ b/dev-tex/dot2tex/files/dot2tex-2.11.3-setup-py-script.patch
@@ -0,0 +1,24 @@
+From 7b4c3e2b62a0e988db06051976260faa3889377a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Thu, 11 Apr 2024 23:11:15 +0200
+Subject: [PATCH] setup.py: Drop script "dot2tex" that collides with entrypoint
+
+---
+ setup.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index d107eed..9f50c7c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -25,7 +25,6 @@ Graphviz_, a more LaTeX friendly look and feel. This is accomplished by:
+ author_email='kjellmf@gmail.com',
+ url="https://github.com/kjellmf/dot2tex",
+ py_modules=['dot2tex.dot2tex', 'dot2tex.dotparsing'],
+- scripts=['dot2tex/dot2tex'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+--
+2.44.0
+
diff --git a/dev-tex/rubber/Manifest b/dev-tex/rubber/Manifest
index 6e87d6e1a269..a0e0d58408c3 100644
--- a/dev-tex/rubber/Manifest
+++ b/dev-tex/rubber/Manifest
@@ -1,8 +1,10 @@
+AUX rubber-1.6.4-pythontex.patch 962 BLAKE2B 6f1e2f16f326b5d3cef5e658d905d54e9ec18a816b7e6ec4eabaa54afc25afe81cd19ea586c89f6a99ee6f4eaa13e615d3e8b010ffd931ad20a147f4d9dc77a5 SHA512 e1440d82bfd2d34c9fba48e57d15c477775f473418dd9f3b0dd59fe7e8b1ebfb767bd36bdf8d8af94f4441a5b4e260acc44137e44479330758a216a4a5229ba3
DIST rubber-1.5.1.tar.gz 111812 BLAKE2B 4d08527689d669e3ac8dd6e9050fc09766bfb46c53d9923ce10efc0aaf8a62a962cb2f1c27a0e7a19a9be96710edba923d93589d816aa22305eec33fd08aa08c SHA512 ba22eeddc24b4f9abf0bf087604a4261add648877ec558b766555de09538cd20c21c8cfd9731c1421540bb2479501dd6ed066346d250c6bc981529e31efacc40
DIST rubber-1.6.0.tar.bz2 98055 BLAKE2B e3355a53f811e972b68a918393023a16c11a84035c0ea76b560df25db2d9c20f2a7c9d0d4fc3b0395c6baab5dc785840fa18a76aa0e3f480cf2c14668d61b083 SHA512 68674c27fa7c6eb2c8ec60c0a961fd2dd07822fe5ba50682e863a7dbe7d1e0ce8ebffce84a52b72a254cb9c8d446a33005715b81e43dd6266e2c247f12ebb1e6
DIST rubber-1.6.4.tar.bz2 100227 BLAKE2B 5a467f5a2a4709e7faffef1308e644900f02ca51e4fff635e7a88bb237788e60257e0e8e82ed9acac66db46f0a1e8aed1296703fefc8e1fb6e28cd38334b7d14 SHA512 dbb3896c165d63cfae8421929d0d796002fb3abcfc2ccb3fe70c4c98acc54ed48be1ad469158436dabd973bf37355c62c096ebd47c0efa7dbe58137a0a895527
EBUILD rubber-1.5.1-r1.ebuild 734 BLAKE2B 7a5830ee24b406390b747717e16a1f2c175dbb46d2d6ee2e94b86731be813bb6c3630e1921e4022e9a1f8b44f47a4cf1d8eb25abb9554bc2aa3534f671d7f1b8 SHA512 6c10c4c6846edd3c57dae36e14763ca6158eeade6f74c5f98a1b68f96469a9042127011448b705bdf5ab2eb40a841146a7cb4fbf5a5882dc96f95cb5938a9c52
EBUILD rubber-1.6.0-r1.ebuild 3043 BLAKE2B 0ad277227573c51966d2cdb38d8a6472c7730ff14883f5a8b227a1288dfef3a439d8a8e9a4d03b91a7c65dc96573a3ea5989c7eb4eb261f5ad9715bcb1f22cad SHA512 9c60c59414e01e14416e68e3564b1fb10c746624158c85b6932350a6b3580ff84fcabecb4ad2c2b216a8b15e067a99001e2df5867457ca306d10b0fc9f293a1c
+EBUILD rubber-1.6.4-r1.ebuild 3248 BLAKE2B 3e4621cc8660acc13962cf63fcc6b9d3c22aec99021dc4457e47bdeda7dab3a9babf0f09709b9b87617e4e582065f7d313453a03bd67659dd1a6cc5b2d89bfd3 SHA512 d4645ff02583bd81807d9a37a6d63e4d9c9be63dc22cc4ebdc56aded706909bb6d989efe31bc3d3b359ec9c2bc8828c5b49458a0feb28ecdb7fe52e2cdb485d6
EBUILD rubber-1.6.4.ebuild 3191 BLAKE2B ec1242306e1a44dcb053d6cba31eb4dffa8e2b945cf882111c007f7c9cca8fa53c88da0b72a61544cde93ef95a55e4b3bba15fe6220eb6275ce4c8e483f5af82 SHA512 e5285fcc84fa09682887b418bc83f0c95f459ac1048204c3800762e2dc88aabc7b591eab3481553039636db0ae8fd32cab9df1845ff653fb6e0bc0476f6372be
EBUILD rubber-9999.ebuild 3191 BLAKE2B ec1242306e1a44dcb053d6cba31eb4dffa8e2b945cf882111c007f7c9cca8fa53c88da0b72a61544cde93ef95a55e4b3bba15fe6220eb6275ce4c8e483f5af82 SHA512 e5285fcc84fa09682887b418bc83f0c95f459ac1048204c3800762e2dc88aabc7b591eab3481553039636db0ae8fd32cab9df1845ff653fb6e0bc0476f6372be
MISC metadata.xml 465 BLAKE2B 36be3746c0ec60fc3396323dd3a1e9401b754c7ab8cf893a0bee6201cf054c90e7caf337772a75c66e4e2391ad6bfeeb5f1284761a87301d09c1421513e1daa1 SHA512 5dbf081ccc11b8ce546c3939267e786f50bf47d5fab94715721a5cac841472143720748914f20079851c9fbe02ed28ddfe734357acde49de13d5106747f39128
diff --git a/dev-tex/rubber/files/rubber-1.6.4-pythontex.patch b/dev-tex/rubber/files/rubber-1.6.4-pythontex.patch
new file mode 100644
index 000000000000..2befc0e54ea5
--- /dev/null
+++ b/dev-tex/rubber/files/rubber-1.6.4-pythontex.patch
@@ -0,0 +1,30 @@
+From 9915f94d320662a719802e32763a7f4e2e4045c7 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Thu, 11 Apr 2024 20:25:55 +0200
+Subject: [PATCH] Invoke PythonTeX as "pythontex.py" in Gentoo
+
+In Gentoo:
+> /usr/bin/pythontex.py
+
+In Debian:
+> /usr/bin/pythontex
+---
+ rubber/latex_modules/pythontex.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rubber/latex_modules/pythontex.py b/rubber/latex_modules/pythontex.py
+index 3c5675b..b0bb535 100644
+--- a/rubber/latex_modules/pythontex.py
++++ b/rubber/latex_modules/pythontex.py
+@@ -20,7 +20,7 @@ class PythonTeXDep(rubber.depend.Shell):
+ def __init__(self, document):
+ self.doc = document
+ basename = self.doc.basename()
+- super().__init__(('pythontex', basename))
++ super().__init__(('pythontex.py', basename))
+ self.pythontex_files = 'pythontex-files-' + basename
+
+ pytxcode = basename + '.pytxcode'
+--
+2.44.0
+
diff --git a/dev-tex/rubber/rubber-1.6.4-r1.ebuild b/dev-tex/rubber/rubber-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..405bf11742ff
--- /dev/null
+++ b/dev-tex/rubber/rubber-1.6.4-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/latex-rubber/${PN}.git"
+else
+ # NOTE: Cannot be "PYPI_PN=latex-rubber" + "inherit pypi" due to missing tests
+ SRC_URI="https://gitlab.com/latex-rubber/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+fi
+
+DESCRIPTION="A LaTeX wrapper for automatically building documents"
+HOMEPAGE="https://gitlab.com/latex-rubber/rubber"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/latex-base"
+
+# Test dependencies:
+# - app-text/texlive-core for rubber's 'cweave' test
+# - dev-lang/R for rubber's 'knitr' test (requires knitr R library, currently disabled)
+# - dev-texlive/texlive-latexextra for rubber's 'combine' test (currently disabled)
+BDEPEND="
+ ${RDEPEND}
+ virtual/texi2dvi
+ test? (
+ app-text/ghostscript-gpl
+ app-text/texlive-core
+ dev-tex/biber
+ dev-tex/biblatex
+ dev-tex/glossaries
+ dev-tex/latex-beamer
+ $(python_gen_cond_dep 'dev-tex/pythontex[${PYTHON_USEDEP}]')
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pstricks
+ media-gfx/asymptote
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.4-pythontex.patch
+)
+
+pkg_setup() {
+ # https://bugs.gentoo.org/727996
+ export VARTEXFONTS="${T}"/fonts
+}
+
+python_test() {
+ cd tests || die
+
+ # Disable the broken 'combine' test as it uses the 'combine' as a
+ # latex package when it is only a document class (probably only in
+ # newer versions of combine). Also note that this tests works
+ # under debian 'buster'. TODO: Look into potential modifications
+ # done by debian.
+ touch combine/disable || die
+
+ # This test does not work under Gentoo nor Debian 'buster'.
+ # TODO: Investigate why it does not work.
+ touch cweb-latex/disable || die
+
+ # TODO: Investigate why the following are failing.
+ touch fig2dev-dvi/disable || die
+ touch fig2dev-path/disable || die
+ touch fig2dev-path-inplace/disable || die
+ touch fig2dev-path-into/disable || die
+ touch graphicx-dotted-files/disable || die
+ touch hooks-input-file/disable || die
+ touch knitr/disable || die
+
+ # Even tough metapost is available, those tests fail on Gentoo
+ # (while they succeed on Debian 'buster').
+ # TODO: Determine why.
+ # ERROR:mpost:I can't read MetaPost's log file, this is wrong.
+ touch metapost/disable || die
+ # expected error message not reported by Rubber
+ touch metapost-error/disable || die
+ # ERROR:mpost:I can't read MetaPost's log file, this is wrong.
+ touch metapost-input/disable || die
+
+ ./run.sh * || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ local my_install_args=(
+ --mandir="${EPREFIX}/usr/share/man"
+ --infodir="${EPREFIX}/usr/share/info"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ )
+
+ distutils-r1_python_install "${my_install_args[@]}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Fix file misplacements
+ dodir /usr/share/man/fr
+ mv "${D}"/usr/share/{doc/man-fr,man/fr/man1} || die
+ mv "${D}"/usr/share/{doc/man-en,man/man1} || die
+ dodir /usr/share/doc/${P}
+ mv "${D}"/usr/share/doc/{rubber.*,${PF}/} || die
+}