summaryrefslogtreecommitdiff
path: root/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild')
-rw-r--r--dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..76062cedbcc9
--- /dev/null
+++ b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test_units"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ )
+"