summaryrefslogtreecommitdiff
path: root/dev-ruby/whole_history_rating
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-ruby/whole_history_rating
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-ruby/whole_history_rating')
-rw-r--r--dev-ruby/whole_history_rating/Manifest4
-rw-r--r--dev-ruby/whole_history_rating/metadata.xml21
-rw-r--r--dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild26
-rw-r--r--dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild31
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-ruby/whole_history_rating/Manifest b/dev-ruby/whole_history_rating/Manifest
new file mode 100644
index 000000000000..559eb17778da
--- /dev/null
+++ b/dev-ruby/whole_history_rating/Manifest
@@ -0,0 +1,4 @@
+DIST whole_history_rating-0.1.2.gem 9728 BLAKE2B 506354634ab0390b7805e31ee1982309a903000b69a20992cfa53196da8e685b4ea1c89df7ed96ddd4fc5c8a8974d23dc48625d3e93ebbc09121b32e0ab7216e SHA512 4ee9a3340a5bbe1a0250b469c1210663ff226a1884d13729e169d2c04ef57c615bef117a641d6ac3b29b5d72147009149c291e1f7ad8c4c8028ad3e6fb44c56c
+EBUILD whole_history_rating-0.1.2-r1.ebuild 485 BLAKE2B 78dfb6fa01b34625b51383a3554a2674f6955328ac37100968660b7971bc51da2783a12923916dbbf6ff15fc4dc646cebbb63eb00a2a34aa6b2454521330ae54 SHA512 9bf22c6960f631a5096240d3c8010e884d9e20a63dbde964c0f3f8e8f223c54b2da94af624830a88c6b5e8549cdb78c815ef1f370c2316385f4ad8744844d93f
+EBUILD whole_history_rating-0.1.2.ebuild 635 BLAKE2B ae6ce4c361672ca9534a3c502f60b429be2a221be9f9f61a4ca5646e7885b5c72cbe0044c52dbe421801d861f9a3736ef9f6d0d851f038445fd4347385019d89 SHA512 d1e37b9531e545038d28b6d1e929eb66de49da5d526347088e4ad74b5f70916da8292c335a9ab154c4a34ed718d37492b353df1c1ef0ebd9e2d6a76356f64a8a
+MISC metadata.xml 914 BLAKE2B 68d087fab3e07ad73034704c9c7907ce67a34fe7ed22beb9c4bf0138b22c799aa97becaacc6d331fcff7a8c0a7b496edbffbd8650051a9604fa5e845bedb492c SHA512 adc3664334965a599fbf0b0ee8b8dbadfce12d2c38d0f94acdd924e1feca5ed549458be20aaabef79436f92ae772d2b40e25f559319ba9a632c2a77fc740dfc5
diff --git a/dev-ruby/whole_history_rating/metadata.xml b/dev-ruby/whole_history_rating/metadata.xml
new file mode 100644
index 000000000000..b39a11c910de
--- /dev/null
+++ b/dev-ruby/whole_history_rating/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Ruby project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">goshrine/whole_history_rating</remote-id>
+ </upstream>
+ <longdescription lang="en">This gem provides a library and executables that take as input as set of games and output a set of skill rankings for the players of those games. The algorithm is a version of Remi Coulom's Whole-History Rating modified to support handicaps, and implemented in Ruby.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..76062cedbcc9
--- /dev/null
+++ b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test_units"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ )
+"
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild
new file mode 100644
index 000000000000..a9746bb09ab3
--- /dev/null
+++ b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ )
+"
+
+all_ruby_prepare (){
+ sed -i 's/git ls-files/ls -1/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ default
+}