summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-platform
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /dev-ruby/tty-platform
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'dev-ruby/tty-platform')
-rw-r--r--dev-ruby/tty-platform/tty-platform-0.2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/tty-platform/tty-platform-0.2.1.ebuild b/dev-ruby/tty-platform/tty-platform-0.2.1.ebuild
new file mode 100644
index 000000000000..e30b88aa6f9c
--- /dev/null
+++ b/dev-ruby/tty-platform/tty-platform-0.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Query methods for detecting different operating systems"
+HOMEPAGE="https://github.com/piotrmurach/tty-platform"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}