summaryrefslogtreecommitdiff
path: root/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
commitf660c6de84558324d784218831d8f0782ee41e2e (patch)
treec1f2aa79617d0ceaaff49d71603abc386aae2c37 /dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
parent95461df035e3867364495f065e5e805bf629b2d7 (diff)
gentoo resync : 27.10.2021
Diffstat (limited to 'dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild')
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..a4f065842ad0
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}