summaryrefslogtreecommitdiff
path: root/dev-ruby/text-hyphen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-27 22:41:01 +0100
commitf660c6de84558324d784218831d8f0782ee41e2e (patch)
treec1f2aa79617d0ceaaff49d71603abc386aae2c37 /dev-ruby/text-hyphen
parent95461df035e3867364495f065e5e805bf629b2d7 (diff)
gentoo resync : 27.10.2021
Diffstat (limited to 'dev-ruby/text-hyphen')
-rw-r--r--dev-ruby/text-hyphen/Manifest1
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/Manifest b/dev-ruby/text-hyphen/Manifest
index e25390c42991..237c15d347ba 100644
--- a/dev-ruby/text-hyphen/Manifest
+++ b/dev-ruby/text-hyphen/Manifest
@@ -1,3 +1,4 @@
DIST text-hyphen-1.4.1.gem 751616 BLAKE2B 4a6d6a9b430c2dee2a486dde9f49405b98bc32fe8f96448c0cbe8d55f416c4e4e9bef5ae3adb57576dee6fa285680fc57b958cb279786872c8d95282cbf72e73 SHA512 4a6667aff01e56afce79302f46d0afdbf9c965ad80dbf9a7266a213143e6b6bc2cb00092d26900286bf72a700e47be6b0860cfdf87fa2856477db02261f9ef3d
EBUILD text-hyphen-1.4.1-r2.ebuild 716 BLAKE2B e99e0c9d2cdd60ef4b21e00807717fce22d81d775c3fcf287f37a9e751dfcdb9382ebf6633e36317be5cc9d19214aeeff922a0eb44a7ec9c2518a3536a547769 SHA512 05ead91f69341923de9634d7c9625ca8a93a347b859572b86112eb3948feb1617b74148263e2ccd17f8ad428dc2333c11072addac83cb45f69a4634605dadc16
+EBUILD text-hyphen-1.4.1-r3.ebuild 682 BLAKE2B 217a5d866362214765ae59905bee0ddedccd1e4a0d69d68927bf2cb238e277e1b4eada024b75836265735ddaa092f35fdc98b1921099dbd23f331787e610b559 SHA512 b581d6ba54cadce8e6bd81c7003ef9a1bd97f439110be52237b0dba4493c161cfacd13015109c6a92606db076ff3f9b3d712c5128725d8427f8c17c7f01e442c
MISC metadata.xml 252 BLAKE2B 77e9556ac1d210367a95f4c47816618b685c707cf01d1543d988338e14794fb9ccfb9976ebd11f389db618616d91ee024d8e46dc3a1a356ba7a017a7796b44d1 SHA512 0a970a16d73747993198dd301a3127cef7e65a9f46816b40ca149669ba617826c1d81bac1e5ecf93d16079922964923d37301cd8160f22c823c1ec3b79ee56f1
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..a4f065842ad0
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}