summaryrefslogtreecommitdiff
path: root/dev-ruby/pathutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-ruby/pathutil
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-ruby/pathutil')
-rw-r--r--dev-ruby/pathutil/Manifest2
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.2.ebuild9
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-ruby/pathutil/Manifest b/dev-ruby/pathutil/Manifest
index 3992ec3c205c..5ac6a0af16af 100644
--- a/dev-ruby/pathutil/Manifest
+++ b/dev-ruby/pathutil/Manifest
@@ -1,3 +1,3 @@
DIST pathutil-0.16.2.tar.gz 26079 BLAKE2B 5a9d1dac1f1171ee6bc447725c04883cb56a9071927f3e0fdbcb9754345ac77a6609533a1308a411cb22658caeb2a4bed49225923af109bca288cfb3aeb3d669 SHA512 d06daf365b94dacd33966f3928a53f0f00d2fca7b9f6348a7efd2b55ab5ba937459e5bd78fde241f30749a1ae55e4ae3ba1ed8945b5333464e7d3ce9666cd054
-EBUILD pathutil-0.16.2.ebuild 932 BLAKE2B 3dd5bae361294a24ad59e5b29ec445810d638f57253f65c0d37df02f5997ba6c2358d7dc7a853699979f6c6011f283cf1673bf3d1bad2956554fca4a2e900ef8 SHA512 df84184e6f8f87cc383042cd9808e82ed83eb48dd08cd444596b1e9a5b468880d7efdbc5c145567d2f59941668c420a3aafcbe75ef6a814aad4125121f30174c
+EBUILD pathutil-0.16.2.ebuild 1084 BLAKE2B a16bc82dee4da29e569c7cbcd42767ddae2c725fc55994349b171c5a6f950d4590f7d51bdaf86fe583021fa859bd5e292be4edacfeb5b7850db968b241c17475 SHA512 042d823153f28c10af50c0d3b5e5445ac213028b5cb0762a9064aecb537d6ba5ea030ac2211e8a7257f56fd6adbccc5e76c4319f8ec2b2d1e6fcb41b0e06e5c5
MISC metadata.xml 397 BLAKE2B 5d92c61c8d5bd93ada1cfb8cf312518568a379c6fec784480adfe804458b6de4b05d22886dcc4df14dc4ceb196cac22d485b8748533c94179c82c26fb71ef1df SHA512 ad03cd42ae59368a0642c46f3ae06ddbb14e003ebaeb79e0a93ff9212ba9fc16bcfb20e90f9f5be49cd8e79a80355bcccbfbbdc44845df0d9b678a2c4a20debe
diff --git a/dev-ruby/pathutil/pathutil-0.16.2.ebuild b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
index c1658c8c53ed..c12850513c72 100644
--- a/dev-ruby/pathutil/pathutil-0.16.2.ebuild
+++ b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_GEMSPEC="Gem.gemspec"
inherit ruby-fakegem
DESCRIPTION="Like Pathname but a little less insane"
-HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutils"
+HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutil"
SRC_URI="https://github.com/envygeeks/pathutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -31,4 +31,7 @@ all_ruby_prepare() {
-e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json"' \
spec/rspec/helper.rb || die
rm -f spec/support/coverage.rb || die
+
+ # Avoid spec failing with newer rspec versions, bug 775383
+ sed -i -e '/should chdir before running the glob/apending' spec/tests/lib/pathutil_spec.rb || die
}