summaryrefslogtreecommitdiff
path: root/dev-ruby/pathutil/pathutil-0.16.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pathutil/pathutil-0.16.2.ebuild')
-rw-r--r--dev-ruby/pathutil/pathutil-0.16.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-ruby/pathutil/pathutil-0.16.2.ebuild b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
index c1658c8c53ed..c12850513c72 100644
--- a/dev-ruby/pathutil/pathutil-0.16.2.ebuild
+++ b/dev-ruby/pathutil/pathutil-0.16.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_GEMSPEC="Gem.gemspec"
inherit ruby-fakegem
DESCRIPTION="Like Pathname but a little less insane"
-HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutils"
+HOMEPAGE="https://rubygems.org/gems/pathutil https://github.com/envygeeks/pathutil"
SRC_URI="https://github.com/envygeeks/pathutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -31,4 +31,7 @@ all_ruby_prepare() {
-e '1irequire "pathname"; require "tempfile"; require "tmpdir"; require "json"' \
spec/rspec/helper.rb || die
rm -f spec/support/coverage.rb || die
+
+ # Avoid spec failing with newer rspec versions, bug 775383
+ sed -i -e '/should chdir before running the glob/apending' spec/tests/lib/pathutil_spec.rb || die
}