summaryrefslogtreecommitdiff
path: root/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/nanotest/nanotest-0.9.4.1.ebuild')
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
new file mode 100644
index 000000000000..52b03ad3f660
--- /dev/null
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extremely mynymal test framework"
+HOMEPAGE="https://github.com/mynyml/nanotest"
+LICENSE="MIT"
+
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_nanotest.rb || die
+}